summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/libchart/libchart-1.3.ebuild')
-rw-r--r--dev-php/libchart/libchart-1.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-php/libchart/libchart-1.3.ebuild b/dev-php/libchart/libchart-1.3.ebuild
new file mode 100644
index 000000000000..ff816e5809e0
--- /dev/null
+++ b/dev-php/libchart/libchart-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Easy-to-use chart creation library for PHP"
+HOMEPAGE="http://naku.dohcrew.com/libchart https://github.com/naku/libchart"
+SRC_URI="https://github.com/naku/${PN}/releases/download/release/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3 BitstreamVera"
+KEYWORDS="~amd64 ~x86"
+SLOT=0
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="dev-lang/php:*[gd,truetype]"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ dodoc "${PN}"/{ChangeLog,README}
+
+ if use examples ; then
+ # PHP won't run a compressed example...
+ docompress -x "/usr/share/doc/${PF}/demo"
+ dodoc -r demo/
+ fi
+
+ insinto "/usr/share/php/${PN}"
+ doins -r "${PN}"/{classes,fonts,images}
+}