summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/clang-python/clang-python-20.0.0_pre20241207.ebuild')
-rw-r--r--dev-python/clang-python/clang-python-20.0.0_pre20241207.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/clang-python/clang-python-20.0.0_pre20241207.ebuild b/dev-python/clang-python/clang-python-20.0.0_pre20241207.ebuild
index 7f3de6814bbb..ac0a5d029db5 100644
--- a/dev-python/clang-python/clang-python-20.0.0_pre20241207.ebuild
+++ b/dev-python/clang-python/clang-python-20.0.0_pre20241207.ebuild
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
inherit llvm.org python-r1
-DESCRIPTION="Python bindings for sys-devel/clang"
+DESCRIPTION="Python bindings for llvm-core/clang"
HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
@@ -18,9 +18,9 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
DEPEND="
- >=sys-devel/clang-${PV}:*
+ >=llvm-core/clang-${PV}:*
!sys-devel/llvm:0[clang(-),python(-)]
- !sys-devel/clang:0[python(-)]
+ !llvm-core/clang:0[python(-)]
"
RDEPEND="
${DEPEND}
@@ -29,7 +29,7 @@ RDEPEND="
BDEPEND="
${PYTHON_DEPS}
test? (
- sys-devel/clang:${LLVM_MAJOR}
+ llvm-core/clang:${LLVM_MAJOR}
)
"