summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/columnize')
-rw-r--r--dev-python/columnize/Manifest2
-rw-r--r--dev-python/columnize/columnize-0.3.5-r1.ebuild25
-rw-r--r--dev-python/columnize/columnize-0.3.8.ebuild27
-rw-r--r--dev-python/columnize/metadata.xml10
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/columnize/Manifest b/dev-python/columnize/Manifest
new file mode 100644
index 000000000000..a63e88ec0613
--- /dev/null
+++ b/dev-python/columnize/Manifest
@@ -0,0 +1,2 @@
+DIST columnize-0.3.5.tar.gz 8838 SHA256 b5793700ef089584681ae703b4bb3b9a31be57eff09021162048d79ef480af68 SHA512 7df49fcb52e2eafd47ca0dad4529117c4181b3306f984c02bf470bdec427bd92c92680caf91398a918bee17c30d4d5a9accd1999241daa1e298d0016e3257d08 WHIRLPOOL 18ce0c5fc16832a6db2dddfac628798018e995f185ef4bceccfdafc4cd3a97d17807bd5f0e36de6e36feaeb3dbed1dacf558f28678f4dc7efc547c7b275ebe9b
+DIST columnize-0.3.8.tar.gz 9464 SHA256 c94d9173e0cb34682b1f63d2cea5924a522ef588981a7baa6a4c08a785808555 SHA512 4bcf232f2c8057eb8a77ab8c140a69c15831291da7476032f8b257774d9f945009bdd2d6295e98dceddcf9943b5e0b5e8eeab6bd229d2ae126f11c421b2e1dae WHIRLPOOL d21410955c3d461246cc7e02fd09277a9071017a287a23ec0d36cbeeef273b8bf4d4be289472f9882bede39afa552934a610bbe2e559929a34963eedad3972dd
diff --git a/dev-python/columnize/columnize-0.3.5-r1.ebuild b/dev-python/columnize/columnize-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..69dc4efd1b02
--- /dev/null
+++ b/dev-python/columnize/columnize-0.3.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Format a simple (i.e. not nested) list into aligned columns"
+HOMEPAGE="http://code.google.com/p/pycolumnize/ http://pypi.python.org/pypi/columnize"
+SRC_URI="http://pycolumnize.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed"
+}
diff --git a/dev-python/columnize/columnize-0.3.8.ebuild b/dev-python/columnize/columnize-0.3.8.ebuild
new file mode 100644
index 000000000000..a88502073542
--- /dev/null
+++ b/dev-python/columnize/columnize-0.3.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format a simple (i.e. not nested) list into aligned columns"
+HOMEPAGE="https://github.com/rocky/pycolumnize http://pypi.python.org/pypi/columnize"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/backports-shutil_get_terminal_size[$(python_gen_usedep 'python2*')]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}
diff --git a/dev-python/columnize/metadata.xml b/dev-python/columnize/metadata.xml
new file mode 100644
index 000000000000..6514190e88b4
--- /dev/null
+++ b/dev-python/columnize/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="google-code">pycolumnize</remote-id>
+ <remote-id type="pypi">columnize</remote-id>
+ <remote-id type="github">rocky/pycolumnize</remote-id>
+ </upstream>
+</pkgmetadata>