summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/commonmark/commonmark-0.7.5.ebuild')
-rw-r--r--dev-python/commonmark/commonmark-0.7.5.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/commonmark/commonmark-0.7.5.ebuild b/dev-python/commonmark/commonmark-0.7.5.ebuild
deleted file mode 100644
index a957191cbbdb..000000000000
--- a/dev-python/commonmark/commonmark-0.7.5.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-MY_PN=CommonMark
-MY_P=${MY_PN}-${PV}
-DESCRIPTION="Python parser for the CommonMark Markdown spec"
-HOMEPAGE="https://github.com/rtfd/CommonMark-py"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/future[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/hypothesis-3.7.1[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-S=${WORKDIR}/${MY_P}
-
-python_test() {
- PYTHONIOENCODING='utf8' \
- esetup.py test
-}
-
-src_prepare() {
- default
- # Fix file collision with app-text/cmark, see bug #627034
- sed -i -e "s:'cmark\( = CommonMark.cmark\:main'\):'cmark.py\1:" \
- setup.py || die
-}
-
-pkg_postinst() {
- ewarn "/usr/bin/cmark has been renamed to /usr/bin/cmark.py due file"
- ewarn "collision with app-text/cmark (see bug #627034)"
-}