summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild')
-rw-r--r--dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild b/dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild
new file mode 100644
index 000000000000..e19a0dbec2a3
--- /dev/null
+++ b/dev-python/django-recaptcha/django-recaptcha-1.0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Django recaptcha form field/widget app"
+HOMEPAGE="http://github.com/praekelt/django-recaptcha http://pypi.python.org/pypi/django-recaptcha"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/praekelt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ >=dev-python/django-setuptest-0.1[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}