summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/paver/paver-1.2.4.ebuild')
-rw-r--r--dev-python/paver/paver-1.2.4.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/paver/paver-1.2.4.ebuild b/dev-python/paver/paver-1.2.4.ebuild
index 21964a1e9c07..f559621873cd 100644
--- a/dev-python/paver/paver-1.2.4.ebuild
+++ b/dev-python/paver/paver-1.2.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,8 +25,12 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+python_prepare_all() {
+ # https://github.com/paver/paver/issues/143#issuecomment-103943327
+ find paver/tests -name '*.pyc' -delete || die
+ distutils-r1_python_prepare_all
+}
+
python_test() {
- # There is a regression in tests
- # https://github.com/paver/paver/issues/143
nosetests || die "Testing failed with ${EPYTHON}"
}