summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyutil')
-rw-r--r--dev-python/pyutil/Manifest1
-rw-r--r--dev-python/pyutil/metadata.xml24
-rw-r--r--dev-python/pyutil/pyutil-2.0.0.ebuild27
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pyutil/Manifest b/dev-python/pyutil/Manifest
new file mode 100644
index 000000000000..b3dcac6f8c8e
--- /dev/null
+++ b/dev-python/pyutil/Manifest
@@ -0,0 +1 @@
+DIST pyutil-2.0.0.tar.gz 125079 SHA256 0ca95cb85843c5b09f7b65b5bd6c42d1940e19667b076620585ac45abe4f4fbb SHA512 3704c028fdc3894ae635dabd2bace1af1e805f4158dc6d67eac0c38fa8e7959cd093ad39cb2f539e59dd74e957947464cc8c7aed727835e127311062ed27e60b WHIRLPOOL e8fcdbed85d324732b8216224167f7920cfaf557238f3f70d22ee9afc96d1f72731164b55e1f385b60b0f77f8f42faf4b4db3e3eb55917c92ad004ab7613d447
diff --git a/dev-python/pyutil/metadata.xml b/dev-python/pyutil/metadata.xml
new file mode 100644
index 000000000000..d1ce02ea2757
--- /dev/null
+++ b/dev-python/pyutil/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ pyutil -- a library of useful Python functions and classes
+ ==========================================================
+
+ Many of these utilities (or their ancestors) were developed for
+ the Mojo
+ Nation, Mnet, Allmydata.com "Mountain View", Tahoe-LAFS, or
+ SimpleGeo's
+ products. (In the case where the code was developed for a
+ for-profit
+ company, the copyright holder donated the pyutil code to the
+ public under
+ these open source licences.)
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyutil</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyutil/pyutil-2.0.0.ebuild b/dev-python/pyutil/pyutil-2.0.0.ebuild
new file mode 100644
index 000000000000..8a6f3c4ea462
--- /dev/null
+++ b/dev-python/pyutil/pyutil-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A collection of utilities for Python programmers"
+HOMEPAGE="https://tahoe-lafs.org/trac/pyutil https://pypi.python.org/pypi/pyutil"
+SRC_URI="mirror://pypi/p/pyutil/pyutil-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+
+ rm -rf "${ED%/}"/usr/share/doc/${PN}
+}