summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/repoze-sphinx-autointerface')
-rw-r--r--dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild (renamed from dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8-r1.ebuild)12
1 files changed, 11 insertions, 1 deletions
diff --git a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8-r1.ebuild b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
index 3423ea0ea701..02e4c048c909 100644
--- a/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8-r1.ebuild
+++ b/dev-python/repoze-sphinx-autointerface/repoze-sphinx-autointerface-0.8.ebuild
@@ -12,13 +12,13 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Sphinx extension: auto-generates API docs from Zope interfaces"
HOMEPAGE="https://pypi.org/project/repoze.sphinx.autointerface/"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
LICENSE="repoze"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="
+ dev-python/namespace-repoze[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
"
@@ -26,6 +26,16 @@ DEPEND="
${RDEPEND}
"
+S=${WORKDIR}/${MY_P}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install the namespace (it's the only subpackage)
+ python_moduleinto repoze.sphinx
+ python_domodule repoze/sphinx/__init__.py
+}
+
python_install_all() {
distutils-r1_python_install_all