summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/abi-compliance-checker/abi-compliance-checker-9999.ebuild')
-rw-r--r--dev-util/abi-compliance-checker/abi-compliance-checker-9999.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/dev-util/abi-compliance-checker/abi-compliance-checker-9999.ebuild b/dev-util/abi-compliance-checker/abi-compliance-checker-9999.ebuild
index d9351e95a936..42214fbbaed1 100644
--- a/dev-util/abi-compliance-checker/abi-compliance-checker-9999.ebuild
+++ b/dev-util/abi-compliance-checker/abi-compliance-checker-9999.ebuild
@@ -1,24 +1,26 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit git-r3
+EAPI=8
DESCRIPTION="A tool for checking backward compatibility of a C/C++ library"
HOMEPAGE="http://ispras.linuxbase.org/index.php/ABI_compliance_checker"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/lvc/${PN}.git"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/lvc/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/lvc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
-IUSE=""
-DEPEND="dev-lang/perl"
-RDEPEND="${DEPEND}
+RDEPEND="
dev-util/abi-dumper
- dev-util/ctags"
+ dev-util/ctags
+"
+BDEPEND="dev-lang/perl"
src_install() {
dodir /usr