summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/its4')
-rw-r--r--dev-util/its4/Manifest1
-rw-r--r--dev-util/its4/its4-1.1.1.ebuild41
-rw-r--r--dev-util/its4/metadata.xml14
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/its4/Manifest b/dev-util/its4/Manifest
new file mode 100644
index 000000000000..c42070e059d3
--- /dev/null
+++ b/dev-util/its4/Manifest
@@ -0,0 +1 @@
+DIST its4-1.1.1.tgz 59759 RMD160 7f3fef7b7f5c6cf4f7e203481a44957bcf74e606 SHA1 f95711fad1a10ca127514132db04791a01088d77 SHA256 386ca694c969108863f3e5c0571ea8c5cbdc288dd13e12ba573a592844682df4
diff --git a/dev-util/its4/its4-1.1.1.ebuild b/dev-util/its4/its4-1.1.1.ebuild
new file mode 100644
index 000000000000..6a988f3f49d0
--- /dev/null
+++ b/dev-util/its4/its4-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="ITS4: Software Security Tool"
+HOMEPAGE="http://www.cigital.com/its4/"
+SRC_URI="${P}.tgz"
+LICENSE="ITS4"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE=""
+DEPEND="sys-devel/gcc"
+RESTRICT="mirror fetch"
+#RDEPEND=""
+S="${WORKDIR}/${PN}"
+
+pkg_nofetch() {
+ einfo "Please visit ${HOMEPAGE} to download the source, and place it in"
+ einfo "${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e 's,iostream.h,iostream,g'\
+ "${S}"/configure
+}
+
+src_compile() {
+ # WARNING
+ # non-standard configure
+ # do NOT use econf
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share/its4 || die "configure failed"
+ emake OPTIMIZATION="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ # WARNING
+ # non-standard, do NOT use einstall or 'make install DESTDIR=...'
+ make install INSTALL_BINDIR="${D}/usr/bin" INSTALL_MANDIR="${D}/usr/share/man" INSTALL_DATADIR="${D}/usr/share/its4" || die "install failed"
+}
diff --git a/dev-util/its4/metadata.xml b/dev-util/its4/metadata.xml
new file mode 100644
index 000000000000..8d7b356d6845
--- /dev/null
+++ b/dev-util/its4/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<longdescription>
+ITS4 scans source code, looking for function calls that are potentially
+dangerous. For some calls, ITS4 tries to perform some code analysis to
+determine how risky the call is. In each case, ITS4 provides a problem report,
+including a short description of the potential problem and suggestions on how
+to fix the code.
+</longdescription>
+</pkgmetadata>