summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kdevelop')
-rw-r--r--dev-util/kdevelop/files/kdevelop-5.0.0-fix-cpp.patch47
-rw-r--r--dev-util/kdevelop/files/kdevelop-ninja-optional.patch11
-rw-r--r--dev-util/kdevelop/kdevelop-5.0.0.ebuild99
-rw-r--r--dev-util/kdevelop/metadata.xml2
4 files changed, 159 insertions, 0 deletions
diff --git a/dev-util/kdevelop/files/kdevelop-5.0.0-fix-cpp.patch b/dev-util/kdevelop/files/kdevelop-5.0.0-fix-cpp.patch
new file mode 100644
index 000000000000..9b15fe954825
--- /dev/null
+++ b/dev-util/kdevelop/files/kdevelop-5.0.0-fix-cpp.patch
@@ -0,0 +1,47 @@
+From: Milian Wolff <mail@milianw.de>
+Date: Mon, 22 Aug 2016 10:47:26 +0000
+Subject: Fix compile
+X-Git-Url: http://quickgit.kde.org/?p=kdevelop.git&a=commitdiff&h=f4b5b7538be64328cf8462ee438caaac6c0907aa
+---
+Fix compile
+
+BUG: 367659
+---
+
+
+--- a/languages/cpp/cppduchain/cppducontext.cpp
++++ b/languages/cpp/cppduchain/cppducontext.cpp
+@@ -39,7 +39,8 @@
+ REGISTER_DUCHAIN_ITEM_WITH_DATA(CppNormalDUContext, DUContextData);
+
+ template<>
+-QWidget* CppDUContext<TopDUContext>::createNavigationWidget( Declaration* decl, TopDUContext* topContext, const QString& htmlPrefix, const QString& htmlSuffix ) const {
++QWidget* CppDUContext<TopDUContext>::createNavigationWidget(Declaration* decl, TopDUContext* topContext, const QString& htmlPrefix, const QString& htmlSuffix,
++ AbstractNavigationWidget::DisplayHints /*hints*/) const {
+ if( decl == 0 ) {
+ Path path( url().str() );
+ IncludeItem i;
+@@ -55,7 +56,8 @@
+ }
+
+ template<>
+-QWidget* CppDUContext<DUContext>::createNavigationWidget(Declaration* decl, TopDUContext* topContext, const QString& htmlPrefix, const QString& htmlSuffix) const {
++QWidget* CppDUContext<DUContext>::createNavigationWidget(Declaration* decl, TopDUContext* topContext, const QString& htmlPrefix, const QString& htmlSuffix,
++ AbstractNavigationWidget::DisplayHints /*hints*/) const {
+ if( decl == 0 ) {
+ if( owner() )
+ return new NavigationWidget( DeclarationPointer(owner()), TopDUContextPointer(topContext ? topContext : this->topContext()), htmlPrefix, htmlSuffix );
+
+--- a/languages/cpp/cppduchain/cppducontext.h
++++ b/languages/cpp/cppduchain/cppducontext.h
+@@ -652,7 +652,8 @@
+ return instantiateDeclarationAndContext( surroundingContext, source, this, info, 0, 0 );
+ }
+
+- virtual QWidget* createNavigationWidget(Declaration* decl, TopDUContext* topContext, const QString& htmlPrefix, const QString& htmlSuffix) const override;
++ virtual QWidget* createNavigationWidget(Declaration* decl, TopDUContext* topContext, const QString& htmlPrefix, const QString& htmlSuffix,
++ KDevelop::AbstractNavigationWidget::DisplayHints hints = KDevelop::AbstractNavigationWidget::NoHints) const override;
+
+ enum {
+ Identity = BaseContext::Identity + 50
+
diff --git a/dev-util/kdevelop/files/kdevelop-ninja-optional.patch b/dev-util/kdevelop/files/kdevelop-ninja-optional.patch
new file mode 100644
index 000000000000..a60da91df6dc
--- /dev/null
+++ b/dev-util/kdevelop/files/kdevelop-ninja-optional.patch
@@ -0,0 +1,11 @@
+diff --git a/projectbuilders/CMakeLists.txt b/projectbuilders/CMakeLists.txt
+index 80d7866..825ca8b 100644
+--- a/projectbuilders/CMakeLists.txt
++++ b/projectbuilders/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ add_subdirectory(makebuilder)
+-add_subdirectory(ninjabuilder)
++ecm_optional_add_subdirectory(ninjabuilder)
+ ecm_optional_add_subdirectory(cmakebuilder)
+ if (KDevelop-PG-Qt_FOUND)
+ ecm_optional_add_subdirectory(qmakebuilder)
diff --git a/dev-util/kdevelop/kdevelop-5.0.0.ebuild b/dev-util/kdevelop/kdevelop-5.0.0.ebuild
new file mode 100644
index 000000000000..c5338246caba
--- /dev/null
+++ b/dev-util/kdevelop/kdevelop-5.0.0.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_BRANCH="5.0"
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional-recursive"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Integrated Development Environment, supporting KF5/Qt, C/C++ and much more"
+LICENSE="GPL-2 LGPL-2"
+IUSE="+cxx +cmake +gdbui +ninja okteta +plasma +qmake qthelp"
+[[ ${KDE_BUILD_TYPE} = release ]] && KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep threadweaver)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwebkit)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ >=dev-util/kdevplatform-${PV}:5
+ x11-misc/shared-mime-info
+ cxx? ( >=sys-devel/clang-3.5.0 )
+ gdbui? ( $(add_plasma_dep libksysguard) )
+ okteta? ( $(add_kdeapps_dep okteta) )
+ plasma? (
+ $(add_frameworks_dep krunner)
+ $(add_frameworks_dep plasma)
+ )
+ qmake? ( dev-util/kdevelop-pg-qt:5 )
+ qthelp? ( $(add_qt_dep qthelp) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep qtconcurrent)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kapptemplate)
+ $(add_kdeapps_dep kio-extras)
+ >=sys-devel/gdb-7.0[python]
+ ninja? ( dev-util/ninja )
+ !dev-util/kdevelop:4
+ !dev-util/kdevelop-clang
+ !dev-util/kdevelop-qmake
+ !dev-util/kdevelop-qmljs
+ !<kde-apps/kapptemplate-16.04.0
+"
+
+RESTRICT+=" test"
+# see bug 366471
+
+PATCHES=(
+ "${FILESDIR}/${PN}-ninja-optional.patch"
+ "${FILESDIR}/${P}-fix-cpp.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLEGACY_CPP_SUPPORT=$(usex !cxx)
+ -DBUILD_cpp=OFF
+ -DBUILD_cmake=$(usex cmake)
+ -DBUILD_cmakebuilder=$(usex cmake)
+ $(cmake-utils_use_find_package gdbui KF5SysGuard)
+ -DBUILD_executeplasmoid=$(usex plasma)
+ $(cmake-utils_use_find_package plasma KF5Plasma)
+ -DBUILD_ninjabuilder=$(usex ninja)
+ $(cmake-utils_use_find_package okteta OktetaKastenControllers)
+ $(cmake-utils_use_find_package qmake KDevelop-PG-Qt)
+ -DBUILD_qthelp=$(usex qthelp)
+ )
+
+ kde5_src_configure
+}
diff --git a/dev-util/kdevelop/metadata.xml b/dev-util/kdevelop/metadata.xml
index e60001d7d062..a83234df73da 100644
--- a/dev-util/kdevelop/metadata.xml
+++ b/dev-util/kdevelop/metadata.xml
@@ -8,7 +8,9 @@
<use>
<flag name="cmake">Enable support for CMake build system</flag>
<flag name="gdbui">Enable GUI for attaching GDB to a running process</flag>
+ <flag name="ninja">Enable support for Ninja build system</flag>
<flag name="okteta">Enable hex editor plugin</flag>
+ <flag name="qmake">Enable support for QMake build system</flag>
<flag name="qthelp">Enable support for QtHelp documentation browsing</flag>
</use>
</pkgmetadata>