summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kscope/kscope-1.9.4-r2.ebuild')
-rw-r--r--dev-util/kscope/kscope-1.9.4-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/kscope/kscope-1.9.4-r2.ebuild b/dev-util/kscope/kscope-1.9.4-r2.ebuild
new file mode 100644
index 000000000000..f433dafdf7ce
--- /dev/null
+++ b/dev-util/kscope/kscope-1.9.4-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib qt4-r2
+
+DESCRIPTION="Source Editing Environment based on Qt"
+HOMEPAGE="http://kscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kscope/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/qscintilla:=[qt4(-)]"
+DEPEND="${RDEPEND}"
+
+DOCS="ChangeLog"
+
+src_prepare() {
+ sed -i -e "s:/usr/local:/usr:" config || die
+ sed -i \
+ -e "s:\$\${QSCI_ROOT_PATH}/include/Qsci:& /usr/include/qt4/Qsci:g" \
+ -e "s:\$\${QSCI_ROOT_PATH}/lib:& -L/usr/lib/qt4:g" \
+ -e "s:/lib:/$(get_libdir):g" \
+ app/app.pro core/core.pro cscope/cscope.pro editor/editor.pro \
+ || die
+
+ # fix build failure with parallel make
+ echo "CONFIG += ordered" >> kscope.pro
+
+ epatch "${FILESDIR}/${P}"-{actions,underlinking}.patch
+}