summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rocm_bandwidth_test')
-rw-r--r--dev-util/rocm_bandwidth_test/Manifest1
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/Manifest b/dev-util/rocm_bandwidth_test/Manifest
index c22630347d05..1b1fea2f1adf 100644
--- a/dev-util/rocm_bandwidth_test/Manifest
+++ b/dev-util/rocm_bandwidth_test/Manifest
@@ -1 +1,2 @@
DIST rocm_bandwidth_test-5.3.3.tar.gz 38681 BLAKE2B 02a09ae869b507ad117e40e2daadd6e2acb2a365b12e5f601a4c8d6e55d3fb51de32feef9122bd532700b46843310ed83088842728a814f55695a3572e83d1d1 SHA512 155480284cdd1b0e42c62ab49f536ef12f2b9cbfcf0e8d076938cf0cf86872b536506a81e283b656ef1896d7d6e691e06145b2021593542755dd7460d08002c9
+DIST rocm_bandwidth_test-5.4.3.tar.gz 38761 BLAKE2B ab3c8fd15039081f7b42e1c5c82e06f2cf3f5c70c0868bf0c195507dd97669f199ecdaa895d292d225bce7aa069d14836923ff9ffd43d13749ca312ed07d3402 SHA512 676ba7aa26fd5eb2858ff61c8cf49ea3c5d51e87f5fa3bd6389c7c53e02561281d2d4a751369ccc66270f1d04b5ec9e55048ba23e758f0be8ef8e2abfd2026c2
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild
new file mode 100644
index 000000000000..684546f46011
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+src_install() {
+ cmake_src_install
+
+ rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
+}