summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/doom3-hellcampaign')
-rw-r--r--games-fps/doom3-hellcampaign/Manifest2
-rw-r--r--games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild47
-rw-r--r--games-fps/doom3-hellcampaign/metadata.xml5
3 files changed, 54 insertions, 0 deletions
diff --git a/games-fps/doom3-hellcampaign/Manifest b/games-fps/doom3-hellcampaign/Manifest
new file mode 100644
index 000000000000..1a5dbea3daef
--- /dev/null
+++ b/games-fps/doom3-hellcampaign/Manifest
@@ -0,0 +1,2 @@
+DIST hardcorehellcampaign_patch.zip 532844 SHA256 98d0619e0dcd8f12bbb596c635831a37b396cab5fd49e004e95f6b8d0deefd92
+DIST sp_hc_final.zip 113992555 SHA256 3b0c4b19139f5c3341a09d4169760f1eac1029e87587a44651cde4a4bc46bcd4
diff --git a/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild b/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild
new file mode 100644
index 000000000000..5c27d160987f
--- /dev/null
+++ b/games-fps/doom3-hellcampaign/doom3-hellcampaign-1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+MOD_DESC="map pack for Doom 3"
+MOD_NAME="Hell Campaign"
+MOD_DIR="hell_campaign"
+
+inherit games games-mods
+
+HOMEPAGE="http://doom3.filefront.com/file/The_Ultimate_Hell_Campaign;52013"
+SRC_URI="sp_hc_final.zip
+ hardcorehellcampaign_patch.zip"
+
+LICENSE="GameFront"
+KEYWORDS="amd64 x86"
+IUSE="dedicated opengl"
+RESTRICT="fetch bindist"
+
+pkg_nofetch() {
+ elog "Please download the following files:"
+ elog "http://www.filefront.com/4445166"
+ elog "http://www.filefront.com/4593578"
+ elog "and move them to ${DISTDIR}"
+}
+
+src_unpack() {
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
+}
+
+src_prepare() {
+ cd ${MOD_DIR}
+
+ # Prevent "non-portable" upper-case-filename warnings in Doom 3
+ mv -f "Hardcore Hell Campaign.pk4" hardcore_hell_campaign.pk4 || die
+ mv -f Q2Textures.pk4 q2Textures.pk4 || die
+ mv -f Q3Textures.pk4 q3Textures.pk4 || die
+
+ mv -f "Hardcore Hell Campaign.rtf" readme.rtf || die
+
+ # Show nice description in "mods" menu within Doom 3
+ echo "${MOD_NAME}" > description.txt
+}
diff --git a/games-fps/doom3-hellcampaign/metadata.xml b/games-fps/doom3-hellcampaign/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-fps/doom3-hellcampaign/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>