summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/Manifest1
-rw-r--r--kde-base/qyoto/metadata.xml10
-rw-r--r--kde-base/qyoto/qyoto-4.14.3.ebuild33
3 files changed, 44 insertions, 0 deletions
diff --git a/kde-base/qyoto/Manifest b/kde-base/qyoto/Manifest
new file mode 100644
index 000000000000..2c5290167a98
--- /dev/null
+++ b/kde-base/qyoto/Manifest
@@ -0,0 +1 @@
+DIST qyoto-4.14.3.tar.xz 507640 SHA256 44a6e2eacc4645cc0e217812948518860661dc52215af005726cc40ab96ddc46 SHA512 4e74a6a8a1ef501490d5680b3c47fd83153798e9c226f39175c5710b78f26854d01611df2e3b5e052369d82d56b72b14696a7599debeca788f30c0fcefe9d46b WHIRLPOOL c684fa80650ea34523d496faeb2f00e189a6019a11e15d3ce6010864f31ec94e5baac626c4ee83ca674ee9a104ef0e7e2e6f78b3943db25d2fb0898e6b43654a
diff --git a/kde-base/qyoto/metadata.xml b/kde-base/qyoto/metadata.xml
new file mode 100644
index 000000000000..b069b55c8cb2
--- /dev/null
+++ b/kde-base/qyoto/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="phonon">Compile bindings for Phonon.</flag>
+ <flag name="qscintilla">Compile bindings for <pkg>x11-libs/qscintilla</pkg>.</flag>
+ <flag name="webkit">Compile bindings for <pkg>dev-qt/qtwebkit</pkg>.</flag>
+</use>
+</pkgmetadata>
diff --git a/kde-base/qyoto/qyoto-4.14.3.ebuild b/kde-base/qyoto/qyoto-4.14.3.ebuild
new file mode 100644
index 000000000000..cfdb9af04a8a
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.14.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_REQUIRED="never"
+inherit mono-env kde4-base
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Qyoto"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ mono-env_pkg_setup
+ kde4-base_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}