summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/files/haproxy.confd4
-rw-r--r--net-proxy/haproxy/files/haproxy.initd-r24
-rw-r--r--net-proxy/haproxy/files/haproxy.initd-r34
-rw-r--r--net-proxy/haproxy/haproxy-1.6.9.ebuild11
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild4
5 files changed, 7 insertions, 20 deletions
diff --git a/net-proxy/haproxy/files/haproxy.confd b/net-proxy/haproxy/files/haproxy.confd
index 5a989a776749..30739eb8bf23 100644
--- a/net-proxy/haproxy/files/haproxy.confd
+++ b/net-proxy/haproxy/files/haproxy.confd
@@ -9,6 +9,6 @@ HAPROXY_OPTS=""
# For more information on how to use that feature please have a look at the
# "seamless_reload.txt" documentation file (requires net-proxy/haproxy[examples])
#reload_seamless() {
-# checkpath -d -m 0700 haproxy:haproxy "/var/run/haproxy/"
-# socat /var/run/haproxy/socket - <<< "show servers state" > /var/run/haproxy/global.state
+# checkpath -d -m 0700 haproxy:haproxy "/run/haproxy/"
+# socat /run/haproxy/socket - <<< "show servers state" > /run/haproxy/global.state
#}
diff --git a/net-proxy/haproxy/files/haproxy.initd-r2 b/net-proxy/haproxy/files/haproxy.initd-r2
index 39a5bb457bd4..15c5eb5b08c6 100644
--- a/net-proxy/haproxy/files/haproxy.initd-r2
+++ b/net-proxy/haproxy/files/haproxy.initd-r2
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -7,7 +7,7 @@ extra_commands="checkconfig"
extra_started_commands="reload"
command="/usr/bin/haproxy"
-pidfile="/var/run/${SVCNAME}.pid"
+pidfile="/run/${SVCNAME}.pid"
if [ -z "${CONFFILE}" -a -d "/etc/haproxy" -a -f "/etc/haproxy/${SVCNAME}.cfg" ]; then
CONFFILE=/etc/haproxy/${SVCNAME}.cfg
diff --git a/net-proxy/haproxy/files/haproxy.initd-r3 b/net-proxy/haproxy/files/haproxy.initd-r3
index 92665cd25464..60ec31ac376b 100644
--- a/net-proxy/haproxy/files/haproxy.initd-r3
+++ b/net-proxy/haproxy/files/haproxy.initd-r3
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,7 +8,7 @@ extra_started_commands="reload"
command="/usr/bin/haproxy"
-pidfile="${HAPROXY_PIDFILE:-/var/run/${SVCNAME}.pid}"
+pidfile="${HAPROXY_PIDFILE:-/run/${SVCNAME}.pid}"
configs=
diff --git a/net-proxy/haproxy/haproxy-1.6.9.ebuild b/net-proxy/haproxy/haproxy-1.6.9.ebuild
index c9a98ed4d849..8f3c3a0fcc08 100644
--- a/net-proxy/haproxy/haproxy-1.6.9.ebuild
+++ b/net-proxy/haproxy/haproxy-1.6.9.ebuild
@@ -15,7 +15,7 @@ SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/$
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
+IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib"
REQUIRED_USE="pcre-jit? ( pcre )
?? ( slz zlib )"
@@ -30,7 +30,6 @@ DEPEND="
)
slz? ( dev-libs/libslz:= )
zlib? ( sys-libs/zlib )"
-# lua? ( dev-lang/lua:5.3 )
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
@@ -69,17 +68,9 @@ src_compile() {
)
args+=( $(haproxy_use crypt LIBCRYPT) )
-
-# bug 541042
-# args+=( $(haproxy_use lua LUA) )
-
args+=( $(haproxy_use net_ns NS) )
args+=( $(haproxy_use pcre PCRE) )
args+=( $(haproxy_use pcre-jit PCRE_JIT) )
-
-# args+=( $(haproxy_use kernel_linux LINUX_SPLICE) )
-# args+=( $(haproxy_use kernel_linux LINUX_TPROXY) )
-
args+=( $(haproxy_use ssl OPENSSL) )
args+=( $(haproxy_use slz SLZ) )
args+=( $(haproxy_use zlib ZLIB) )
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
index 4100bfa77387..97a58d9c88f9 100644
--- a/net-proxy/haproxy/haproxy-9999.ebuild
+++ b/net-proxy/haproxy/haproxy-9999.ebuild
@@ -76,10 +76,6 @@ src_compile() {
args+=( $(haproxy_use net_ns NS) )
args+=( $(haproxy_use pcre PCRE) )
args+=( $(haproxy_use pcre-jit PCRE_JIT) )
-
-# args+=( $(haproxy_use kernel_linux LINUX_SPLICE) )
-# args+=( $(haproxy_use kernel_linux LINUX_TPROXY) )
-
args+=( $(haproxy_use ssl OPENSSL) )
args+=( $(haproxy_use slz SLZ) )
args+=( $(haproxy_use zlib ZLIB) )