summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/allpathslg/allpathslg-52488.ebuild')
-rw-r--r--sci-biology/allpathslg/allpathslg-52488.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-biology/allpathslg/allpathslg-52488.ebuild b/sci-biology/allpathslg/allpathslg-52488.ebuild
new file mode 100644
index 000000000000..0b0b806e5cf6
--- /dev/null
+++ b/sci-biology/allpathslg/allpathslg-52488.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+# see also http://www.broadinstitute.org/software/allpaths-lg/blog/?page_id=12
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+DEPEND="
+ dev-libs/boost
+ !sci-biology/allpaths
+ sci-biology/vaal"
+RDEPEND=""
+
+PATCHES=("${FILESDIR}/${P}_fix-buildsystem.patch" "${FILESDIR}/${P}_remove-namespace-std.patch")
+
+pkg_pretend() {
+ # as of release 44849, GCC 4.7.0 (or higher) is required
+ # seems pre gcc-4.7 users must stay with:
+ # ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/2013/2013-01/allpathslg-44837.tar.gz
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(tc-getCC) == *gcc* ]] && [[ $(gcc-version) < 4.7 ]] && \
+ die "You need to use gcc >4.7"
+ fi
+}
+
+src_prepare() {
+ default_src_prepare
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable openmp)
+ )
+ default_src_configure
+}