summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/muscle/muscle-5.1.0.ebuild')
-rw-r--r--sci-biology/muscle/muscle-5.1.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/muscle/muscle-5.1.0.ebuild b/sci-biology/muscle/muscle-5.1.0.ebuild
new file mode 100644
index 000000000000..033c35b8ee1a
--- /dev/null
+++ b/sci-biology/muscle/muscle-5.1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Multiple sequence comparison by log-expectation"
+HOMEPAGE="https://www.drive5.com/muscle/"
+SRC_URI="https://github.com/rcedgar/muscle/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="!sci-libs/libmuscle"
+
+S="${WORKDIR}"/${P}/src
+
+PATCHES=(
+ "${FILESDIR}"/0001-Makefile-fix-horribleness-so-that-it-respects-build-.patch
+)
+
+src_configure() {
+ tc-export CXX
+ printf '"%s"\n' "${PV}" > gitver.txt
+}
+
+src_install() {
+ local OS=$(uname) || die
+ dobin ${OS}/muscle
+ dodoc *.txt
+}