summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r1.ebuild8
-rw-r--r--sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch39
2 files changed, 46 insertions, 1 deletions
diff --git a/sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r1.ebuild b/sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r1.ebuild
index 574fe036ecf0..de1d816c1465 100644
--- a/sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r1.ebuild
+++ b/sci-libs/fflas-ffpack/fflas-ffpack-2.4.3-r1.ebuild
@@ -23,7 +23,13 @@ DEPEND="virtual/cblas
=sci-libs/givaro-4.1*"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-2.3.2-blaslapack.patch" )
+# The no-test-echelon patch works around a test failure that may
+# eventually be fixed upstream. Gentoo bug 725446 and upstream
+# Github issue 282.
+PATCHES=(
+ "${FILESDIR}/${PN}-2.3.2-blaslapack.patch"
+ "${FILESDIR}/${P}-no-test-echelon.patch"
+)
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
diff --git a/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch
new file mode 100644
index 000000000000..0b8b68fa6093
--- /dev/null
+++ b/sci-libs/fflas-ffpack/files/fflas-ffpack-2.4.3-no-test-echelon.patch
@@ -0,0 +1,39 @@
+From 5be5c93ed41d0136730477beccad7b9f21d47e86 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Tue, 26 May 2020 09:45:50 -0400
+Subject: [PATCH 1/1] tests: disable test_echelon.
+
+There are two reported failures of test_echelon on Gentoo and Conda
+that the Gentoo maintainers haven't been able to reproduce yet. Until
+upstream has a chance to look at the failures, this commit disables
+that particular test.
+
+Gentoo-bug: https://bugs.gentoo.org/724526
+Upstream-bug: https://github.com/linbox-team/fflas-ffpack/issues/282
+---
+ tests/Makefile.am | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 4326820..62e92bc 100755
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -56,7 +56,6 @@ BASIC_TESTS = \
+ test-rankprofiles \
+ test-det \
+ test-det-check \
+- test-echelon \
+ test-charpoly \
+ test-charpoly-check \
+ test-minpoly \
+@@ -119,7 +118,6 @@ test_ftrsm_check_SOURCES = test-ftrsm-check.C
+ test_invert_check_SOURCES = test-invert-check.C
+ test_charpoly_check_SOURCES = test-charpoly-check.C
+ test_minpoly_SOURCES = test-minpoly.C
+-test_echelon_SOURCES = test-echelon.C
+ test_rankprofiles_SOURCES = test-rankprofiles.C
+ test_fgemm_SOURCES = test-fgemm.C
+ test_fger_SOURCES = test-fger.C
+--
+2.26.2
+