summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cado-nfs/cado-nfs-2.1.ebuild')
-rw-r--r--sci-mathematics/cado-nfs/cado-nfs-2.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-mathematics/cado-nfs/cado-nfs-2.1.ebuild b/sci-mathematics/cado-nfs/cado-nfs-2.1.ebuild
new file mode 100644
index 000000000000..af4044b322f5
--- /dev/null
+++ b/sci-mathematics/cado-nfs/cado-nfs-2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+DESCRIPTION="Number Field Sieve (NFS) implementation for factoring integers"
+HOMEPAGE="http://cado-nfs.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/33856/${P}.tar.gz"
+
+inherit eutils cmake-utils
+
+# Fails F9_{k,m}bucket_test F9_tracektest
+RESTRICT="test"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/gmp
+ dev-lang/perl
+ !sci-mathematics/ggnfs
+ !sci-biology/shrimp
+ "
+DEPEND="${RDEPEND}
+ "
+
+src_prepare() {
+ # looks like packaging mistake
+ sed -i -e 's/add_executable (convert_rels convert_rels.c)//' misc/CMakeLists.txt || die
+ sed -i -e 's/target_link_libraries (convert_rels utils)//' misc/CMakeLists.txt || die
+ sed -i -e 's~install(TARGETS convert_rels RUNTIME DESTINATION bin/misc)~~' misc/CMakeLists.txt || die
+}
+
+src_configure() {
+ DESTINATION="/usr/libexec/cado-nfs" cmake-utils_src_configure
+}
+src_compile() {
+ # autodetection goes confused for gf2x
+ ABI=default cmake-utils_src_compile
+}