summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gwnum')
-rw-r--r--sci-mathematics/gwnum/Manifest1
-rw-r--r--sci-mathematics/gwnum/gwnum-277.ebuild34
-rw-r--r--sci-mathematics/gwnum/metadata.xml8
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-mathematics/gwnum/Manifest b/sci-mathematics/gwnum/Manifest
new file mode 100644
index 000000000000..d448d4ae40e7
--- /dev/null
+++ b/sci-mathematics/gwnum/Manifest
@@ -0,0 +1 @@
+DIST gwnum-277.tar.bz2 24143696 SHA256 bbd7baec05d66b3cbe315e742b1b1aaa882dea838bed4901203c29a2e231397f SHA512 d88a15b01fad458640a84ffa3d5fca6fb35ecd99aff711e679cdae2a58b95c9caefdd4218015f620fd7a93bb54aabad1311205d7ec62d212ca8c6e80af696cc3 WHIRLPOOL db520213f8b324e5c4dc21800424755cd8f23cbbe26619f6393e8b5ed65653a89b73098638fd75137a05a6a323fc71b0acc5496d5ad405fe70f7d26671b301df
diff --git a/sci-mathematics/gwnum/gwnum-277.ebuild b/sci-mathematics/gwnum/gwnum-277.ebuild
new file mode 100644
index 000000000000..1842938ca888
--- /dev/null
+++ b/sci-mathematics/gwnum/gwnum-277.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+DESCRIPTION="George Woltman's GWNUM library"
+HOMEPAGE="http://www.mersenne.org/freesoft/"
+# Sourcecode split out from prime95, we don't need the full lib
+SRC_URI="http://gentooexperimental.org/~patrick/${P}.tar.bz2"
+
+inherit eutils
+
+LICENSE="gwnum BSD GPL-2+"
+SLOT="0"
+# Need to test if it actually compiles on x86
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="bindist" #465566
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # makefile doesn't return zero? || die fails :(
+ use amd64 && emake -f make64
+ use x86 && emake
+}
+
+src_install() {
+ mkdir "${D}/usr/lib" -p
+ cp gwnum.a gwnum.lib "${D}/usr/lib" || die
+ mkdir "${D}/usr/include" -p
+ cp *.h "${D}/usr/include" || die
+}
diff --git a/sci-mathematics/gwnum/metadata.xml b/sci-mathematics/gwnum/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/sci-mathematics/gwnum/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>