summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/grub/grub-9999-r1.ebuild')
-rw-r--r--sys-boot/grub/grub-9999-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-boot/grub/grub-9999-r1.ebuild b/sys-boot/grub/grub-9999-r1.ebuild
index c880d12e4920..b0c7084c38c5 100644
--- a/sys-boot/grub/grub-9999-r1.ebuild
+++ b/sys-boot/grub/grub-9999-r1.ebuild
@@ -48,7 +48,7 @@ LICENSE="GPL-3 fonts? ( GPL-2-with-font-exception ) themes? ( BitstreamVera )"
SLOT="2/${PVR}"
IUSE="debug device-mapper doc efiemu +fonts mount +multislot nls static sdl test +themes truetype libzfs"
-GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen )
+GRUB_ALL_PLATFORMS=( coreboot efi-32 efi-64 emu ieee1275 loongson multiboot qemu qemu-mips pc uboot xen xen-32 )
IUSE+=" ${GRUB_ALL_PLATFORMS[@]/#/grub_platforms_}"
REQUIRED_USE="
@@ -82,6 +82,7 @@ DEPEND="${RDEPEND}
sys-apps/texinfo
fonts? ( media-libs/freetype:2 )
grub_platforms_xen? ( app-emulation/xen-tools:= )
+ grub_platforms_xen-32? ( app-emulation/xen-tools:= )
static? (
app-arch/xz-utils[static-libs(+)]
truetype? (
@@ -181,6 +182,11 @@ grub_configure() {
local TARGET_CPPFLAGS="-march=x86-64 ${TARGET_CPPFLAGS}"
export TARGET_CFLAGS TARGET_CPPFLAGS
fi ;;
+ xen-32)
+ platform=xen
+ if [[ ${CHOST} == x86_64* ]]; then
+ local CTARGET=i386
+ fi ;;
guessed) ;;
*) platform=${MULTIBUILD_VARIANT} ;;
esac