summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild')
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..aa6fe7ce9e43
--- /dev/null
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+MY_P="hfsplus_${PV}"
+DESCRIPTION="HFS+ Filesystem Access Utilities (a PPC filesystem)"
+HOMEPAGE="http://penguinppc.org/historical/hfsplus/"
+SRC_URI="http://penguinppc.org/historical/hfsplus/${MY_P}.src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc ppc64 x86"
+IUSE=""
+
+DEPEND="app-arch/bzip2"
+RDEPEND=""
+
+S=${WORKDIR}/hfsplus-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-glob.patch"
+ epatch "${FILESDIR}/${P}-errno.patch"
+ epatch "${FILESDIR}/${P}-gcc4.patch"
+ epatch "${FILESDIR}/${P}-string.patch"
+ #let's avoid the Makefile.cvs since isn't working for us
+ eautoreconf
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ newman doc/man/hfsp.man hfsp.1
+}