summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/kibana-bin/kibana-bin-4.1.3.ebuild')
-rw-r--r--www-apps/kibana-bin/kibana-bin-4.1.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/www-apps/kibana-bin/kibana-bin-4.1.3.ebuild b/www-apps/kibana-bin/kibana-bin-4.1.3.ebuild
new file mode 100644
index 000000000000..facd6af6d492
--- /dev/null
+++ b/www-apps/kibana-bin/kibana-bin-4.1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit user
+
+MY_PN="kibana"
+MY_P=${MY_PN}-${PV/_rc/-rc}
+
+DESCRIPTION="Explore and visualize data"
+HOMEPAGE="https://www.elastic.co/products/kibana"
+SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_P}-linux-x64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=""
+RDEPEND=""
+
+RESTRICT="strip"
+QA_PREBUILT="opt/kibana/node/bin/node"
+
+S="${WORKDIR}/${MY_P}-linux-x64"
+
+pkg_setup() {
+ enewgroup ${MY_PN}
+ enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
+}
+
+src_install() {
+ keepdir /opt/${MY_PN}
+ keepdir /var/log/${MY_PN}
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}
+
+ newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
+ newinitd "${FILESDIR}"/${MY_PN}.initd-r2 ${MY_PN}
+
+ mv * "${D}"/opt/${MY_PN}
+}
+
+pkg_postinst() {
+ elog "Be sure to point ES_INSTANCE to your Elasticsearch instance"
+ elog "in /etc/conf.d/${MY_PN}."
+ elog
+ elog "Elasticsearch can run local or remote."
+}