summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-91.3.0.ebuild')
-rw-r--r--www-client/firefox/firefox-91.3.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/www-client/firefox/firefox-91.3.0.ebuild b/www-client/firefox/firefox-91.3.0.ebuild
index 5f04301ca82d..713d7014869a 100644
--- a/www-client/firefox/firefox-91.3.0.ebuild
+++ b/www-client/firefox/firefox-91.3.0.ebuild
@@ -64,7 +64,7 @@ LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="+clang cpu_flags_arm_neon dbus debug eme-free hardened hwaccel"
IUSE+=" jack lto +openh264 pgo pulseaudio sndio selinux"
-IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx +system-webp"
+IUSE+=" +system-av1 +system-harfbuzz +system-icu +system-jpeg +system-libevent +system-libvpx system-png +system-webp"
IUSE+=" wayland wifi"
# Firefox-only IUSE
@@ -131,7 +131,6 @@ CDEPEND="
>=x11-libs/gtk+-3.4.0:3[X]
x11-libs/gdk-pixbuf
>=x11-libs/pango-1.22.0
- >=media-libs/libpng-1.6.35:0=[apng]
>=media-libs/mesa-10.2:*
media-libs/fontconfig
>=media-libs/freetype-2.4.10
@@ -167,6 +166,7 @@ CDEPEND="
system-jpeg? ( >=media-libs/libjpeg-turbo-1.2.1 )
system-libevent? ( >=dev-libs/libevent-2.0:0=[threads] )
system-libvpx? ( >=media-libs/libvpx-1.8.2:0=[postproc] )
+ system-png? ( >=media-libs/libpng-1.6.35:0=[apng] )
system-webp? ( >=media-libs/libwebp-1.1.0:0= )
wifi? (
kernel_linux? (
@@ -711,7 +711,6 @@ src_configure() {
--with-libclang-path="$(llvm-config --libdir)" \
--with-system-nspr \
--with-system-nss \
- --with-system-png \
--with-system-zlib \
--with-toolchain-prefix="${CHOST}-" \
--with-unsigned-addon-scopes=app,system \
@@ -770,6 +769,7 @@ src_configure() {
mozconfig_use_with system-jpeg
mozconfig_use_with system-libevent system-libevent "${SYSROOT}${EPREFIX}/usr"
mozconfig_use_with system-libvpx
+ mozconfig_use_with system-png
mozconfig_use_with system-webp
mozconfig_use_enable dbus