summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/firefox-102.4.0.ebuild10
-rw-r--r--www-client/firefox/firefox-106.0.5.ebuild10
2 files changed, 12 insertions, 8 deletions
diff --git a/www-client/firefox/firefox-102.4.0.ebuild b/www-client/firefox/firefox-102.4.0.ebuild
index 9cb14de9e22a..0d52f3b9361f 100644
--- a/www-client/firefox/firefox-102.4.0.ebuild
+++ b/www-client/firefox/firefox-102.4.0.ebuild
@@ -211,8 +211,8 @@ llvm_check_deps() {
fi
if use clang ; then
- if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
- einfo "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "sys-devel/lld:${LLVM_SLOT}" ; then
+ einfo "sys-devel/lld:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
@@ -618,10 +618,12 @@ src_configure() {
einfo "Current RUSTFLAGS:\t\t${RUSTFLAGS:-no value set}"
local have_switched_compiler=
- if use clang && ! tc-is-clang ; then
+ if use clang; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
- have_switched_compiler=yes
+ if tc-is-gcc; then
+ have_switched_compiler=yes
+ fi
AR=llvm-ar
AS=llvm-as
CC=${CHOST}-clang
diff --git a/www-client/firefox/firefox-106.0.5.ebuild b/www-client/firefox/firefox-106.0.5.ebuild
index 0c86994fb351..199bc3a3de9c 100644
--- a/www-client/firefox/firefox-106.0.5.ebuild
+++ b/www-client/firefox/firefox-106.0.5.ebuild
@@ -226,8 +226,8 @@ llvm_check_deps() {
fi
if use clang ; then
- if ! has_version -b "=sys-devel/lld-${LLVM_SLOT}*" ; then
- einfo "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
+ if ! has_version -b "sys-devel/lld:${LLVM_SLOT}" ; then
+ einfo "sys-devel/lld:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
return 1
fi
@@ -663,10 +663,12 @@ src_configure() {
einfo "Current RUSTFLAGS:\t\t${RUSTFLAGS:-no value set}"
local have_switched_compiler=
- if use clang && ! tc-is-clang ; then
+ if use clang; then
# Force clang
einfo "Enforcing the use of clang due to USE=clang ..."
- have_switched_compiler=yes
+ if tc-is-gcc; then
+ have_switched_compiler=yes
+ fi
AR=llvm-ar
AS=llvm-as
CC=${CHOST}-clang