summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xdesktopwaves/xdesktopwaves-1.3.ebuild')
-rw-r--r--x11-misc/xdesktopwaves/xdesktopwaves-1.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xdesktopwaves/xdesktopwaves-1.3.ebuild b/x11-misc/xdesktopwaves/xdesktopwaves-1.3.ebuild
new file mode 100644
index 000000000000..20b4aa95c6b3
--- /dev/null
+++ b/x11-misc/xdesktopwaves/xdesktopwaves-1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
+HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
+LICENSE="GPL-2"
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+src_compile() {
+ emake || die "failed building program"
+ cd xdwapi
+ emake || die "failed building demo"
+}
+
+src_install() {
+ dobin xdesktopwaves xdwapi/xdwapidemo
+ doman xdesktopwaves.1
+ insinto /usr/share/pixmaps
+ doins xdesktopwaves.xpm
+ make_desktop_entry xdesktopwaves
+ dodoc README
+}
+
+pkg_preinst() {
+ elog "To see what xdesktopwaves is able to do, start it by running"
+ elog "'xdesktopwaves' and then run 'xdwapidemo'. You should see the"
+ elog "supported effects on your desktop"
+}