summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-08 18:49:53 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-08 18:49:53 +0000
commit188282c921e236a07f72583f5655d7b6fae19000 (patch)
treed441c187e0e012980c7b3273b2d5088227020e95
parentMark 0.78 stable on alpha (diff)
downloadhistorical-188282c921e236a07f72583f5655d7b6fae19000.tar.gz
historical-188282c921e236a07f72583f5655d7b6fae19000.tar.bz2
historical-188282c921e236a07f72583f5655d7b6fae19000.zip
use new patch to fix warnings
Package-Manager: portage-2.0.51.22-r2
-rw-r--r--net-analyzer/bigeye/ChangeLog7
-rw-r--r--net-analyzer/bigeye/Manifest14
-rw-r--r--net-analyzer/bigeye/bigeye-0.3-r1.ebuild42
-rw-r--r--net-analyzer/bigeye/files/digest-bigeye-0.3-r12
4 files changed, 53 insertions, 12 deletions
diff --git a/net-analyzer/bigeye/ChangeLog b/net-analyzer/bigeye/ChangeLog
index d7e1beec2925..26929ae262c8 100644
--- a/net-analyzer/bigeye/ChangeLog
+++ b/net-analyzer/bigeye/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/bigeye
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bigeye/ChangeLog,v 1.8 2005/08/29 19:11:19 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bigeye/ChangeLog,v 1.9 2005/09/08 18:49:53 vanquirius Exp $
+
+*bigeye-0.3-r1 (08 Sep 2005)
+
+ 08 Sep 2005; Marcelo Goes <vanquirius@gentoo.org> +bigeye-0.3-r1.ebuild:
+ Use my new patch to fix compilation warnings in gcc-3.4.
29 Aug 2005; <dang@gentoo.org> bigeye-0.3.ebuild:
Marked ~amd64
diff --git a/net-analyzer/bigeye/Manifest b/net-analyzer/bigeye/Manifest
index 59a5cb60013e..64bc9d729717 100644
--- a/net-analyzer/bigeye/Manifest
+++ b/net-analyzer/bigeye/Manifest
@@ -1,15 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 8ef98b2cb770190cd10cdb71595ccf30 bigeye-0.3.ebuild 957
-MD5 6053008af5bdbe918538be52201e6c9b ChangeLog 931
+MD5 fa5c66f3e0b78b26db67aea78f715355 bigeye-0.3-r1.ebuild 1018
+MD5 6a7d64eed9c79e56f27c47d627b00036 ChangeLog 1102
MD5 f34e3c8858756da0001b12d2d3fa1af2 metadata.xml 159
MD5 8ef1b063fc9655f3f06781a2eeaa785d files/0.3-gcc3.patch 525
+MD5 18b8ab6d586876dda6d6ff539a6c96a0 files/digest-bigeye-0.3-r1 126
MD5 dcc42b28916e9e2c9b9d9aff3b156684 files/digest-bigeye-0.3 58
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDE13qomPajV0RnrERAkJPAKCBrcKJtEbVpyvhR/Kzus2qjcBPqQCghNwM
-vyFq9jRGp0SohU3pZZN57Ag=
-=xRB0
------END PGP SIGNATURE-----
diff --git a/net-analyzer/bigeye/bigeye-0.3-r1.ebuild b/net-analyzer/bigeye/bigeye-0.3-r1.ebuild
new file mode 100644
index 000000000000..3913b068e229
--- /dev/null
+++ b/net-analyzer/bigeye/bigeye-0.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/bigeye/bigeye-0.3-r1.ebuild,v 1.1 2005/09/08 18:49:53 vanquirius Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Bigeye is a network utility dump and simple honeypot utility"
+HOMEPAGE="http://violating.us/projects/bigeye/"
+SRC_URI="http://violating.us/projects/bigeye/download/${P}.tgz
+ mirror://gentoo/${P}-gcc34.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${WORKDIR}/${P}-gcc34.diff
+}
+
+src_compile() {
+ cd src
+ $(tc-getCC) ${CFLAGS} bigeye.c emulate.c -o bigeye || die
+ einfo "Done compiling."
+}
+
+src_install() {
+ dobin src/bigeye || die
+
+ insinto /usr/share/bigeye
+ doins sig.file
+ cp -r messages ${D}/usr/share/bigeye/
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "The service emulation files mentioned in the README"
+ einfo "are located in /usr/share/bigeye/messages"
+}
diff --git a/net-analyzer/bigeye/files/digest-bigeye-0.3-r1 b/net-analyzer/bigeye/files/digest-bigeye-0.3-r1
new file mode 100644
index 000000000000..c20ddc2909dc
--- /dev/null
+++ b/net-analyzer/bigeye/files/digest-bigeye-0.3-r1
@@ -0,0 +1,2 @@
+MD5 51c38aea3258273cc97d759f82218655 bigeye-0.3.tgz 32462
+MD5 04465f7c7547ffa185640ad3ead30e93 bigeye-0.3-gcc34.diff.bz2 2774