summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-28 21:27:20 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-28 21:27:20 +0000
commit4510edc50fcdc21d85107b998a49958b5ef041af (patch)
treebc3e496a3bf38771bd7bce96c5a521d403138854
parentMigrate to EAPI 2 in order to get rid of built_with_use. (diff)
downloadhistorical-4510edc50fcdc21d85107b998a49958b5ef041af.tar.gz
historical-4510edc50fcdc21d85107b998a49958b5ef041af.tar.bz2
historical-4510edc50fcdc21d85107b998a49958b5ef041af.zip
Remove old security vulnerable versions that also used built_with_use.
Package-Manager: portage-2.2_rc38/cvs/Linux i686
-rw-r--r--net-misc/neon/ChangeLog6
-rw-r--r--net-misc/neon/neon-0.28.4.ebuild114
-rw-r--r--net-misc/neon/neon-0.28.5.ebuild105
-rw-r--r--net-misc/scponly/Manifest14
4 files changed, 16 insertions, 223 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index 06d9d3085daf..4a756f1d29fb 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/neon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.137 2009/08/27 00:10:16 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.138 2009/08/28 21:27:20 betelgeuse Exp $
+
+ 28 Aug 2009; Petteri Räty <betelgeuse@gentoo.org> -neon-0.28.4.ebuild,
+ -neon-0.28.5.ebuild:
+ Remove old security vulnerable versions that also used built_with_use.
27 Aug 2009; Alex Legler <a3li@gentoo.org> neon-0.28.6.ebuild:
amd64 stable, security bug 281950
diff --git a/net-misc/neon/neon-0.28.4.ebuild b/net-misc/neon/neon-0.28.4.ebuild
deleted file mode 100644
index 96dc2347bb25..000000000000
--- a/net-misc/neon/neon-0.28.4.ebuild
+++ /dev/null
@@ -1,114 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.28.4.ebuild,v 1.7 2009/06/12 23:10:32 arfrever Exp $
-
-inherit autotools eutils libtool versionator
-
-RESTRICT="test"
-
-DESCRIPTION="HTTP and WebDAV client library"
-HOMEPAGE="http://www.webdav.org/neon/"
-SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="doc expat gnutls kerberos nls pkcs11 socks5 ssl zlib"
-IUSE_LINGUAS="cs de fr ja nn pl ru tr zh_CN"
-for lingua in ${IUSE_LINGUAS}; do
- IUSE="${IUSE} linguas_${lingua}"
-done
-
-RDEPEND="expat? ( dev-libs/expat )
- !expat? ( dev-libs/libxml2 )
- gnutls? (
- >=net-libs/gnutls-2.0
- pkcs11? ( dev-libs/pakchois )
- )
- !gnutls? ( ssl? (
- >=dev-libs/openssl-0.9.6f
- pkcs11? ( dev-libs/pakchois )
- ) )
- kerberos? ( virtual/krb5 )
- nls? ( virtual/libintl )
- socks5? ( net-proxy/dante )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- local lingua linguas
- for lingua in ${IUSE_LINGUAS}; do
- use linguas_${lingua} && linguas="${linguas} ${lingua}"
- done
- sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
- sed -i -e "s/socks5/socks/g" macros/neon.m4
-
- epatch "${FILESDIR}/${P}-SOCK_CLOEXEC.patch"
-
- AT_M4DIR="macros" eautoreconf
-}
-
-src_compile() {
- local myconf
-
- if has_version sys-libs/glibc; then
- if built_with_use --missing true sys-libs/glibc nptlonly \
- || built_with_use --missing true sys-libs/glibc nptl; then
- einfo "Enabling SSL library thread-safety using POSIX threads..."
- myconf="${myconf} --enable-threadsafe-ssl=posix"
- fi
- fi
-
- if use expat; then
- myconf="${myconf} --with-expat"
- else
- myconf="${myconf} --with-libxml2"
- fi
-
- if use gnutls; then
- myconf="${myconf} --with-ssl=gnutls"
- elif use ssl; then
- myconf="${myconf} --with-ssl=openssl"
- fi
-
- econf \
- --enable-static \
- --enable-shared \
- $(use_with kerberos gssapi) \
- $(use_enable nls) \
- $(use_with pkcs11 pakchois) \
- $(use_with socks5 socks) \
- $(use_with zlib) \
- ${myconf}
- emake || die "emake failed"
-}
-
-src_test() {
- emake check || die "Trying make check without success."
-}
-
-src_install() {
- emake DESTDIR="${D}" install-lib install-headers install-config install-nls || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" install-docs || die "emake install-docs failed"
- fi
-
- dodoc AUTHORS BUGS NEWS README THANKS TODO
- doman doc/man/*.[1-8]
-}
-
-pkg_postinst() {
- ewarn "Neon has a policy of breaking API across minor versions, this means"
- ewarn "that any package that links against neon may be broken after"
- ewarn "updating. They will remain broken until they are ported to the"
- ewarn "new API. You can downgrade neon to the previous version by doing:"
- ewarn
- ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
- ewarn
- ewarn "You may also have to downgrade any package that has already been"
- ewarn "ported to the new API."
-}
diff --git a/net-misc/neon/neon-0.28.5.ebuild b/net-misc/neon/neon-0.28.5.ebuild
deleted file mode 100644
index 654cd4e4569a..000000000000
--- a/net-misc/neon/neon-0.28.5.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.28.5.ebuild,v 1.4 2009/08/09 18:58:07 jer Exp $
-
-EAPI="2"
-
-inherit autotools libtool versionator
-
-DESCRIPTION="HTTP and WebDAV client library"
-HOMEPAGE="http://www.webdav.org/neon/"
-SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="doc expat gnutls kerberos nls pkcs11 socks5 ssl zlib"
-IUSE_LINGUAS="cs de fr ja nn pl ru tr zh_CN"
-for lingua in ${IUSE_LINGUAS}; do
- IUSE+=" linguas_${lingua}"
-done
-unset lingua
-RESTRICT="test"
-
-RDEPEND="expat? ( dev-libs/expat )
- !expat? ( dev-libs/libxml2 )
- gnutls? (
- >=net-libs/gnutls-2.0
- pkcs11? ( dev-libs/pakchois )
- )
- !gnutls? ( ssl? (
- >=dev-libs/openssl-0.9.6f
- pkcs11? ( dev-libs/pakchois )
- ) )
- kerberos? ( virtual/krb5 )
- nls? ( virtual/libintl )
- socks5? ( net-proxy/dante )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- local lingua linguas
- for lingua in ${IUSE_LINGUAS}; do
- use linguas_${lingua} && linguas+=" ${lingua}"
- done
- sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
- sed -i -e "s/socks5/socks/g" macros/neon.m4
-
- AT_M4DIR="macros" eautoreconf
-
- elibtoolize
-}
-
-src_configure() {
- local myconf
-
- if has_version sys-libs/glibc; then
- einfo "Enabling SSL library thread-safety using POSIX threads..."
- myconf+=" --enable-threadsafe-ssl=posix"
- fi
-
- if use expat; then
- myconf+=" --with-expat"
- else
- myconf+=" --with-libxml2"
- fi
-
- if use gnutls; then
- myconf+=" --with-ssl=gnutls"
- elif use ssl; then
- myconf+=" --with-ssl=openssl"
- fi
-
- econf \
- --enable-static \
- --enable-shared \
- $(use_with kerberos gssapi) \
- $(use_enable nls) \
- $(use_with pkcs11 pakchois) \
- $(use_with socks5 socks) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install-lib install-headers install-config install-nls || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" install-docs || die "emake install-docs failed"
- fi
-
- dodoc AUTHORS BUGS NEWS README THANKS TODO
- doman doc/man/*.[1-8]
-}
-
-pkg_postinst() {
- ewarn "Neon has a policy of breaking API across minor versions, this means"
- ewarn "that any package that links against Neon may be broken after"
- ewarn "updating. They will remain broken until they are ported to the"
- ewarn "new API. You can downgrade Neon to the previous version by doing:"
- ewarn
- ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
- ewarn
- ewarn "You may also have to downgrade any package that has not been"
- ewarn "ported to the new API yet."
-}
diff --git a/net-misc/scponly/Manifest b/net-misc/scponly/Manifest
index a3bbcb3d29f4..0d926323355f 100644
--- a/net-misc/scponly/Manifest
+++ b/net-misc/scponly/Manifest
@@ -1,9 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
AUX scponly-4.8-gcc4.4.0.patch 571 RMD160 acb834c4fba11b7f412c930b74ffba6782acf579 SHA1 6b1e6dc884121709d0490dd8b37507826ee1779a SHA256 bf89c4b56552654140c93b5cf3090370c24ee20e5870f0cf0df76218e52e15b2
AUX scponly-4.8-rsync.patch 7838 RMD160 fc7464eeab781ed51ba85b8120489e10b9db1442 SHA1 992e58ddc5ea7334cf9b72324a96f149b298c210 SHA256 bfab1408ad8cfdfd8fc7f9b583c57a5c6b73be36cb3955db46e4c892acd7e55e
DIST scponly-4.8.tgz 101687 RMD160 de6b58fcb8108d42a1576c69003e9136b9417869 SHA1 154de34901ce22fd9d406f6e02cddc440c435afc SHA256 1693dd678355749c5d9e48ecdd4628dbfe71d82955afde950ee8d88b5adc01cf
-EBUILD scponly-4.8-r1.ebuild 8903 RMD160 3d8cb5017aeb1a0757c536d2c725320b65122e01 SHA1 90299bcae8b562f2112e63f10eb5d720a3293323 SHA256 f3f19a50e52c52012f31a589e3b88a12fbb0818a54b9a92433041b9281a61420
-EBUILD scponly-4.8-r2.ebuild 8992 RMD160 1e5ce20bac50f1d4ce2f30e0e2d4dc1317ba9831 SHA1 bc317f4b3660bfa2f5c4fed198436c2df5518210 SHA256 0b832b322733cce99806d5be1dd86cde459d76dd28b6ffbcf4aefd4e1e3b42b1
EBUILD scponly-4.8-r3.ebuild 9049 RMD160 738040d742bd6ce07155e7996cd4a03e89aad05e SHA1 7df7e1402591360144076607e5b1941ddb3bae6e SHA256 89048b3f8b617f6d07fa52559825054057e8eac95945e3568ad599ef498655ac
EBUILD scponly-4.8.ebuild 4283 RMD160 2e555f2bf02554ccf2c6005476c90e637690e3be SHA1 a73ad3c22ba463951c3827f5b1a515fd3e621a13 SHA256 ea3d3d88d8079353a846129de71679bcdf7021f2f91593a0ee95d218a9c11a90
-MISC ChangeLog 6458 RMD160 2dac7f152021592dff473feaadbb66ee37a12050 SHA1 70abcfcf57a646ba4a2ed609924c3e7a0135c10c SHA256 27f40667e9fae128736355387a72c000477382fe98c04e1322f09914340eeb36
+MISC ChangeLog 6590 RMD160 84c54e1041903056e8bc6ba1f62650de8a660208 SHA1 7dad4851edd66cbaaa95ffe24563df8c2b6f242d SHA256 c9582ce60870df6515b39c516a15df5aeb28f891eabc4d36de0d51a592d02ed9
MISC metadata.xml 1424 RMD160 bedfada17f8ebfb8964a627769b1f6f96114ada4 SHA1 c7063171c58a7d6195e291232b96820957df8fbf SHA256 39e481515e78825063291d053dd92d5652d0c824b706e67dadaccecdcad491e2
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.11 (GNU/Linux)
+
+iEYEARECAAYFAkqYTAMACgkQcxLzpIGCsLRmPgCfWmcf+VLlpktzi9IPqkBo8itK
+jDcAniJu1TzqxhMUj5O5ezdNYe4tCM/A
+=I4Zs
+-----END PGP SIGNATURE-----