summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-06-24 08:45:02 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-06-24 08:45:02 +0000
commitffbe29c422ac0730c7062a856bd528be5fdf6794 (patch)
treeb0e3ae9b3f6346242409980d399804fe6ed4f5b2
parentBump to 3.4.2 (diff)
downloadhistorical-ffbe29c422ac0730c7062a856bd528be5fdf6794.tar.gz
historical-ffbe29c422ac0730c7062a856bd528be5fdf6794.tar.bz2
historical-ffbe29c422ac0730c7062a856bd528be5fdf6794.zip
Bump to 3.4.3
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog8
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.4.3.ebuild140
-rw-r--r--gnome-extra/evolution-ews/ChangeLog8
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.4.3.ebuild38
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog8
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-3.4.3.ebuild44
6 files changed, 243 insertions, 3 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index efc9be9c0b94..a181e17affb7 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.337 2012/06/20 06:51:30 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.338 2012/06/24 08:45:02 nirbheek Exp $
+
+*evolution-data-server-3.4.3 (24 Jun 2012)
+
+ 24 Jun 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +evolution-data-server-3.4.3.ebuild:
+ Bump to 3.4.3
20 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
evolution-data-server-3.2.3-r2.ebuild:
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.4.3.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.4.3.ebuild
new file mode 100644
index 000000000000..2badf2e1711e
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.4.3.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-3.4.3.ebuild,v 1.1 2012/06/24 08:45:02 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit db-use eutils flag-o-matic gnome2 versionator virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2 BSD DB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+IUSE="doc +gnome-online-accounts +introspection ipv6 ldap kerberos vala +weather"
+
+RDEPEND=">=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.2:3
+ >=gnome-base/gconf-2
+ >=dev-db/sqlite-3.5
+ >=dev-libs/libgdata-0.10
+ >=gnome-base/gnome-keyring-2.20.1
+ >=dev-libs/dbus-glib-0.6
+ >=dev-libs/libical-0.43
+ >=net-libs/libsoup-2.31.2:2.4
+ >=dev-libs/libxml2-2
+ >=sys-libs/db-4
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9
+
+ sys-libs/zlib
+ virtual/libiconv
+
+ gnome-online-accounts? (
+ >=net-libs/gnome-online-accounts-3.1.1
+ >=net-libs/liboauth-0.9.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12 )
+ kerberos? ( virtual/krb5 )
+ ldap? ( >=net-nds/openldap-2 )
+ weather? ( >=dev-libs/libgweather-2.90.0:2 )
+"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/gperf
+ >=dev-util/intltool-0.35.5
+ sys-devel/bison
+ >=gnome-base/gnome-common-2
+ >=dev-util/gtk-doc-am-1.9
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.14 )
+ vala? ( >=dev-lang/vala-0.13.0:0.14[vapigen] )"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2
+# >=dev-util/gtk-doc-am-1.9
+
+REQUIRED_USE="vala? ( introspection )"
+
+# FIXME
+RESTRICT="test"
+
+pkg_setup() {
+ DOCS="ChangeLog MAINTAINERS NEWS TODO"
+ # Uh, what to do about dbus-call-timeout ?
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ VALAC=$(type -P valac-0.14)
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable gnome-online-accounts goa)
+ $(use_enable introspection)
+ $(use_enable ipv6)
+ $(use_with kerberos krb5 ${EPREFIX}/usr)
+ $(use_with ldap openldap)
+ $(use_enable vala vala-bindings)
+ $(use_enable weather)
+ --enable-nntp
+ --enable-largefile
+ --enable-smime
+ --with-libdb=${EPREFIX}/usr"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # GNOME bug 611353 (skips failing test atm)
+ # XXX: uncomment when there's a proper fix
+ #epatch "${FILESDIR}/e-d-s-camel-skip-failing-test.patch"
+
+ # GNOME bug 621763 (skip failing test-ebook-stress-factory--fifo)
+ #sed -e 's/\(SUBDIRS =.*\)ebook/\1/' \
+ # -i addressbook/tests/Makefile.{am,in} \
+ # || die "failing test sed 1 failed"
+
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ append-cppflags "-I$(db_includedir)"
+
+ # FIXME: Fix compilation flags crazyness
+ # Touch configure.ac if doing eautoreconf
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure || die "sed failed"
+}
+
+src_install() {
+ # Prevent this evolution-data-server from linking to libs in the installed
+ # evolution-data-server libraries by adding -L arguments for build dirs to
+ # every .la file's relink_command field, forcing libtool to look there
+ # first during relinking. This will mangle the .la files installed by
+ # make install, but we don't care because we will be punting them anyway.
+ perl "${FILESDIR}/fix_relink_command.pl" . ||
+ die "fix_relink_command.pl failed"
+ gnome2_src_install
+
+ if use ldap; then
+ MY_MAJORV=$(get_version_component_range 1-2)
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema || die "doins failed"
+ dosym /usr/share/${PN}-${MY_MAJORV}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ unset ORBIT_SOCKETDIR
+ unset SESSION_MANAGER
+ export XDG_DATA_HOME="${T}"
+ unset DISPLAY
+ Xemake check || die "Tests failed."
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use ldap; then
+ elog ""
+ elog "LDAP schemas needed by evolution are installed in /etc/openldap/schema"
+ fi
+}
diff --git a/gnome-extra/evolution-ews/ChangeLog b/gnome-extra/evolution-ews/ChangeLog
index 5240d55c97f4..577fb48946ab 100644
--- a/gnome-extra/evolution-ews/ChangeLog
+++ b/gnome-extra/evolution-ews/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-ews
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-ews/ChangeLog,v 1.1 2012/05/07 05:59:00 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-ews/ChangeLog,v 1.2 2012/06/24 08:44:48 nirbheek Exp $
+
+*evolution-ews-3.4.3 (24 Jun 2012)
+
+ 24 Jun 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +evolution-ews-3.4.3.ebuild:
+ Bump to 3.4.3
*evolution-ews-3.4.1 (07 May 2012)
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.4.3.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.4.3.ebuild
new file mode 100644
index 000000000000..7aa9e2717f7a
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-ews/evolution-ews-3.4.3.ebuild,v 1.1 2012/06/24 08:44:48 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit db-use eutils flag-o-matic gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="" # doc
+
+RDEPEND=">=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}
+ >=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2
+ >=gnome-base/gconf-2:2
+ >=net-libs/libsoup-2.30:2.4
+ >=x11-libs/gtk+-2.90.4:3
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+# For now, this package has no gtk-doc documentation to build
+# doc? ( >=dev-util/gtk-doc-1.9 )
+
+RESTRICT="test" # tests require connecting to an Exchange server
+
+pkg_setup() {
+ DOCS="ChangeLog NEWS README" # AUTHORS is empty
+}
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index 0bffc18d7e57..b3213deccf4b 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.147 2012/05/07 05:58:29 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.148 2012/06/24 08:45:00 nirbheek Exp $
+
+*evolution-exchange-3.4.3 (24 Jun 2012)
+
+ 24 Jun 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +evolution-exchange-3.4.3.ebuild:
+ Bump to 3.4.3
*evolution-exchange-3.4.1 (07 May 2012)
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-3.4.3.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-3.4.3.ebuild
new file mode 100644
index 000000000000..4bcccc061a1b
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-3.4.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-3.4.3.ebuild,v 1.1 2012/06/24 08:45:00 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+IUSE="debug doc static"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}[ldap,kerberos]
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.0:3
+ >=gnome-base/gconf-2:2
+ >=dev-libs/libical-0.43
+ dev-libs/libxml2:2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2
+ virtual/krb5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-krb5=${EPREFIX}/usr
+ --with-openldap
+ --disable-static
+ $(use_enable debug e2k-debug)
+ $(use_with static static-ldap)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}