summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-03-12 00:22:39 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-03-12 00:22:39 +0000
commitaad6393eaf5ff72e9f9505162c790f3f9765a685 (patch)
tree180189a661b5bb734165f29cb64309d1a1c2565e /app-accessibility
parentphase out old kpowersave powersave daemon (diff)
downloadhistorical-aad6393eaf5ff72e9f9505162c790f3f9765a685.tar.gz
historical-aad6393eaf5ff72e9f9505162c790f3f9765a685.tar.bz2
historical-aad6393eaf5ff72e9f9505162c790f3f9765a685.zip
Fixed the ebuild so that the correct options are passed to make if no audio output option is in the use flags.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak/ChangeLog6
-rw-r--r--app-accessibility/espeak/Manifest4
-rw-r--r--app-accessibility/espeak/espeak-1.36.ebuild45
3 files changed, 32 insertions, 23 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index 6b0dd7839095..b4e2bc0555fb 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.35 2008/03/10 01:01:41 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.36 2008/03/12 00:22:39 williamh Exp $
+
+ 12 Mar 2008; William Hubbs <williamh@gentoo.org> espeak-1.36.ebuild:
+ Updated the ebuild to pass the correct options to make if neither portaudio
+ nor pulseaudio is in the use flags.
*espeak-1.36 (10 Mar 2008)
diff --git a/app-accessibility/espeak/Manifest b/app-accessibility/espeak/Manifest
index c096bbc6d396..155fa64b07ac 100644
--- a/app-accessibility/espeak/Manifest
+++ b/app-accessibility/espeak/Manifest
@@ -1,6 +1,6 @@
DIST espeak-1.25-source.zip 912952 RMD160 68c06d6ca30b3bf3c5b865151b1c3d720c9a5626 SHA1 2287553f0a80d38487500d7ce42c5221627ef1ae SHA256 981ccad8255677aa6858d7b206cebed183c9d4586ed886da707259e5b379e302
DIST espeak-1.36-source.zip 1269634 RMD160 a97023a673f0535b9a40e46f2c977a9557dd5a4a SHA1 c02718d8e135002b6931324e8da509aa749493ef SHA256 245e1a15271e3e8e51a4196336cabc2e164c664c5f73d08789cc2efce91e094a
EBUILD espeak-1.25.ebuild 1438 RMD160 518d275393a41030ad1122e7e60ec6ed43071f40 SHA1 99c12a17a49679bbccff243e2cc682cb21f3c586 SHA256 4148b52d32ce6be315b2e5a9fda2f3d021b150fcf66b0b4c644dcf6e1cd76955
-EBUILD espeak-1.36.ebuild 1836 RMD160 19a9b5b0bc4b9ffa6e3f62d6ef190a90fa737bc0 SHA1 0e85279848527797998b7b2f00ed058a6d4bbd72 SHA256 497f639dd4d0ec2d6eb78de6583eff993c568821142c9c7fac14915e63c8b140
-MISC ChangeLog 5860 RMD160 50d6b7e8238991032679a988bd299d14ba84081e SHA1 9a7e1ad1a220d9a2358d7dfaf4c512c6f1d0596a SHA256 77930aa70b9c4f2d96a73ef01d6fc61ad17cb189ba43df4be2f87d610637c8a6
+EBUILD espeak-1.36.ebuild 1928 RMD160 dfb278389e689d281dd73e7019e647ff553b739f SHA1 70cfb3bd10bd6ed88a0f4e4b67044510950ebe55 SHA256 026c4408e865975ed61902e68db1c82bccf2de0e1bf1115f9156e8df5108c1da
+MISC ChangeLog 6048 RMD160 6e14cc700e29319c82c87dfc208c8e2a69305577 SHA1 90c32a6681d32ed2da6733aac72159315d1b24f4 SHA256 6a47c3f534e1fea946c429741616ad5961fe3184a706d0542ab1de2bd7924d70
MISC metadata.xml 229 RMD160 7f8d6a0235529eccff705022803122c9534628d7 SHA1 2295356b566d60c8eb979db0e598de9d1d8ccf49 SHA256 b128d301356b3f98f1d6093b4401c36143ff55fc62636612567b0995739b9e66
diff --git a/app-accessibility/espeak/espeak-1.36.ebuild b/app-accessibility/espeak/espeak-1.36.ebuild
index ae5b01fb3527..85a6b900151c 100644
--- a/app-accessibility/espeak/espeak-1.36.ebuild
+++ b/app-accessibility/espeak/espeak-1.36.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.36.ebuild,v 1.1 2008/03/10 01:01:41 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.36.ebuild,v 1.2 2008/03/12 00:22:39 williamh Exp $
inherit eutils
@@ -18,15 +18,29 @@ DEPEND="portaudio? ( >=media-libs/portaudio-18.1-r5 )
S=${WORKDIR}/${MY_P}
+get_audio() {
+ local MY_AUDIO
+
+ MY_AUDIO=none
+ if use portaudio; then
+ MY_AUDIO=portaudio
+ elif use pulseaudio; then
+ MY_AUDIO=pulseaudio
+ fi
+ echo ${MY_AUDIO}
+}
+
pkg_setup() {
- if ! use portaudio -a ! ! use pulseaudio; then
- ewarn
- ewarn Since portaudio and pulseaudio are not in your use flags, espeak
- ewarn will only bbe able to create wav files.
- ewarn If this is not what you want, press ctrl-c and put either
- ewarn portaudio or pulseaudio in your use flags.
- ebeep
- epause 10
+ if ! use portaudio; then
+ if ! use pulseaudio; then
+ ewarn
+ ewarn Since portaudio and pulseaudio are not in your use flags, espeak
+ ewarn will only bbe able to create wav files.
+ ewarn If this is not what you want, press ctrl-c and put either
+ ewarn portaudio or pulseaudio in your use flags.
+ ebeep
+ epause 10
+ fi
fi
}
@@ -43,17 +57,8 @@ src_unpack() {
}
src_compile() {
- local MY_AUDIO
-
cd src
-
- if use portaudio; then
- MY_AUDIO=portaudio
- elif use pulseaudio; then
- MY_AUDIO=pulseaudio
- fi
-
- emake AUDIO="${MY_AUDIO}" CXXFLAGS="${CXXFLAGS}" || die "Compilation failed"
+ emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
einfo "Fixing byte order of phoneme data files"
cd "${S}/platforms/big_endian"
@@ -64,7 +69,7 @@ src_compile() {
src_install() {
cd src
- make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die "Installation failed"
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
cd ..
dodoc ChangeLog ReadMe