summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-21 10:00:20 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-21 10:00:20 +0000
commit1ab7ad255435e95d1f86f963d448b1bba93b4f10 (patch)
tree57d45d12080c3f6fd2f5a3efaab5018529dfe211 /app-benchmarks/siege
parentinitscript updates (diff)
downloadhistorical-1ab7ad255435e95d1f86f963d448b1bba93b4f10.tar.gz
historical-1ab7ad255435e95d1f86f963d448b1bba93b4f10.tar.bz2
historical-1ab7ad255435e95d1f86f963d448b1bba93b4f10.zip
Added command-line completion for siege.
Diffstat (limited to 'app-benchmarks/siege')
-rw-r--r--app-benchmarks/siege/ChangeLog6
-rw-r--r--app-benchmarks/siege/Manifest13
-rw-r--r--app-benchmarks/siege/files/siege.bash-completion25
-rw-r--r--app-benchmarks/siege/siege-2.60.ebuild7
-rw-r--r--app-benchmarks/siege/siege-2.61.ebuild7
5 files changed, 45 insertions, 13 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index e1e7eed0df64..c49bcf15c07c 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-benchmarks/siege
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.19 2004/11/20 16:40:04 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.20 2004/11/21 10:00:20 ka0ttic Exp $
+
+ 21 Nov 2004; Aaron Walker <ka0ttic@gentoo.org>
+ +files/siege.bash-completion, siege-2.60.ebuild, siege-2.61.ebuild:
+ Added command-line completion for siege.
*siege-2.61 (20 Nov 2004)
diff --git a/app-benchmarks/siege/Manifest b/app-benchmarks/siege/Manifest
index 354a46651132..d6a98fb93e24 100644
--- a/app-benchmarks/siege/Manifest
+++ b/app-benchmarks/siege/Manifest
@@ -1,17 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 8270d0d683a7d297d3ebccdc7fd86389 siege-2.60.ebuild 1126
-MD5 0b15a0443e97d9cbc5650a8d28eea2de ChangeLog 1969
+MD5 97ecac5b00a36c3cab3cee1d19fc3a6c siege-2.60.ebuild 1224
+MD5 b33c119c86dc0fd03cf6fb39cec3ddd8 ChangeLog 2132
MD5 f8d10f350e91f30316ea4e1bd1e76470 metadata.xml 254
-MD5 f52c9304b8bf73e81b632465f842b019 siege-2.61.ebuild 1134
+MD5 05b2969c91a54299ef3b0df40d37b7b3 siege-2.61.ebuild 1232
MD5 9e437904b960c0cab42d691c8678774b files/siege-2.60-gentoo.diff 1740
+MD5 16fc2e7263b085c5c027844be0fdc63f files/siege.bash-completion 783
MD5 1185a0d2d8ac987001f575f8eb302327 files/digest-siege-2.60 62
MD5 777c4d7f0fca11bdfc849cb76422dde9 files/digest-siege-2.61 62
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBn3N5EZCkKN40op4RAuR8AKCszoAoZTtxpLhU3WVSBX6NH6qh/gCgwRLa
-G+O4RlNzt7v6E7Nkq+H4LwQ=
-=0qSF
+iD8DBQFBoGc9EZCkKN40op4RAl/BAKCT2dmQOTU3B2aoQciI6O1slh3WVwCdEbk8
+VmRxzh4hNi1tw5FJn22WwiY=
+=AZpa
-----END PGP SIGNATURE-----
diff --git a/app-benchmarks/siege/files/siege.bash-completion b/app-benchmarks/siege/files/siege.bash-completion
new file mode 100644
index 000000000000..f74cc79ecc3f
--- /dev/null
+++ b/app-benchmarks/siege/files/siege.bash-completion
@@ -0,0 +1,25 @@
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/files/siege.bash-completion,v 1.1 2004/11/21 10:00:20 ka0ttic Exp $
+# siege completion
+
+_siege() {
+ local cur prev opts
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-V --version -h --help -C --config -v --verbose -g --get \
+ -c --concurrent -i --internet -d --delay -b --benchmark -r --reps \
+ -t --time -l --log -m --mark -H --header -R --rc -f --file -u --url"
+
+ if [[ "${cur}" == -* ]] || [ ${COMP_CWORD} -eq 1 ]; then
+ COMPREPLY=($(compgen -W "${opts}" -- ${cur}))
+ fi
+
+ case "${prev}" in
+ -R|--rc|-f|--file)
+ COMPREPLY=($(compgen -o filenames -A file -- ${cur}))
+ ;;
+ esac
+}
+complete -F _siege siege
+
+# vim: set ft=sh tw=80 ts=4 sw=4 :
diff --git a/app-benchmarks/siege/siege-2.60.ebuild b/app-benchmarks/siege/siege-2.60.ebuild
index 23cc440b11e9..f7dc5ccd2c9d 100644
--- a/app-benchmarks/siege/siege-2.60.ebuild
+++ b/app-benchmarks/siege/siege-2.60.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.60.ebuild,v 1.7 2004/11/20 16:40:04 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.60.ebuild,v 1.8 2004/11/21 10:00:20 ka0ttic Exp $
-inherit eutils
+inherit eutils bash-completion
DESCRIPTION="A HTTP regression testing and benchmarking utility"
HOMEPAGE="http://www.joedog.org/siege/"
@@ -35,11 +35,12 @@ src_install() {
dodoc AUTHORS ChangeLog INSTALL MACHINES README KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
use ssl && dodoc README.https
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion ${PN}
}
pkg_postinst() {
echo
einfo "An example ~/.siegerc file has been installed as"
einfo "/usr/share/doc/${PF}/siegerc-example.gz"
- echo
+ bash-completion_pkg_postinst
}
diff --git a/app-benchmarks/siege/siege-2.61.ebuild b/app-benchmarks/siege/siege-2.61.ebuild
index f4bb89912ead..7a3b21e0017e 100644
--- a/app-benchmarks/siege/siege-2.61.ebuild
+++ b/app-benchmarks/siege/siege-2.61.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.61.ebuild,v 1.1 2004/11/20 16:40:04 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.61.ebuild,v 1.2 2004/11/21 10:00:20 ka0ttic Exp $
-inherit eutils
+inherit eutils bash-completion
DESCRIPTION="A HTTP regression testing and benchmarking utility"
HOMEPAGE="http://www.joedog.org/siege/"
@@ -35,11 +35,12 @@ src_install() {
dodoc AUTHORS ChangeLog INSTALL MACHINES README KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
use ssl && dodoc README.https
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion ${PN}
}
pkg_postinst() {
echo
einfo "An example ~/.siegerc file has been installed as"
einfo "/usr/share/doc/${PF}/siegerc-example.gz"
- echo
+ bash-completion_pkg_postinst
}