summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-11-03 21:47:24 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-11-03 21:47:24 +0000
commitb0bc08f7c9abf81ba88905f2a190570b199ec9c1 (patch)
treee270374c971d4679567f505fe6e8f7c91a9e44d8 /app-benchmarks
parentMarking iprutils-2.0.15.3-r1 ~ppc for 32bit ppc64 userlands (diff)
downloadhistorical-b0bc08f7c9abf81ba88905f2a190570b199ec9c1.tar.gz
historical-b0bc08f7c9abf81ba88905f2a190570b199ec9c1.tar.bz2
historical-b0bc08f7c9abf81ba88905f2a190570b199ec9c1.zip
Add some sedfu to escape certain things in the siege.config script that get interpreted by bash causing what should go in ${HOME}/.siegerc to go to stderr instead, bug 111057.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog8
-rw-r--r--app-benchmarks/siege/Manifest14
-rw-r--r--app-benchmarks/siege/siege-2.60.ebuild9
-rw-r--r--app-benchmarks/siege/siege-2.61.ebuild9
-rw-r--r--app-benchmarks/siege/siege-2.64.ebuild9
5 files changed, 38 insertions, 11 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index 06e13bb1c797..0ddbf66ffd39 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/siege
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.32 2005/10/14 20:25:49 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.33 2005/11/03 21:47:24 ka0ttic Exp $
+
+ 03 Nov 2005; Aaron Walker <ka0ttic@gentoo.org> siege-2.60.ebuild,
+ siege-2.61.ebuild, siege-2.64.ebuild:
+ Add some sedfu to escape certain things in the siege.config script that get
+ interpreted by bash causing what should go in ${HOME}/.siegrc to go to
+ stderr instead, bug 111057.
*siege-2.64 (14 Oct 2005)
diff --git a/app-benchmarks/siege/Manifest b/app-benchmarks/siege/Manifest
index aac233ea4de7..b4b2ed4a5ac6 100644
--- a/app-benchmarks/siege/Manifest
+++ b/app-benchmarks/siege/Manifest
@@ -1,20 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 79909ee6dc6c868f3c9165c96b8d4c51 ChangeLog 3587
+MD5 1b6dfdd5b425ec9840b7ec2c286e33cc ChangeLog 3877
MD5 1185a0d2d8ac987001f575f8eb302327 files/digest-siege-2.60 62
MD5 777c4d7f0fca11bdfc849cb76422dde9 files/digest-siege-2.61 62
MD5 6f081910176735dfe5a4ab9bcc7203c2 files/digest-siege-2.64 62
MD5 9e437904b960c0cab42d691c8678774b files/siege-2.60-gentoo.diff 1740
MD5 16fc2e7263b085c5c027844be0fdc63f files/siege.bash-completion 783
MD5 15d8ee1460109dffd23fe7d243b750bd metadata.xml 257
-MD5 c8390cbc140a9b92aa12c49879d70e42 siege-2.60.ebuild 1230
-MD5 511ccfc31bba3b79faa278eca7c02a62 siege-2.61.ebuild 1242
-MD5 fd8342bc08ed1adfc5e738c7a9f6ff07 siege-2.64.ebuild 1524
+MD5 58eac526181cbc7c3337fdaea49ab8ab siege-2.60.ebuild 1460
+MD5 487ef6398e122bed77abf2f504c23e24 siege-2.61.ebuild 1470
+MD5 7af63078bec21f6367cd1d119c7afe82 siege-2.64.ebuild 1752
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDUBRvEZCkKN40op4RAre5AJ0f3YSO/mz+WAZ52uYlZ7k8uhcK4QCeIi3Y
-XRSHHGtXfBly1TvzT/flONw=
-=pSTM
+iD8DBQFDaoV/EZCkKN40op4RAs1fAJ9K6k46UPEaeSHQzt04lpylu5T+ZwCgndrd
+YT3ZvC3UZfG6eIZvjzQJ2a4=
+=GTJT
-----END PGP SIGNATURE-----
diff --git a/app-benchmarks/siege/siege-2.60.ebuild b/app-benchmarks/siege/siege-2.60.ebuild
index cf733115f434..b634c7041e66 100644
--- a/app-benchmarks/siege/siege-2.60.ebuild
+++ b/app-benchmarks/siege/siege-2.60.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.60.ebuild,v 1.10 2005/02/26 19:10:10 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.60.ebuild,v 1.11 2005/11/03 21:47:24 ka0ttic Exp $
inherit eutils bash-completion
@@ -32,6 +32,13 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
dodoc AUTHORS ChangeLog INSTALL MACHINES README KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
use ssl && dodoc README.https
diff --git a/app-benchmarks/siege/siege-2.61.ebuild b/app-benchmarks/siege/siege-2.61.ebuild
index e12813bbb1b5..bde55ee653ec 100644
--- a/app-benchmarks/siege/siege-2.61.ebuild
+++ b/app-benchmarks/siege/siege-2.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.61.ebuild,v 1.8 2005/09/08 16:52:50 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.61.ebuild,v 1.9 2005/11/03 21:47:24 ka0ttic Exp $
inherit eutils bash-completion
@@ -32,6 +32,13 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
dodoc AUTHORS ChangeLog INSTALL MACHINES README KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
use ssl && dodoc README.https
diff --git a/app-benchmarks/siege/siege-2.64.ebuild b/app-benchmarks/siege/siege-2.64.ebuild
index 9fc659985ff8..66890b3c9b30 100644
--- a/app-benchmarks/siege/siege-2.64.ebuild
+++ b/app-benchmarks/siege/siege-2.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.64.ebuild,v 1.1 2005/10/14 20:25:49 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.64.ebuild,v 1.2 2005/11/03 21:47:24 ka0ttic Exp $
inherit eutils bash-completion
@@ -42,6 +42,13 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
siegerc-example urls.txt || die "dodoc failed"
dobashcompletion ${FILESDIR}/${PN}.bash-completion