summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-04-09 22:17:33 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-04-09 22:17:33 +0000
commit124da07ad52bbe5df163c1121f8f3c5afbc9d2be (patch)
tree9976190b5680d8b1075963650fc4eac91413c58b /app-crypt/chntpw
parentMarked ~amd64, closes bug 88482. (diff)
downloadhistorical-124da07ad52bbe5df163c1121f8f3c5afbc9d2be.tar.gz
historical-124da07ad52bbe5df163c1121f8f3c5afbc9d2be.tar.bz2
historical-124da07ad52bbe5df163c1121f8f3c5afbc9d2be.zip
gcc4 patch
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-crypt/chntpw')
-rw-r--r--app-crypt/chntpw/ChangeLog6
-rw-r--r--app-crypt/chntpw/Manifest5
-rw-r--r--app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild11
-rw-r--r--app-crypt/chntpw/files/chntpw-0.99.3.20040818-gcc4.diff40
4 files changed, 56 insertions, 6 deletions
diff --git a/app-crypt/chntpw/ChangeLog b/app-crypt/chntpw/ChangeLog
index af7d346f8fab..340f6b94fcb8 100644
--- a/app-crypt/chntpw/ChangeLog
+++ b/app-crypt/chntpw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/chntpw
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.5 2005/01/07 12:34:21 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/ChangeLog,v 1.6 2005/04/09 22:17:33 vanquirius Exp $
+
+ 09 Apr 2005; Marcelo Goes <vanquirius@gentoo.org>
+ +files/chntpw-0.99.3.20040818-gcc4.diff, chntpw-0.99.3.20040818.ebuild:
+ Adding gcc4 patch from Debian.
07 Jan 2005; Robin H. Johnson <robbat2@gentoo.org>
chntpw-0.99.3.20040818.ebuild:
diff --git a/app-crypt/chntpw/Manifest b/app-crypt/chntpw/Manifest
index 183323da7dd8..0386c32910db 100644
--- a/app-crypt/chntpw/Manifest
+++ b/app-crypt/chntpw/Manifest
@@ -1,4 +1,5 @@
-MD5 663eb6163983f460a894df8e0b477007 chntpw-0.99.3.20040818.ebuild 694
-MD5 c555b344d473d65de666b0dc07331224 ChangeLog 747
+MD5 f4bc62dd0a8d53754908498283abefd8 chntpw-0.99.3.20040818.ebuild 777
+MD5 62fce6cbbd6350c1ec19e6087444a2e9 ChangeLog 910
MD5 a5ab3618f9cd3d7433bdfa40ae257618 metadata.xml 222
+MD5 b6c2d8532ea340448a1c1b03f70acdfb files/chntpw-0.99.3.20040818-gcc4.diff 1328
MD5 67f4823ebe707ddcadb41da795b88a5f files/digest-chntpw-0.99.3.20040818 68
diff --git a/app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild b/app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild
index 5d8957fe20ea..498f0ec681b8 100644
--- a/app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild
+++ b/app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild,v 1.5 2005/01/07 12:34:21 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/chntpw/chntpw-0.99.3.20040818.ebuild,v 1.6 2005/04/09 22:17:33 vanquirius Exp $
+
+inherit eutils
DESCRIPTION="Offline Windows NT Password & Registry Editor"
HOMEPAGE="http://home.eunet.no/~pnordahl/ntpasswd/"
@@ -14,6 +16,11 @@ SRC_URI="http://home.eunet.no/~pnordahl/ntpasswd/chntpw-source-${MY_PV}.zip"
IUSE=""
S="${WORKDIR}"
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc4.diff
+}
+
src_compile() {
emake LIBS="-lcrypto" CFLAGS="${CFLAGS}" || die "emake failed"
}
@@ -23,5 +30,3 @@ src_install() {
dobin chntpw
dodoc *.txt
}
-
-
diff --git a/app-crypt/chntpw/files/chntpw-0.99.3.20040818-gcc4.diff b/app-crypt/chntpw/files/chntpw-0.99.3.20040818-gcc4.diff
new file mode 100644
index 000000000000..21ecc2bf87e9
--- /dev/null
+++ b/app-crypt/chntpw/files/chntpw-0.99.3.20040818-gcc4.diff
@@ -0,0 +1,40 @@
+--- chntpw/chntpw.c 2004-08-18 17:42:01.000000000 -0300
++++ chntpw.new/chntpw.c 2005-04-09 18:58:34.000000000 -0300
+@@ -511,7 +511,7 @@
+ printf("** LANMAN password IS however set. Will now install new password as NT pass instead.\n");
+ printf("** NOTE: Continue at own risk!\n");
+ ntpw_offs = lmpw_offs;
+- (unsigned int)*(vp+0xa8) = ntpw_offs - 0xcc;
++ *((unsigned int*)vp+0xa8) = ntpw_offs - 0xcc;
+ ntpw_len = 16;
+ lmpw_len = 0;
+ }
+@@ -621,14 +621,14 @@
+ ntpw_len = 16;
+ lmpw_len = 16;
+ ntpw_offs -= 4;
+- (unsigned int)*(vp+0xa8) = ntpw_offs - 0xcc;
++ *((unsigned int*)vp+0xa8) = ntpw_offs - 0xcc;
+ *(vp + 0xa0) = 16;
+ *(vp + 0xac) = 16;
+ }
+
+ for (i = 0; i < 16; i++) {
+- (unsigned char)*(vp+ntpw_offs+i) = despw[i];
+- if (lmpw_len >= 16) (unsigned char)*(vp+lmpw_offs+i) = newlandes[i];
++ *(vp+ntpw_offs+i) = (char)despw[i];
++ if (lmpw_len >= 16) *(vp+lmpw_offs+i) = (char)newlandes[i];
+ }
+ } else {
+ printf("Unable to set since it is blank.\n");
+--- chntpw/ntreg.c 2004-08-18 17:42:02.000000000 -0300
++++ chntpw.new/ntreg.c 2005-04-09 19:07:50.000000000 -0300
+@@ -2514,7 +2514,7 @@
+ ALLOC(kr,1,sizeof(int)+sizeof(int));
+
+ kr->len = sizeof(int);
+- (int)kr->data = dword;
++ kr->data = dword;
+
+ r = put_buf2val(hdesc, kr, vofs, path, REG_DWORD);
+