summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-12-18 16:14:20 +0000
committerMichael Januszewski <spock@gentoo.org>2004-12-18 16:14:20 +0000
commit98c16e142c2ad674229047cac3a8da4e23ac567c (patch)
tree9aaec1b64a65f607f79612217fe021b367e7b517 /app-dicts/ydpdict
parentadding support for automated modules.d file generation (diff)
downloadhistorical-98c16e142c2ad674229047cac3a8da4e23ac567c.tar.gz
historical-98c16e142c2ad674229047cac3a8da4e23ac567c.tar.bz2
historical-98c16e142c2ad674229047cac3a8da4e23ac567c.zip
Initial commit.
Diffstat (limited to 'app-dicts/ydpdict')
-rw-r--r--app-dicts/ydpdict/ChangeLog9
-rw-r--r--app-dicts/ydpdict/Manifest14
-rw-r--r--app-dicts/ydpdict/files/digest-ydpdict-0.631
-rw-r--r--app-dicts/ydpdict/metadata.xml8
-rw-r--r--app-dicts/ydpdict/ydpdict-0.63.ebuild36
5 files changed, 68 insertions, 0 deletions
diff --git a/app-dicts/ydpdict/ChangeLog b/app-dicts/ydpdict/ChangeLog
new file mode 100644
index 000000000000..80231e155346
--- /dev/null
+++ b/app-dicts/ydpdict/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-dicts/ydpdict
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ydpdict/ChangeLog,v 1.1 2004/12/18 16:14:20 spock Exp $
+
+*ydpdict-0.63 (18 Dec 2004)
+
+ 18 Dec 2004; Michal Januszewski <spock@gentoo.org> +ydpdict-0.63.ebuild:
+ Initial commit.
+
diff --git a/app-dicts/ydpdict/Manifest b/app-dicts/ydpdict/Manifest
new file mode 100644
index 000000000000..32beeaf32bf6
--- /dev/null
+++ b/app-dicts/ydpdict/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 1b7656a40a98b90ae24e09fb7f0a3a40 ChangeLog 329
+MD5 cfe1b5f88cc51ac6ffc42809178d2a06 metadata.xml 221
+MD5 7bc0ad9faeed264f284cd2f69da2eb27 ydpdict-0.63.ebuild 1119
+MD5 b0b14844966cea4dd2dea36f6c805f8c files/digest-ydpdict-0.63 63
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBxFdychej4aZK9/cRAvoMAJ4sYYeOR+WXzX8xv4cmAfZYAq6KRgCfS+ZQ
+bjOkeHDKtov+wclvuKAeIJQ=
+=6CSq
+-----END PGP SIGNATURE-----
diff --git a/app-dicts/ydpdict/files/digest-ydpdict-0.63 b/app-dicts/ydpdict/files/digest-ydpdict-0.63
new file mode 100644
index 000000000000..0935265bc580
--- /dev/null
+++ b/app-dicts/ydpdict/files/digest-ydpdict-0.63
@@ -0,0 +1 @@
+MD5 bd20edfa221ecb5f04ce6a36b1b15179 ydpdict-0.63.tar.gz 64184
diff --git a/app-dicts/ydpdict/metadata.xml b/app-dicts/ydpdict/metadata.xml
new file mode 100644
index 000000000000..28b373129e37
--- /dev/null
+++ b/app-dicts/ydpdict/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>spock@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-dicts/ydpdict/ydpdict-0.63.ebuild b/app-dicts/ydpdict/ydpdict-0.63.ebuild
new file mode 100644
index 000000000000..afdbed4767b5
--- /dev/null
+++ b/app-dicts/ydpdict/ydpdict-0.63.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ydpdict/ydpdict-0.63.ebuild,v 1.1 2004/12/18 16:14:20 spock Exp $
+
+DESCRIPTION="A Linux interface for the Collins Polish-English, English-Polish Dictionary."
+HOMEPAGE="http://toxygen.net/ydpdict/"
+SRC_URI="http://toxygen.net/${PN}/${P}.tar.gz"
+SLOT="0"
+DEPEND=""
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ mkdir -p ${D}/{usr/bin,etc}
+ einstall || die
+ dodoc README
+ sed -i "s#/usr/local/share/ydpdict#/usr/share/ydpdict#" ydpdict.conf.example
+ cp ydpdict.conf.example ${D}/etc/ydpdict.conf
+}
+
+pkg_postinst() {
+ echo ""
+ einfo "Note that to use this program you'll need the original Collins Dictionary"
+ einfo "datafiles (dict100.*, dict101.*). These can be found in the Dabasase/"
+ einfo "directory of the Windows version of the Collins dictionary. Once you obtain"
+ einfo "the files, put them into /usr/share/ydpdict"
+ einfo
+ einfo "Some configuration options can be set in /etc/ydpdict.conf"
+ echo ""
+}