summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-10-09 20:58:53 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-10-09 20:58:53 +0000
commit038a2a3fbb6eb0d731b320055a6fd29632c684ae (patch)
tree454bc2c459ec5d07a3df99409c0d2b0ad977fba0 /app-doc
parentnew mplayer release, fix issue, and some other enhancements (diff)
downloadhistorical-038a2a3fbb6eb0d731b320055a6fd29632c684ae.tar.gz
historical-038a2a3fbb6eb0d731b320055a6fd29632c684ae.tar.bz2
historical-038a2a3fbb6eb0d731b320055a6fd29632c684ae.zip
Updated docs. Sec 8: added lo to dhcp info. Sec. 12: now uses latest
kernel, also added extra logger info.
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gentoo-web/files/xml/build.xml22
1 files changed, 17 insertions, 5 deletions
diff --git a/app-doc/gentoo-web/files/xml/build.xml b/app-doc/gentoo-web/files/xml/build.xml
index 5494d5b6f99f..e124f63c2ffd 100644
--- a/app-doc/gentoo-web/files/xml/build.xml
+++ b/app-doc/gentoo-web/files/xml/build.xml
@@ -266,9 +266,12 @@ and the last step before we can grab the Portage tree and bootstrap is to config
<p>
Network configuration is simple with DHCP; If your ISP is not using
DHCP, skip down to the static configuration section below.
+(DHCP does not configure the localhost interface, so we add it
+by hand here.)
</p>
<pre caption="Network configuration with DHCP">
# <i>dhcpcd eth0</i>
+# <i>/sbin/ifconfig lo 127.0.0.1 up</i>
</pre>
<note>
Some ISPs require you to provide a hostname. To do that,
@@ -423,12 +426,11 @@ you have to install it yourself. Here are the steps to compile and configure
your own custom kernel:
</p>
<pre>
-# <i>cd /usr/portage/sys-kernel/linux-sources</i>
-# <i>emerge linux-sources-2.4.8.8.ebuild</i>
+# <i>emerge sys-kernel/linux-sources</i>
# <i>cd /usr/src/linux</i>
# <i>make menuconfig</i>
# <i>make dep; make clean; make bzImage; make modules; make modules_install</i>
-# <i>mv /boot/bzImage /boot/bzImage.orig</i> <comment>[if bzImage already exists]</comment>
+# <i>mv bzImage bzImage.orig</i> <comment>[if bzImage already exists]</comment>
# <i>cp /usr/src/linux/arch/i386/boot/bzImage /boot</i>
</pre>
<impo>For your kernel to function properly, there are several options that you will
@@ -452,11 +454,21 @@ To merge your logger of choice, type <e>one</e> of the next three lines:
<pre>
# <i>emerge sys-apps/sysklogd</i>
+# <i>rc-update add sysklogd default</i>
<comment>or</comment>
# <i>emerge app-admin/syslog-ng</i>
+# <i>rc-update syslog-ng default</i>
<comment>or</comment>
# <i>emerge app-admin/metalog</i>
-</pre>
+# <i>rc-update add metalog default</i>
+</pre>
+<warn>
+In the case of syslog-ng and metalog, you need to create
+<path>/etc/syslog-ng/syslog-ng.conf</path> or
+<path>/etc/metalog/metalog.conf</path>, respectively.
+See <path>/etc/syslog-ng</path> or <path>/etc/metalog</path>
+for sample configuration files.
+</warn>
</body>
</section>
</chapter>
@@ -466,7 +478,7 @@ To merge your logger of choice, type <e>one</e> of the next three lines:
<body>
<p>
To install any additional packages in the Portage tree
-you can just <c>emerge</c> any packages in <path>/usr/portage/</path>
+you can just <c>emerge</c> any packages in <path>/usr/portage/</path>
that you'd
like to install, for example:</p>
<pre>