summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-18 07:38:10 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-18 07:38:10 +0000
commit9941b56f2da085fb1921fd3e85562073e35a65dc (patch)
tree3ac2b7a3384f8c7c0968e904623414b1363c020c /app-editors/nvi
parentfix the db3/4 bug, but it now exposes this package has bigger problems with g... (diff)
downloadhistorical-9941b56f2da085fb1921fd3e85562073e35a65dc.tar.gz
historical-9941b56f2da085fb1921fd3e85562073e35a65dc.tar.bz2
historical-9941b56f2da085fb1921fd3e85562073e35a65dc.zip
fix the db3/4 bug, but it now exposes this package has bigger problems with glibc. masked.
Diffstat (limited to 'app-editors/nvi')
-rw-r--r--app-editors/nvi/Manifest4
-rw-r--r--app-editors/nvi/files/digest-nvi-1.81.5-r11
-rw-r--r--app-editors/nvi/nvi-1.81.5-r1.ebuild39
3 files changed, 42 insertions, 2 deletions
diff --git a/app-editors/nvi/Manifest b/app-editors/nvi/Manifest
index e5f331c4f7c9..92e746c05050 100644
--- a/app-editors/nvi/Manifest
+++ b/app-editors/nvi/Manifest
@@ -1,6 +1,6 @@
MD5 08048e1b906418131df99610d352de8e nvi-1.81.5.ebuild 704
-MD5 7200658f83aa2a2fa6b1fe8f487393d5 nvi-1.81.5-r1.ebuild 926
-MD5 1d730ebd7d248274f24365777984c583 ChangeLog 1519
+MD5 85ef5dba16bc863eb9184dd66ce344dc nvi-1.81.5-r1.ebuild 928
+MD5 79c67062b74373dc19782d520dfd61d7 ChangeLog 1719
MD5 abc0cfdf090a8bb116da85a573418fc0 nvi-1.81.4.ebuild 674
MD5 47f5a61b93feb15280fbaf8deae78ea5 files/digest-nvi-1.81.4 63
MD5 9c126ee8e4a3070016e51438d8ad45b9 files/digest-nvi-1.81.5 63
diff --git a/app-editors/nvi/files/digest-nvi-1.81.5-r1 b/app-editors/nvi/files/digest-nvi-1.81.5-r1
new file mode 100644
index 000000000000..38945f51da60
--- /dev/null
+++ b/app-editors/nvi/files/digest-nvi-1.81.5-r1
@@ -0,0 +1 @@
+MD5 5cc674f049054f3e8f7600df8d8d5cf4 nvi-1.81.5.tar.gz 1628555
diff --git a/app-editors/nvi/nvi-1.81.5-r1.ebuild b/app-editors/nvi/nvi-1.81.5-r1.ebuild
new file mode 100644
index 000000000000..e85a5effa181
--- /dev/null
+++ b/app-editors/nvi/nvi-1.81.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.5-r1.ebuild,v 1.1 2003/08/18 07:38:07 robbat2 Exp $
+
+DESCRIPTION="Vi clone"
+SRC_URI="http://www.kotnet.org/~skimo/nvi/devel/${P}.tar.gz"
+HOMEPAGE="http://www.bostic.com/vi/"
+SLOT="0"
+LICENSE="Sleepycat"
+KEYWORDS="-*"
+DEPEND="virtual/glibc
+ =sys-libs/db-3*"
+PROVIDE="virtual/editor"
+IUSE=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ sed 's|-ldb|-ldb-3|g' -i ${S}/dist/configure
+}
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} --enable-dynamic-loading"
+ export LIBS="-lpthread"
+ cd build.unix
+ ../dist/configure \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die "configure failed"
+ einfo "Doing make now"
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd ${S}/build.unix
+ einstall
+}