summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-10-16 05:01:21 +0000
committerMamoru Komachi <usata@gentoo.org>2004-10-16 05:01:21 +0000
commit0c601c63454623ed875af45f7c317d8ce2f9da54 (patch)
tree2f0b8965e64f61c9914f39e8eb51a43d4a8e4226 /app-editors
parent-ppc marked, subtle flaws here and there (diff)
downloadhistorical-0c601c63454623ed875af45f7c317d8ce2f9da54.tar.gz
historical-0c601c63454623ed875af45f7c317d8ce2f9da54.tar.bz2
historical-0c601c63454623ed875af45f7c317d8ce2f9da54.zip
Fixed compile problem when lesstif USE flag is set but openmotif is not installed. This closes bug #67492.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog7
-rw-r--r--app-editors/emacs/Manifest12
-rw-r--r--app-editors/emacs/emacs-21.3-r3.ebuild5
-rw-r--r--app-editors/emacs/emacs-21.3-r4.ebuild5
4 files changed, 18 insertions, 11 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 7322075899ee..97b5eeb3a060 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.40 2004/10/13 22:22:12 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.41 2004/10/16 05:01:21 usata Exp $
+
+ 16 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> emacs-21.3-r3.ebuild,
+ emacs-21.3-r4.ebuild:
+ Fixed compile problem when lesstif USE flag is set but openmotif is not
+ installed. This closes bug #67492.
14 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> emacs-21.3-r4.ebuild:
Specify alternatives version explicitly.
diff --git a/app-editors/emacs/Manifest b/app-editors/emacs/Manifest
index 2d64d50fb418..417d9afb3637 100644
--- a/app-editors/emacs/Manifest
+++ b/app-editors/emacs/Manifest
@@ -1,12 +1,12 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 86057a34fde59eb633c7ae1bf852a2e8 ChangeLog 6203
+MD5 761200aae3263fd17926174bc09888d5 ChangeLog 6410
MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
MD5 7c1bb3b83cc8d65547925c15dd605a71 emacs-21.3-r2.ebuild 2190
MD5 4ff8a8c4e69f80929f2c1f7aac9a7dd3 emacs-18.59.ebuild 2002
-MD5 856465bdcf5420f48b1213e131fc36f2 emacs-21.3-r3.ebuild 2518
-MD5 ef77d63f86a77803c4d749b6dfaf356d emacs-21.3-r4.ebuild 3595
+MD5 e9abc3b23cdb10be0f4af44307852fda emacs-21.3-r3.ebuild 2604
+MD5 c8362e5135d10f660627227f2cff4e27 emacs-21.3-r4.ebuild 3682
MD5 4163870348c1c0d4dc485dff749fe5cb files/digest-emacs-21.3-r2 126
MD5 2f000567bd6037e79de677b0edd814ab files/60emacs-21.envd 34
MD5 6aafc439ab1c05f97db2bfefc707bdcc files/emacs-21.desktop 196
@@ -21,7 +21,7 @@ MD5 2aaf4fc4c9513f13c4edb24327247f83 files/emacs-21.3-ppc64.patch 1622
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBbalPVWNWqTUmv+0RAg/BAKCVCpBhar2RVCzDN9Ub+9Pes7EZfgCfeUKY
-5pvsfNIe2dg8OYdCKl/rDTk=
-=Rdq9
+iD8DBQFBcKnKVWNWqTUmv+0RAmQeAJ9NKb9+91ppm59kBCmyzYd1DsrOGACglxxX
+5mcox4NweMQwZV5u9kyR6CM=
+=WqNF
-----END PGP SIGNATURE-----
diff --git a/app-editors/emacs/emacs-21.3-r3.ebuild b/app-editors/emacs/emacs-21.3-r3.ebuild
index 94c673e61355..777a104ef121 100644
--- a/app-editors/emacs/emacs-21.3-r3.ebuild
+++ b/app-editors/emacs/emacs-21.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r3.ebuild,v 1.11 2004/10/06 11:41:44 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r3.ebuild,v 1.12 2004/10/16 05:01:21 usata Exp $
inherit flag-o-matic eutils gcc
@@ -58,7 +58,8 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
if use X ; then
if use motif && use lesstif; then
- export LIBS="-L/usr/X11R6/lib/lesstif/"
+ append-ldflags -L/usr/X11R6/lib/lesstif -R/usr/X11R6/lib/lesstif
+ export CPPFLAGS="${CPPFLAGS} -I/usr/X11R6/include/lesstif"
fi
myconf="${myconf}
--with-x
diff --git a/app-editors/emacs/emacs-21.3-r4.ebuild b/app-editors/emacs/emacs-21.3-r4.ebuild
index 5c50bf2f5b15..defa3cdf96b7 100644
--- a/app-editors/emacs/emacs-21.3-r4.ebuild
+++ b/app-editors/emacs/emacs-21.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r4.ebuild,v 1.10 2004/10/13 22:22:12 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r4.ebuild,v 1.11 2004/10/16 05:01:21 usata Exp $
inherit flag-o-matic eutils alternatives gcc
@@ -61,7 +61,8 @@ src_compile() {
use nls || myconf="${myconf} --disable-nls"
if use X ; then
if use motif && use lesstif; then
- export LIBS="-L/usr/X11R6/lib/lesstif/"
+ append-ldflags -L/usr/X11R6/lib/lesstif -R/usr/X11R6/lib/lesstif
+ export CPPFLAGS="${CPPFLAGS} -I/usr/X11R6/include/lesstif"
fi
myconf="${myconf}
--with-x