summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-22 21:41:22 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-22 21:41:22 +0000
commit77411d5bc34028a91009c40f57120a9b56809ddf (patch)
tree64f76ab4029120de3082e560e936de8e83f485ec /app-emulation/bochs
parentRe-SLOT'd all cyrus-sasl packages back to 0 as there are conflicting (diff)
downloadhistorical-77411d5bc34028a91009c40f57120a9b56809ddf.tar.gz
historical-77411d5bc34028a91009c40f57120a9b56809ddf.tar.bz2
historical-77411d5bc34028a91009c40f57120a9b56809ddf.zip
new version 1.4.1; also move /usr/bochs to /usr/lib/bochs and fix #5381 (configure parameters)
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog11
-rw-r--r--app-emulation/bochs/bochs-1.4.1.ebuild54
-rw-r--r--app-emulation/bochs/files/digest-bochs-1.4.12
3 files changed, 65 insertions, 2 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index f79db019408a..f9b33e30f650 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,13 @@
-# ChangeLog for app-emulation/darcnes
+# ChangeLog for app-emulation/bochs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.4 2002/07/16 02:52:22 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.5 2002/07/22 21:41:22 danarmak Exp $
+
+*bochs-1.4.1 (23 Jul 2002)
+
+ 23 Jul 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ New version 1.4.1. Also fix #5381 (configure parameters) and #5312 (new
+ version notice).
*bochs-1.4 (7 May 2002):
diff --git a/app-emulation/bochs/bochs-1.4.1.ebuild b/app-emulation/bochs/bochs-1.4.1.ebuild
new file mode 100644
index 000000000000..cb636e177086
--- /dev/null
+++ b/app-emulation/bochs/bochs-1.4.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-1.4.1.ebuild,v 1.1 2002/07/22 21:41:22 danarmak Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Bochs is a pc emulator.
+This ebuild is set up to emulate a Pentium, with a NE2000 network card, and a
+CDROM drive. It also comes with a disk image using dlxlinux."
+SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
+ http://bochs.sourceforge.net/guestos/dlxlinux3.tar.gz"
+HOMEPAGE="http://bochs.sourceforge.net"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1"
+RDEPEND="${DEPEND}"
+
+KEYWORDS="x86 ppc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd $S
+ cp Makefile.in Makefile.in.orig
+ sed -e "s:\$(WGET) \$(DLXLINUX_TAR_URL):cp ${DISTDIR}/dlxlinux3.tar.gz .:" \
+ -e 's: $(prefix): $(DESTDIR)$(prefix):g' \
+ -e 's: $(bindir): $(DESTDIR)$(bindir):g' \
+ -e 's:BOCHSDIR=:BOCHSDIR=/usr/lib/bochs#:' \
+ -e 's: $(BOCHSDIR): $(DESTDIR)$(BOCHSDIR):g' Makefile.in.orig > Makefile.in
+
+}
+
+src_compile() {
+
+ [ "$ARCH" == "x86" ] && myconf="--enable-idle-hack"
+
+ ./configure --enable-fpu --enable-cdrom --enable-control-panel \
+ --enable-ne2000 --enable-sb16=linux --enable-slowdown --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man --host=${CHOST} --with-x11 $myconf || die
+
+ # there's an sdl interface now, but since we an only compile 1 interface at a time
+ # i'd rather have xwindows.
+
+ emake || die
+}
+
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc CHANGES COPYING CVS README TESTFORM.txt
+}
+
diff --git a/app-emulation/bochs/files/digest-bochs-1.4.1 b/app-emulation/bochs/files/digest-bochs-1.4.1
new file mode 100644
index 000000000000..75238a5b93fc
--- /dev/null
+++ b/app-emulation/bochs/files/digest-bochs-1.4.1
@@ -0,0 +1,2 @@
+MD5 12e591b5cec2e0051e18605483f64678 bochs-1.4.1.tar.gz 1395173
+MD5 b1c1592f105fa7aa0ffaba349d38fcaa dlxlinux3.tar.gz 1504727