summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-12-23 14:43:57 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-12-23 14:43:57 +0000
commit6742babf156a61c7b0f5bb74ff649ebdb2231a09 (patch)
tree970e41de30d6dbc475155ca2d586c0f3130df5d6 /app-emulation/kqemu
parentBugs #115970 (/var/xen/dump), #115969 (dhcp), #116332 (hotplug). Removed xen-... (diff)
downloadhistorical-6742babf156a61c7b0f5bb74ff649ebdb2231a09.tar.gz
historical-6742babf156a61c7b0f5bb74ff649ebdb2231a09.tar.bz2
historical-6742babf156a61c7b0f5bb74ff649ebdb2231a09.zip
New ebuild
Package-Manager: portage-2.0.53
Diffstat (limited to 'app-emulation/kqemu')
-rw-r--r--app-emulation/kqemu/ChangeLog9
-rw-r--r--app-emulation/kqemu/Manifest4
-rw-r--r--app-emulation/kqemu/files/digest-kqemu-0.7.22
-rw-r--r--app-emulation/kqemu/kqemu-0.7.2.ebuild95
-rw-r--r--app-emulation/kqemu/metadata.xml8
5 files changed, 118 insertions, 0 deletions
diff --git a/app-emulation/kqemu/ChangeLog b/app-emulation/kqemu/ChangeLog
new file mode 100644
index 000000000000..dda81d57eedd
--- /dev/null
+++ b/app-emulation/kqemu/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/kqemu
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.1 2005/12/23 14:43:57 lu_zero Exp $
+
+*kqemu-0.7.2 (23 Dec 2005)
+
+ 23 Dec 2005; Luca Barbato <lu_zero@gentoo.org> +kqemu-0.7.2.ebuild:
+ Separate ebuild, thanks to Alexey Maximov <amax@mail.ru> for the ebuild
+
diff --git a/app-emulation/kqemu/Manifest b/app-emulation/kqemu/Manifest
new file mode 100644
index 000000000000..4796c8cedb65
--- /dev/null
+++ b/app-emulation/kqemu/Manifest
@@ -0,0 +1,4 @@
+MD5 fa0a6394e4c425dd18cd1aab62ad088b ChangeLog 385
+MD5 22d8bd748c6ab7d096d531da636bf5da files/digest-kqemu-0.7.2 125
+MD5 cd8326580e282de6a8a766939513be7a kqemu-0.7.2.ebuild 2569
+MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
diff --git a/app-emulation/kqemu/files/digest-kqemu-0.7.2 b/app-emulation/kqemu/files/digest-kqemu-0.7.2
new file mode 100644
index 000000000000..98d16399e956
--- /dev/null
+++ b/app-emulation/kqemu/files/digest-kqemu-0.7.2
@@ -0,0 +1,2 @@
+MD5 02cfdecda90458d6393781496ec6b48b kqemu-0.7.2.tar.gz 79314
+MD5 7d69dd96edf7ae5298a9a7283a0e9fb8 qemu-0.7.2.tar.gz 1341993
diff --git a/app-emulation/kqemu/kqemu-0.7.2.ebuild b/app-emulation/kqemu/kqemu-0.7.2.ebuild
new file mode 100644
index 000000000000..9e31113d5f41
--- /dev/null
+++ b/app-emulation/kqemu/kqemu-0.7.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-0.7.2.ebuild,v 1.1 2005/12/23 14:43:57 lu_zero Exp $
+
+inherit eutils flag-o-matic linux-mod toolchain-funcs
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator kernel fast execution module"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/qemu-${PV}.tar.gz
+ http://fabrice.bellard.free.fr/qemu/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 KQEMU"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -alpha -sparc ~amd64"
+RESTRICT="nostrip"
+IUSE="sdl"
+
+S="${WORKDIR}/qemu-${PV}"
+
+DEPEND="virtual/libc
+ >=app-emulation/qemu-softmmu-0.8.0"
+
+pkg_setup() {
+ MODULE_NAMES="kqemu(misc:${S}/kqemu)"
+ linux-mod_pkg_setup
+
+ einfo "kqemu is binary module with a restricted license."
+ einfo "Please read carefully the KQEMU license"
+ einfo "and ${HOMEPAGE}qemu-accel.html"
+ einfo "if you would like to see it released under the GPL"
+}
+
+src_unpack() {
+ unpack ${A}
+
+ mv ${WORKDIR}/kqemu ${S}
+ cd ${S}/kqemu
+ sed -i -e 's:#ifndef PAGE_KERNEL_EXEC:#if 1:' ${S}/kqemu/kqemu-linux.c
+ # The class_simple interfaces were removed in 2.6.13-rc1, leaving only
+ # GPL symbols behind, which this module can't use. Until there's a fix
+ # from Fabrice, kqemu+udev no worky.
+ cd ${S}
+
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf=""
+ if ! use sdl ; then
+ myconf="$myconf --disable-gfx-check"
+ fi
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ --enable-kqemu \
+ ${myconf} \
+ || die "could not configure"
+
+ emake -C kqemu || die "make failed"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ # udev rule
+ dodir /etc/udev/rules.d/
+ echo 'KERNEL="kqemu*", NAME="%k", GROUP="qemu", MODE="0660"' > ${D}/etc/udev/rules.d/48-qemu.rules
+ enewgroup qemu
+
+ # Module doc
+ dodoc ${S}/kqemu/README
+
+ # module params
+ dodir /etc/modules.d
+ echo "options kqemu major=0" > ${D}/etc/modules.d/kqemu
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ einfo "Make sure you have the kernel module loaded before running qemu"
+ einfo "and your user is in the qemu group"
+}
diff --git a/app-emulation/kqemu/metadata.xml b/app-emulation/kqemu/metadata.xml
new file mode 100644
index 000000000000..7ea327a416ea
--- /dev/null
+++ b/app-emulation/kqemu/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>lu_zero@gentoo.org</email>
+</maintainer>
+</pkgmetadata>