summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTodd Berman <tberman@gentoo.org>2003-05-23 16:31:51 +0000
committerTodd Berman <tberman@gentoo.org>2003-05-23 16:31:51 +0000
commit017e14c08737e065c6afe99179c066df4c620e81 (patch)
tree44c7f4081bd2f021d97302f0d7e4bdf836752a69 /app-misc
parentInitial Import. (diff)
downloadhistorical-017e14c08737e065c6afe99179c066df4c620e81.tar.gz
historical-017e14c08737e065c6afe99179c066df4c620e81.tar.bz2
historical-017e14c08737e065c6afe99179c066df4c620e81.zip
Initial Import.
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/largorecipes/Manifest4
-rw-r--r--app-misc/largorecipes/files/digest-largorecipes-0.9.0.32
-rw-r--r--app-misc/largorecipes/files/largorecipes8
-rw-r--r--app-misc/largorecipes/largorecipes-0.9.0.3.ebuild36
4 files changed, 48 insertions, 2 deletions
diff --git a/app-misc/largorecipes/Manifest b/app-misc/largorecipes/Manifest
index ab9fbf33e5f3..555bc0194f65 100644
--- a/app-misc/largorecipes/Manifest
+++ b/app-misc/largorecipes/Manifest
@@ -1,4 +1,4 @@
-MD5 e9eccc5d23cb869443fe6bacb87a7428 largorecipes-0.9.0.3.ebuild 848
-MD5 f15c29801bd48a5f4b1affefcb1aa9d4 ChangeLog 199
+MD5 38474be7da87e0d0889b6bec7b0c0482 largorecipes-0.9.0.3.ebuild 961
+MD5 9470bbcf575f66ffa694c25fcea256c9 ChangeLog 294
MD5 6d96c5335aa0580e64f6d201bb1788ab files/largorecipes 394
MD5 905c37f0fb9cdd190d9c3e30d4a7d863 files/digest-largorecipes-0.9.0.3 143
diff --git a/app-misc/largorecipes/files/digest-largorecipes-0.9.0.3 b/app-misc/largorecipes/files/digest-largorecipes-0.9.0.3
new file mode 100644
index 000000000000..7dc317bc4cf5
--- /dev/null
+++ b/app-misc/largorecipes/files/digest-largorecipes-0.9.0.3
@@ -0,0 +1,2 @@
+MD5 da548170cca577e2ab6dc08ea15bb502 largorecipes-0.9.0.1.jar 2622096
+MD5 efb651eeef59536702bd8864d5f0f0ba largorecipespatch-0.9.0.3.jar 11760
diff --git a/app-misc/largorecipes/files/largorecipes b/app-misc/largorecipes/files/largorecipes
new file mode 100644
index 000000000000..b8878bb54173
--- /dev/null
+++ b/app-misc/largorecipes/files/largorecipes
@@ -0,0 +1,8 @@
+if [ ! -e ~/.largorecipes ];then
+ echo "Running for the first time"
+ echo -n "Setting up things..."
+ mkdir -p ~/.largorecipes/patches
+ (cd ~/.largorecipes;ln -s `java-config --classpath=largorecipes | cut -f2 -d:` patches/0.9.0.3-patch.jar );
+ echo "done"
+fi
+(cd ~/.largorecipes;java -classpath `java-config --classpath=largorecipes` -jar `java-config --classpath=largorecipes | cut -f1 -d:`);
diff --git a/app-misc/largorecipes/largorecipes-0.9.0.3.ebuild b/app-misc/largorecipes/largorecipes-0.9.0.3.ebuild
new file mode 100644
index 000000000000..8e87786408df
--- /dev/null
+++ b/app-misc/largorecipes/largorecipes-0.9.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/largorecipes/largorecipes-0.9.0.3.ebuild,v 1.1 2003/05/23 16:31:46 tberman Exp $
+
+# Based on an original ebuild by Per Wigren <wigren@home.se>
+
+inherit java-pkg
+
+DESCRIPTION="LargoRecipes is an application for managing recipes."
+SRC_URI="mirror://sourceforge/largorecipes/${PN}-0.9.0.1.jar
+ mirror://sourceforge/largorecipes/${PN}patch-${PV}.jar"
+HOMEPAGE="http://largorecipes.sourceforge.net/"
+
+IUSE=""
+DEPEND=">=virtual/jre-1.4"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+LICENSE="GPL-2"
+
+src_unpack() {
+ mkdir -p ${S}
+ cp ${DISTDIR}/${PN}-0.9.0.1.jar ${S}
+ cp ${DISTDIR}/${PN}patch-0.9.0.3.jar ${S}
+}
+
+src_compile() {
+ einfo "No compilation needed (for now)"
+}
+
+src_install() {
+
+ dobin ${FILESDIR}/largorecipes
+ java-pkg_dojar ${PN}-0.9.0.1.jar
+ java-pkg_dojar ${PN}patch-0.9.0.3.jar
+}