summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2007-01-18 00:04:20 +0000
committerRyan Hill <rhill@gentoo.org>2007-01-18 00:04:20 +0000
commit6bd240e6c7249ba2b2a97a32f7f790808ca0675b (patch)
treed0a9c0ac4b6bbe70b9c792b43cb71ebe94d91a89 /app-misc
parentarm/s390/sh stable (diff)
downloadhistorical-6bd240e6c7249ba2b2a97a32f7f790808ca0675b.tar.gz
historical-6bd240e6c7249ba2b2a97a32f7f790808ca0675b.tar.bz2
historical-6bd240e6c7249ba2b2a97a32f7f790808ca0675b.zip
Fix bug with recent flex versions breaking build for bug #137223. Also patch Makefile to pass proper CFLAGS and not prestrip binaries.
Package-Manager: portage-2.1.2_rc4-r9
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/boxes/ChangeLog10
-rw-r--r--app-misc/boxes/boxes-1.0.1.ebuild15
-rw-r--r--app-misc/boxes/files/boxes-1.0.1-Makefile.patch46
-rw-r--r--app-misc/boxes/files/boxes-1.0.1-flex.patch28
-rw-r--r--app-misc/boxes/files/digest-boxes-1.0.12
5 files changed, 91 insertions, 10 deletions
diff --git a/app-misc/boxes/ChangeLog b/app-misc/boxes/ChangeLog
index ec42f6f60d19..4a57027d9bed 100644
--- a/app-misc/boxes/ChangeLog
+++ b/app-misc/boxes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/boxes
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.14 2005/04/21 19:03:36 blubb Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/ChangeLog,v 1.15 2007/01/18 00:04:20 dirtyepic Exp $
+
+ 18 Jan 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/boxes-1.0.1-Makefile.patch, +files/boxes-1.0.1-flex.patch,
+ -files/boxes-1.0.1-gentoo.diff, boxes-1.0.1.ebuild:
+ Fix bug with recent flex versions breaking build for bug #137223. Also patch
+ Makefile to pass proper CFLAGS and not prestrip binaries.
21 Apr 2005; Simon Stelling <blubb@gentoo.org> boxes-1.0.1.ebuild:
stable on amd64
diff --git a/app-misc/boxes/boxes-1.0.1.ebuild b/app-misc/boxes/boxes-1.0.1.ebuild
index 30a267ecf621..79fff1f195d7 100644
--- a/app-misc/boxes/boxes-1.0.1.ebuild
+++ b/app-misc/boxes/boxes-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.0.1.ebuild,v 1.24 2005/04/21 19:03:36 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/boxes/boxes-1.0.1.ebuild,v 1.25 2007/01/18 00:04:20 dirtyepic Exp $
inherit eutils
@@ -13,18 +13,17 @@ SLOT="0"
KEYWORDS="x86 ppc sparc mips alpha amd64 ppc64"
IUSE=""
-DEPEND="virtual/libc"
+DEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-flex.patch
}
-
src_compile() {
- make clean || die
- make CFLAGS="$CFLAGS -I. -Iregexp" || die
+ emake || die
}
src_install() {
diff --git a/app-misc/boxes/files/boxes-1.0.1-Makefile.patch b/app-misc/boxes/files/boxes-1.0.1-Makefile.patch
new file mode 100644
index 000000000000..ec5189287ac9
--- /dev/null
+++ b/app-misc/boxes/files/boxes-1.0.1-Makefile.patch
@@ -0,0 +1,46 @@
+diff -Naur boxes-1.0.1-orig/Makefile boxes-1.0.1/Makefile
+--- boxes-1.0.1-orig/Makefile 2007-01-17 17:53:39.000000000 -0600
++++ boxes-1.0.1/Makefile 2007-01-17 17:54:13.000000000 -0600
+@@ -51,7 +51,7 @@
+
+
+ # The following line (GLOBALCONF) is the only line you should need to edit!
+-GLOBALCONF = /usr/local/share/boxes
++GLOBALCONF = /usr/share/boxes/boxes-config
+ BVERSION = 1.0.1
+
+ SNAPFILE = boxes-SNAP-$(shell date +%Y%m%d)
+diff -Naur boxes-1.0.1-orig/src/Makefile boxes-1.0.1/src/Makefile
+--- boxes-1.0.1-orig/src/Makefile 2007-01-17 17:53:39.000000000 -0600
++++ boxes-1.0.1/src/Makefile 2007-01-17 17:54:31.000000000 -0600
+@@ -79,7 +79,7 @@
+ LEX = flex
+ YACC = bison
+ CC = gcc
+-CFLAGS = -ansi -I. -Iregexp -Wall -W $(CFLAGS_ADDTL)
++CFLAGS += -ansi -I. -Iregexp -Wall -W $(CFLAGS_ADDTL)
+ LDFLAGS = -Lregexp
+
+ GEN_HDR = parser.h boxes.h
+@@ -99,8 +99,7 @@
+
+
+ build:
+- $(MAKE) CFLAGS_ADDTL=-O boxes
+- strip boxes
++ $(MAKE) boxes
+ debug:
+ $(MAKE) CFLAGS_ADDTL=-g boxes
+
+diff -Naur boxes-1.0.1-orig/src/regexp/Makefile boxes-1.0.1/src/regexp/Makefile
+--- boxes-1.0.1-orig/src/regexp/Makefile 2007-01-17 17:53:39.000000000 -0600
++++ boxes-1.0.1/src/regexp/Makefile 2007-01-17 17:54:13.000000000 -0600
+@@ -32,7 +32,7 @@
+ #============================================================================
+
+
+-CFLAGS = -traditional -O -I. $(CFLAGS_ADDTL)
++CFLAGS += -I. $(CFLAGS_ADDTL)
+
+ ALL_CL = regexp/regexp.c regexp/regsub.c
+ C_SRC = $(notdir $(ALL_CL))
diff --git a/app-misc/boxes/files/boxes-1.0.1-flex.patch b/app-misc/boxes/files/boxes-1.0.1-flex.patch
new file mode 100644
index 000000000000..cbbf1a6c8d45
--- /dev/null
+++ b/app-misc/boxes/files/boxes-1.0.1-flex.patch
@@ -0,0 +1,28 @@
+diff -Naur boxes-1.0.1-orig/src/lexer.l boxes-1.0.1/src/lexer.l
+--- boxes-1.0.1-orig/src/lexer.l 2006-07-02 20:39:46.000000000 -0600
++++ boxes-1.0.1/src/lexer.l 2006-07-02 20:47:06.000000000 -0600
+@@ -116,7 +116,6 @@
+ "$Id: boxes-1.0.1-flex.patch,v 1.1 2007/01/18 00:04:20 dirtyepic Exp $";
+
+
+-int yylineno = 1;
+ static int yyerrcnt = 0;
+
+ static char sdel = '\"';
+@@ -138,6 +137,7 @@
+ %option noyywrap
+ %option never-interactive
+ %option caseless
++%option noyylineno
+
+
+ %x SAMPLE
+@@ -468,7 +468,7 @@
+ exit (EXIT_FAILURE);
+ }
+ yy_delete_buffer (YY_CURRENT_BUFFER);
+- YY_CURRENT_BUFFER = yy_create_buffer (yyin, sinf.st_size+10);
++ yy_switch_to_buffer (yy_create_buffer (yyin, sinf.st_size+10));
+ }
+
+
diff --git a/app-misc/boxes/files/digest-boxes-1.0.1 b/app-misc/boxes/files/digest-boxes-1.0.1
index abbf79762206..0576a101912e 100644
--- a/app-misc/boxes/files/digest-boxes-1.0.1
+++ b/app-misc/boxes/files/digest-boxes-1.0.1
@@ -1 +1,3 @@
MD5 77935fb3b566755db798d678f945bd4d boxes-1.0.1.src.tar.gz 125071
+RMD160 4c602d99c6a84fdba6ad89f88eb7c1126ddc9c86 boxes-1.0.1.src.tar.gz 125071
+SHA256 27d507c6419c724eabd18288881d4a426720754bb0832de4205bda65bdcfb67c boxes-1.0.1.src.tar.gz 125071