summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-15 13:08:51 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-15 13:08:51 +0000
commitdaf38047027e6f1da5843396845d752469969dca (patch)
tree363e733e8ab1ef83115ed6f7f903fb72e8ae4c89 /app-misc
parentMigrate to EAPI 2 in order to remove built_with_use calls for bug #261562. (diff)
downloadhistorical-daf38047027e6f1da5843396845d752469969dca.tar.gz
historical-daf38047027e6f1da5843396845d752469969dca.tar.bz2
historical-daf38047027e6f1da5843396845d752469969dca.zip
USE deps instead of built_with_use
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hachoir-urwid/hachoir-urwid-1.0.1.ebuild19
-rw-r--r--app-misc/ledit/ledit-2.01.ebuild29
-rw-r--r--app-misc/pal/pal-0.4.3.ebuild23
-rw-r--r--app-misc/tracker/files/tracker-0.6.2-implicit-pointer-conversion.patch12
-rw-r--r--app-misc/tracker/files/tracker-0.6.3-fix-unac-option.patch18
-rw-r--r--app-misc/tracker/files/tracker-0.6.3-really-disable-libtrackergtk.patch11
-rw-r--r--app-misc/tracker/files/tracker-0.6.3-tracker-extract-needs-gthread.patch12
-rw-r--r--app-misc/tracker/tracker-0.6.3.ebuild144
-rw-r--r--app-misc/tracker/tracker-0.6.6-r1.ebuild37
-rw-r--r--app-misc/tracker/tracker-0.6.6.ebuild129
-rw-r--r--app-misc/tracker/tracker-9999.ebuild34
-rw-r--r--app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild17
-rw-r--r--app-misc/wyrd/wyrd-1.4.4.ebuild26
13 files changed, 55 insertions, 456 deletions
diff --git a/app-misc/hachoir-urwid/hachoir-urwid-1.0.1.ebuild b/app-misc/hachoir-urwid/hachoir-urwid-1.0.1.ebuild
index da24376095b4..a8794eb75329 100644
--- a/app-misc/hachoir-urwid/hachoir-urwid-1.0.1.ebuild
+++ b/app-misc/hachoir-urwid/hachoir-urwid-1.0.1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hachoir-urwid/hachoir-urwid-1.0.1.ebuild,v 1.2 2008/08/12 08:13:46 cedk Exp $
-
-NEED_PYTHON=2.4
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hachoir-urwid/hachoir-urwid-1.0.1.ebuild,v 1.3 2009/08/15 13:08:51 ssuominen Exp $
+EAPI=2
inherit distutils
DESCRIPTION="user interface based on hachoir-parser to explore a binary file"
@@ -15,16 +14,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=">=dev-python/hachoir-core-1.0.1
+DEPEND=">=dev-lang/python-2.4[ncurses]"
+RDEPEND="${DEPEND}
+ >=dev-python/hachoir-core-1.0.1
>=dev-python/hachoir-parser-1.0
>=dev-python/urwid-0.9.4"
PYTHON_MODNAME="hachoir_urwid"
-
-pkg_setup() {
- if ! built_with_use virtual/python ncurses; then
- eerror "virtual/python must be build with ncurses"
- die "${PN} requires virtual/python with USE=ncurses"
- fi
-}
diff --git a/app-misc/ledit/ledit-2.01.ebuild b/app-misc/ledit/ledit-2.01.ebuild
index 13373d4100fa..d45ca8115036 100644
--- a/app-misc/ledit/ledit-2.01.ebuild
+++ b/app-misc/ledit/ledit-2.01.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-2.01.ebuild,v 1.4 2008/09/25 12:10:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ledit/ledit-2.01.ebuild,v 1.5 2009/08/15 13:02:14 ssuominen Exp $
+EAPI=2
inherit eutils
-EAPI="1"
-
RESTRICT="installsources"
IUSE="+ocamlopt"
@@ -13,24 +12,15 @@ DESCRIPTION="A line editor to be used with interactive commands."
SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
-DEPEND=">=dev-lang/ocaml-3.09 dev-ml/camlp5"
+DEPEND=">=dev-lang/ocaml-3.09[ocamlopt?]
+ dev-ml/camlp5"
RDEPEND="${DEPEND}"
SLOT="0"
LICENSE="BSD"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_compile()
-{
+src_compile() {
emake -j1 all || die "make failed"
if use ocamlopt; then
emake -j1 ledit.opt || die "make failed"
@@ -41,12 +31,11 @@ src_compile()
fi
}
-src_install()
-{
+src_install() {
if use ocamlopt; then
- newbin ledit.opt ledit
+ newbin ledit.opt ledit || die
else
- newbin ledit.out ledit
+ newbin ledit.out ledit || die
fi
doman ledit.1
dodoc CHANGES README
diff --git a/app-misc/pal/pal-0.4.3.ebuild b/app-misc/pal/pal-0.4.3.ebuild
index 61144f46f570..6b9cdfdb3893 100644
--- a/app-misc/pal/pal-0.4.3.ebuild
+++ b/app-misc/pal/pal-0.4.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pal/pal-0.4.3.ebuild,v 1.1 2008/10/05 11:49:51 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pal/pal-0.4.3.ebuild,v 1.2 2009/08/15 12:58:52 ssuominen Exp $
+EAPI=2
inherit toolchain-funcs eutils
DESCRIPTION="pal command-line calendar program"
@@ -15,27 +16,21 @@ IUSE="nls unicode"
RDEPEND=">=dev-libs/glib-2.0
sys-libs/readline
- sys-libs/ncurses
+ sys-libs/ncurses[unicode?]
nls? ( virtual/libintl )"
-
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )"
-S="${WORKDIR}/${P}/src"
+S=${WORKDIR}/${P}/src
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PV}-strip.patch
epatch "${FILESDIR}"/${PV}-ldflags.patch
- if use unicode ; then
- if built_with_use sys-libs/ncurses unicode ; then
- sed -i "/^LIBS/s/-lncurses/&w/" "${S}"/Makefile || die
- else
- ewarn "Rebuild sys-libs/ncurses with unicode before you try"
- ewarn "to build app-misc/pal with unicode support!"
- fi
+ if use unicode; then
+ sed -i "/^LIBS/s/-lncurses/&w/" "${S}"/Makefile || die
fi
}
@@ -45,11 +40,11 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install-man install-bin install-share \
+ emake DESTDIR="${D}" install-man install-bin install-share \
|| die "make install failed"
if use nls; then
- make DESTDIR="${D}" install-mo || die "make install-mo failed"
+ emake DESTDIR="${D}" install-mo || die "make install-mo failed"
fi
dodoc "${WORKDIR}"/${P}/{ChangeLog,doc/example.css} || die "dodoc failed"
diff --git a/app-misc/tracker/files/tracker-0.6.2-implicit-pointer-conversion.patch b/app-misc/tracker/files/tracker-0.6.2-implicit-pointer-conversion.patch
deleted file mode 100644
index 1d4ea8805eee..000000000000
--- a/app-misc/tracker/files/tracker-0.6.2-implicit-pointer-conversion.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- trunk/src/trackerd/tracker-apps.c 2007/08/19 00:31:33 786
-+++ trunk/src/trackerd/tracker-apps.c 2007/09/06 01:53:27 811
-@@ -18,7 +18,8 @@
- * Boston, MA 02110-1301, USA.
- */
-
--#include<string.h>
-+#include <stdlib.h>
-+#include <string.h>
-
- #include "tracker-apps.h"
- #include "tracker-db.h"
diff --git a/app-misc/tracker/files/tracker-0.6.3-fix-unac-option.patch b/app-misc/tracker/files/tracker-0.6.3-fix-unac-option.patch
deleted file mode 100644
index b5c5e21009cf..000000000000
--- a/app-misc/tracker/files/tracker-0.6.3-fix-unac-option.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- configure.ac.orig 2007-10-02 02:15:44.000000000 -0700
-+++ configure.ac 2007-10-02 02:16:18.000000000 -0700
-@@ -528,13 +528,13 @@
- AC_SUBST([UNAC_LIBS])
-
- else
-- enable-unac="no (disabled)"
-+ enable_unac="no"
- fi
-
- if test "$enable_unac" = "yes"; then
- AC_DEFINE(HAVE_UNAC, [], [Define if we have unac lib])
- fi
--AM_CONDITIONAL(ENABLE_UNAC, test "$enable-unac" != "no")
-+AM_CONDITIONAL(ENABLE_UNAC, test "$enable_unac" != "no")
-
-
-
diff --git a/app-misc/tracker/files/tracker-0.6.3-really-disable-libtrackergtk.patch b/app-misc/tracker/files/tracker-0.6.3-really-disable-libtrackergtk.patch
deleted file mode 100644
index 7cfdf5c4d40c..000000000000
--- a/app-misc/tracker/files/tracker-0.6.3-really-disable-libtrackergtk.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.ac.orig 2007-10-28 12:08:45.000000000 -0700
-+++ configure.ac 2007-10-28 12:09:00.000000000 -0700
-@@ -508,7 +508,7 @@
- enable-libtrackergtk="no (disabled)"
- fi
-
--AM_CONDITIONAL(ENABLE_LIBTRACKERGTK, test "$enable-libtrackergtk" != "no")
-+AM_CONDITIONAL(ENABLE_LIBTRACKERGTK, test "$enable_libtrackergtk" = "yes")
-
-
-
diff --git a/app-misc/tracker/files/tracker-0.6.3-tracker-extract-needs-gthread.patch b/app-misc/tracker/files/tracker-0.6.3-tracker-extract-needs-gthread.patch
deleted file mode 100644
index 65393f98c217..000000000000
--- a/app-misc/tracker/files/tracker-0.6.3-tracker-extract-needs-gthread.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: Makefile.am
-===================================================================
---- src/tracker-extract/Makefile.am (revision 899)
-+++ src/tracker-extract/Makefile.am (revision 944)
-@@ -41,6 +41,7 @@
- $(video_sources)
-
- tracker_extract_LDADD = $(GLIB2_LIBS) \
-+ $(GTHREAD_LIBS) \
- $(POPPLER_GLIB_LIBS) \
- $(LIBPNG_LIBS) \
- $(LIBEXIF_LIBS) \
diff --git a/app-misc/tracker/tracker-0.6.3.ebuild b/app-misc/tracker/tracker-0.6.3.ebuild
deleted file mode 100644
index a419197e4b90..000000000000
--- a/app-misc/tracker/tracker-0.6.3.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.6.3.ebuild,v 1.14 2009/03/30 02:02:05 loki_val Exp $
-
-inherit autotools eutils flag-o-matic linux-info
-
-DESCRIPTION="A tagging metadata database, search tool and indexer"
-HOMEPAGE="http://www.tracker-project.org/"
-SRC_URI="http://www.gnome.org/~jamiemcc/tracker/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ppc64 sparc x86"
-IUSE="applet debug gnome gsf gstreamer gtk jpeg pdf xine kernel_linux"
-
-RDEPEND=">=dev-libs/glib-2.12.0
- >=x11-libs/pango-1.0.0
- =dev-libs/gmime-2.2*
- >=media-gfx/imagemagick-5.2.1
- >=dev-libs/dbus-glib-0.71
- >=dev-db/qdbm-1.8
- >=dev-db/sqlite-3.4
- >=media-libs/libpng-1.2
- >=dev-libs/libxml2-2.6
- sys-libs/zlib
- applet? ( >=gnome-extra/deskbar-applet-2.16 )
- gnome? (
- >=x11-libs/gtk+-2.8
- >=gnome-base/libglade-2.5
- >=gnome-base/libgnome-2.14
- >=gnome-base/gnome-vfs-2.10
- >=gnome-base/libgnomeui-2.14
- >=gnome-base/gnome-desktop-2.14
- )
- gsf? ( >=gnome-extra/libgsf-1.13 )
- gstreamer? ( >=media-libs/gstreamer-0.10 )
- gtk? ( >=x11-libs/gtk+-2.8.20 )
- jpeg? ( >=media-gfx/exif-0.6 )
- xine? ( >=media-libs/xine-lib-1.0 )
- !gstreamer? ( !xine? ( || ( media-video/totem media-video/mplayer ) ) )
- !kernel_linux? ( >=app-admin/gamin-0.1.7 )
- pdf? (
- >=x11-libs/cairo-1.0
- >=virtual/poppler-glib-0.5
- >=virtual/poppler-utils-0.5
- )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=sys-devel/gettext-0.14
- >=dev-util/pkgconfig-0.20"
-
-function notify_inotify() {
- ewarn
- ewarn "You should enable the INOTIFY support in your kernel."
- ewarn "Check the 'Inotify file change notification support' under the"
- ewarn "'File systems' option. It is marked as CONFIG_INOTIFY in the config"
- ewarn "Also enable 'Inotify support for userland' in under the previous"
- ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config."
- ewarn
- die 'missing CONFIG_INOTIFY'
-}
-
-function inotify_enabled() {
- linux_chkconfig_present INOTIFY && linux_chkconfig_present INOTIFY_USER
-}
-
-pkg_setup() {
- linux-info_pkg_setup
-
- if ! built_with_use --missing true 'dev-db/sqlite' 'threadsafe' \
- || built_with_use --missing false 'dev-db/sqlite' 'nothreadsafe'; then
- eerror "You must build sqlite with threading support"
- die "dev-db/sqlite built without thread safety"
- fi
-
- if ! built_with_use 'media-gfx/imagemagick' 'png' ; then
- ewarn "You must build imagemagick with png"
- die "imagemagick needs png support"
- fi
-
- if use jpeg && ! built_with_use 'media-gfx/imagemagick' 'jpeg' ; then
- ewarn "You must build imagemagick with jpeg to get support for JPEG"
- die "imagemagick needs jpeg support"
- fi
-
- if use kernel_linux ; then
- inotify_enabled || notify_inotify
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-0.6.3-fix-unac-option.patch"
-
- epatch "${FILESDIR}/${PN}-0.6.3-tracker-extract-needs-gthread.patch"
-
- # Fix libtrackergtk enable option (bug #196420)
- epatch "${FILESDIR}/${PN}-0.6.3-really-disable-libtrackergtk.patch"
-
- # Fix POTFILES.in for tests
- echo "python/deskbar-handler/tracker-handler-static.py" >> "${S}/po/POTFILES.in"
-
- eautoreconf
- intltoolize --force || die "intltoolize failed"
-}
-
-src_compile() {
- local myconf=
-
- if use gstreamer ; then
- myconf="${myconf} --enable-video-extractor=gstreamer"
- elif use xine ; then
- myconf="${myconf} --enable-video-extractor=xine"
- else
- myconf="${myconf} --enable-video-extractor=external"
- fi
-
- if use kernel_linux ; then
- myconf="${myconf} --enable-file-monitoring=inotify"
- else
- myconf="${myconf} --enable-file-monitoring=fam"
- fi
-
- econf ${myconf} \
- --enable-preferences --disable-xmp --disable-unac \
- --enable-libxml2 --enable-external-qdbm \
- $(use_enable applet deskbar-applet auto) \
- $(use_enable debug debug-code) \
- $(use_enable gnome gui) \
- $(use_enable gsf) \
- $(use_enable gtk libtrackergtk) \
- $(use_enable jpeg exif) \
- $(use_enable pdf) \
- || die "configure failed"
-
- emake || die "build failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README
-}
diff --git a/app-misc/tracker/tracker-0.6.6-r1.ebuild b/app-misc/tracker/tracker-0.6.6-r1.ebuild
index 6fda123e2a93..e5dc62437a83 100644
--- a/app-misc/tracker/tracker-0.6.6-r1.ebuild
+++ b/app-misc/tracker/tracker-0.6.6-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.6.6-r1.ebuild,v 1.10 2009/03/30 02:02:05 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.6.6-r1.ebuild,v 1.11 2009/08/15 12:55:07 ssuominen Exp $
-inherit autotools eutils flag-o-matic linux-info
+EAPI=2
+inherit eutils flag-o-matic linux-info
DESCRIPTION="A tagging metadata database, search tool and indexer"
HOMEPAGE="http://www.tracker-project.org/"
@@ -19,8 +20,8 @@ RDEPEND=">=dev-libs/glib-2.14.0
>=dev-libs/dbus-glib-0.71
>=media-libs/libpng-1.2
>=dev-libs/libxml2-2.6
- >=dev-db/sqlite-3.4
- >=media-gfx/imagemagick-5.2.1
+ >=dev-db/sqlite-3.4[threadsafe]
+ >=media-gfx/imagemagick-5.2.1[png,jpeg?]
applet? ( >=x11-libs/libnotify-0.4.3 )
deskbar? ( >=gnome-extra/deskbar-applet-2.19 )
gnome? (
@@ -67,36 +68,17 @@ function inotify_enabled() {
pkg_setup() {
linux-info_pkg_setup
- if built_with_use --missing false 'dev-db/sqlite' 'nothreadsafe' ||
- ! built_with_use --missing true 'dev-db/sqlite' 'threadsafe' ; then
- eerror "You must build sqlite with threading support"
- die "dev-db/sqlite built without thread safety"
- fi
-
- if ! built_with_use 'media-gfx/imagemagick' 'png' ; then
- ewarn "You must build imagemagick with png"
- die "imagemagick needs png support"
- fi
-
- if use jpeg && ! built_with_use 'media-gfx/imagemagick' 'jpeg' ; then
- ewarn "You must build imagemagick with jpeg to get support for JPEG"
- die "imagemagick needs jpeg support"
- fi
-
if use kernel_linux ; then
inotify_enabled || notify_inotify
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# fix tests
echo "src/tracker-applet/tracker-applet-prefs.glade" >> po/POTFILES.in
}
-src_compile() {
+src_configure() {
local myconf=
if use gstreamer ; then
@@ -124,10 +106,7 @@ src_compile() {
$(use_enable gtk libtrackergtk) \
$(use_enable hal) \
$(use_enable jpeg exif) \
- $(use_enable pdf) \
- || die "configure failed"
-
- emake || die "build failed"
+ $(use_enable pdf)
}
src_install() {
diff --git a/app-misc/tracker/tracker-0.6.6.ebuild b/app-misc/tracker/tracker-0.6.6.ebuild
deleted file mode 100644
index 8dbe9973eeb2..000000000000
--- a/app-misc/tracker/tracker-0.6.6.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.6.6.ebuild,v 1.3 2009/03/30 02:02:05 loki_val Exp $
-
-inherit autotools eutils flag-o-matic linux-info
-
-DESCRIPTION="A tagging metadata database, search tool and indexer"
-HOMEPAGE="http://www.tracker-project.org/"
-SRC_URI="http://www.gnome.org/~jamiemcc/tracker/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="applet debug deskbar gnome gsf gstreamer gtk hal jpeg pdf xine kernel_linux"
-
-RDEPEND=">=dev-libs/glib-2.14.0
- >=x11-libs/pango-1.0.0
- =dev-libs/gmime-2.2*
- >=dev-libs/dbus-glib-0.71
- >=media-libs/libpng-1.2
- >=dev-db/qdbm-1.8
- >=dev-libs/libxml2-2.6
- >=dev-db/sqlite-3.4
- >=media-gfx/imagemagick-5.2.1
- applet? ( >=x11-libs/libnotify-0.4.3 )
- deskbar? ( >=gnome-extra/deskbar-applet-2.19 )
- gnome? (
- >=x11-libs/gtk+-2.8
- >=gnome-base/libgnome-2.14
- >=gnome-base/libgnomeui-2.14
- >=gnome-base/gnome-vfs-2.10
- >=gnome-base/gnome-desktop-2.14
- >=gnome-base/libglade-2.5
- )
- gsf? ( >=gnome-extra/libgsf-1.13 )
- gstreamer? ( >=media-libs/gstreamer-0.10 )
- !gstreamer? ( !xine? ( || ( media-video/totem media-video/mplayer ) ) )
- gtk? ( >=x11-libs/gtk+-2.8.20 )
- hal? ( >=sys-apps/hal-0.5 )
- jpeg? ( >=media-gfx/exif-0.6 )
- !kernel_linux? ( >=app-admin/gamin-0.1.7 )
- pdf? (
- >=x11-libs/cairo-1.0
- >=virtual/poppler-glib-0.5
- >=virtual/poppler-utils-0.5
- )
- xine? ( >=media-libs/xine-lib-1.0 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=sys-devel/gettext-0.14
- >=dev-util/pkgconfig-0.20"
-
-function notify_inotify() {
- ewarn
- ewarn "You should enable the INOTIFY support in your kernel."
- ewarn "Check the 'Inotify file change notification support' under the"
- ewarn "'File systems' option. It is marked as CONFIG_INOTIFY in the config"
- ewarn "Also enable 'Inotify support for userland' in under the previous"
- ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config."
- ewarn
- die 'missing CONFIG_INOTIFY'
-}
-
-function inotify_enabled() {
- linux_chkconfig_present INOTIFY && linux_chkconfig_present INOTIFY_USER
-}
-
-pkg_setup() {
- linux-info_pkg_setup
-
- if built_with_use --missing false 'dev-db/sqlite' 'nothreadsafe' ||
- ! built_with_use --missing true 'dev-db/sqlite' 'threadsafe' ; then
- eerror "You must build sqlite with threading support"
- die "dev-db/sqlite built without thread safety"
- fi
-
- if ! built_with_use 'media-gfx/imagemagick' 'png' ; then
- ewarn "You must build imagemagick with png"
- die "imagemagick needs png support"
- fi
-
- if use jpeg && ! built_with_use 'media-gfx/imagemagick' 'jpeg' ; then
- ewarn "You must build imagemagick with jpeg to get support for JPEG"
- die "imagemagick needs jpeg support"
- fi
-
- if use kernel_linux ; then
- inotify_enabled || notify_inotify
- fi
-}
-
-src_compile() {
- local myconf=
-
- if use gstreamer ; then
- myconf="${myconf} --enable-video-extractor=gstreamer"
- elif use xine ; then
- myconf="${myconf} --enable-video-extractor=xine"
- else
- myconf="${myconf} --enable-video-extractor=external"
- fi
-
- if use kernel_linux ; then
- myconf="${myconf} --enable-file-monitoring=inotify"
- else
- myconf="${myconf} --enable-file-monitoring=fam"
- fi
-
- econf ${myconf} \
- --disable-xmp --disable-unac \
- --enable-preferences --enable-external-qdbm \
- $(use_enable applet trackerapplet) \
- $(use_enable deskbar deskbar-applet auto) \
- $(use_enable debug debug-code) \
- $(use_enable gnome gui) \
- $(use_enable gsf) \
- $(use_enable gtk libtrackergtk) \
- $(use_enable hal) \
- $(use_enable jpeg exif) \
- $(use_enable pdf) \
- || die "configure failed"
-
- emake || die "build failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README
-}
diff --git a/app-misc/tracker/tracker-9999.ebuild b/app-misc/tracker/tracker-9999.ebuild
index 45e89d8ec852..552e81271068 100644
--- a/app-misc/tracker/tracker-9999.ebuild
+++ b/app-misc/tracker/tracker-9999.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-9999.ebuild,v 1.3 2009/03/30 02:02:05 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-9999.ebuild,v 1.4 2009/08/15 12:55:07 ssuominen Exp $
+EAPI=2
inherit autotools eutils flag-o-matic linux-info subversion
DESCRIPTION="A tagging metadata database, search tool and indexer"
@@ -20,8 +21,8 @@ RDEPEND=">=dev-libs/glib-2.14.0
>=dev-libs/dbus-glib-0.71
>=media-libs/libpng-1.2
>=dev-libs/libxml2-2.6
- >=dev-db/sqlite-3.4
- >=media-gfx/imagemagick-5.2.1
+ >=dev-db/sqlite-3.4[threadsafe]
+ >=media-gfx/imagemagick-5.2.1[png,jpeg?]
applet? ( >=x11-libs/libnotify-0.4.3 )
deskbar? ( >=gnome-extra/deskbar-applet-2.19 )
gnome? (
@@ -68,35 +69,19 @@ function inotify_enabled() {
pkg_setup() {
linux-info_pkg_setup
- if built_with_use --missing false 'dev-db/sqlite' 'nothreadsafe' ||
- ! built_with_use --missing true 'dev-db/sqlite' 'threadsafe' ; then
- eerror "You must build sqlite with threading support"
- die "dev-db/sqlite built without thread safety"
- fi
-
- if ! built_with_use 'media-gfx/imagemagick' 'png' ; then
- ewarn "You must build imagemagick with png"
- die "imagemagick needs png support"
- fi
-
- if use jpeg && ! built_with_use 'media-gfx/imagemagick' 'jpeg' ; then
- ewarn "You must build imagemagick with jpeg to get support for JPEG"
- die "imagemagick needs jpeg support"
- fi
-
if use kernel_linux ; then
inotify_enabled || notify_inotify
fi
}
-src_unpack() {
- subversion_src_unpack
+src_prepare() {
+ subversion_src_prepare
intltoolize --force || die "intltoolize failed"
eautoreconf
}
-src_compile() {
+src_configure() {
local myconf=
if use gstreamer ; then
@@ -124,10 +109,7 @@ src_compile() {
$(use_enable gtk libtrackergtk) \
$(use_enable hal) \
$(use_enable jpeg exif) \
- $(use_enable pdf) \
- || die "configure failed"
-
- emake || die "build failed"
+ $(use_enable pdf)
}
src_install() {
diff --git a/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild b/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild
index 5cc393479f6a..22e7b3d46ce1 100644
--- a/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild
+++ b/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild,v 1.4 2005/09/30 15:57:34 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild,v 1.5 2009/08/15 13:04:14 ssuominen Exp $
-inherit distutils eutils
+EAPI=2
+inherit distutils
DESCRIPTION="python script for downloading webcomics"
HOMEPAGE="http://collector.skumleren.net/"
@@ -13,17 +14,13 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
+RDEPEND="dev-lang/python[gdbm]"
+DEPEND="${RDEPEND}"
+
S=${WORKDIR}/collector-${PV}
DOCS="UPGRADE"
-pkg_setup() {
- if ! built_with_use dev-lang/python gdbm ; then
- eerror "You need to emerge python with USE=gdbm"
- die "re-emerge python with USE=gdbm"
- fi
-}
-
pkg_postinst() {
ewarn "If you are upgrading from an earlier version of Collector, please"
ewarn "read UPGRADE. This new version will not be able to use your old"
diff --git a/app-misc/wyrd/wyrd-1.4.4.ebuild b/app-misc/wyrd/wyrd-1.4.4.ebuild
index 90d84c1071fd..16fbaab653dc 100644
--- a/app-misc/wyrd/wyrd-1.4.4.ebuild
+++ b/app-misc/wyrd/wyrd-1.4.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.4.ebuild,v 1.2 2008/10/26 19:09:28 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.4.ebuild,v 1.3 2009/08/15 13:06:35 ssuominen Exp $
-inherit eutils
+EAPI=2
DESCRIPTION="Text-based front-end to Remind"
HOMEPAGE="http://pessimization.com/software/wyrd/"
@@ -14,27 +14,17 @@ KEYWORDS="amd64 ~ppc ~sparc x86"
IUSE="unicode"
DEPEND=">=dev-lang/ocaml-3.08
- sys-libs/ncurses
+ sys-libs/ncurses[unicode?]
>=x11-misc/remind-03.01"
RDEPEND=${DEPEND}
-pkg_setup() {
- use unicode || return 0
- if ! built_with_use sys-libs/ncurses unicode ; then
- eerror "To use unicode in wyrd you must build sys-libs/ncurses"
- eerror "with unicode support."
- die "Please rebuilt sys-libs/ncurses with unicode in USE!"
- fi
-}
-
-src_compile() {
- econf $(use_enable unicode utf8 ) || die "configure failed"
- emake || die "make failed"
+src_configure() {
+ econf \
+ $(use_enable unicode utf8)
}
src_install() {
- make DESTDIR="${D}" install || die "install died"
-
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc ChangeLog || die "dodoc failed"
dohtml doc/manual.html || die "dohtml failed"
}