summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-01 18:16:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-01 18:16:35 +0000
commit4d3262a9891e76f43e4c087ca5e1ebd1452564f7 (patch)
treef9d1878cd5b20327a4cbb867a69c96faad375d3d /app-office/karbon
parentStable on hppa (diff)
downloadhistorical-4d3262a9891e76f43e4c087ca5e1ebd1452564f7.tar.gz
historical-4d3262a9891e76f43e4c087ca5e1ebd1452564f7.tar.bz2
historical-4d3262a9891e76f43e4c087ca5e1ebd1452564f7.zip
Version bump.
Package-Manager: portage-2.1.2_rc2-r3
Diffstat (limited to 'app-office/karbon')
-rw-r--r--app-office/karbon/ChangeLog7
-rw-r--r--app-office/karbon/files/digest-karbon-1.6.13
-rw-r--r--app-office/karbon/karbon-1.6.1.ebuild52
3 files changed, 61 insertions, 1 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index 926f9f9cb6cb..63a81fd936b3 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.60 2006/12/01 01:51:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.61 2006/12/01 18:16:35 flameeyes Exp $
+
+*karbon-1.6.1 (01 Dec 2006)
+
+ 01 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> +karbon-1.6.1.ebuild:
+ Version bump.
01 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> -karbon-1.4.2.ebuild,
-karbon-1.5.1.ebuild:
diff --git a/app-office/karbon/files/digest-karbon-1.6.1 b/app-office/karbon/files/digest-karbon-1.6.1
new file mode 100644
index 000000000000..8296a0484c60
--- /dev/null
+++ b/app-office/karbon/files/digest-karbon-1.6.1
@@ -0,0 +1,3 @@
+MD5 f7b90b46b79019edc60761a6bff2d387 koffice-1.6.1.tar.bz2 56999028
+RMD160 ee4fa84a53f92035c0ab9427e0acb18feca701db koffice-1.6.1.tar.bz2 56999028
+SHA256 5505a6c54009dd0cb75a3770c3daa476154958f92692ca0748b1842d9cd6e728 koffice-1.6.1.tar.bz2 56999028
diff --git a/app-office/karbon/karbon-1.6.1.ebuild b/app-office/karbon/karbon-1.6.1.ebuild
new file mode 100644
index 000000000000..352b5c7c5743
--- /dev/null
+++ b/app-office/karbon/karbon-1.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-1.6.1.ebuild,v 1.1 2006/12/01 18:16:35 flameeyes Exp $
+
+MAXKOFFICEVER=${PV}
+KMNAME=koffice
+inherit kde-meta eutils
+
+DESCRIPTION="KOffice vector drawing application."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="$(deprange $PV $MAXKOFFICEVER app-office/koffice-libs)
+ >=media-gfx/imagemagick-5.5.2
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KMCOPYLIB="
+ libkformula lib/kformula
+ libkofficecore lib/kofficecore
+ libkofficeui lib/kofficeui
+ libkopainter lib/kopainter
+ libkopalette lib/kopalette
+ libkotext lib/kotext
+ libkwmf lib/kwmf
+ libkowmf lib/kwmf
+ libkstore lib/store"
+
+KMEXTRACTONLY="lib/"
+
+KMCOMPILEONLY="filters/liboofilter"
+
+KMEXTRA="filters/karbon"
+
+need-kde 3.4
+
+src_unpack() {
+ kde-meta_src_unpack unpack
+
+ # We need to compile liboofilter first
+ echo "SUBDIRS = liboofilter karbon" > $S/filters/Makefile.am
+
+ kde-meta_src_unpack makefiles
+}