summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2003-10-31 04:47:31 +0000
committerSteve Arnold <nerdboy@gentoo.org>2003-10-31 04:47:31 +0000
commit12ab149d8831fac7cab773cc69cc39b97ea34659 (patch)
treea4f9c402141cb14aed067aa10fb7f061bc1f7752 /app-pda
parentfix for bug #24215, be aware that it may break on non-Linux Portage. (diff)
downloadhistorical-12ab149d8831fac7cab773cc69cc39b97ea34659.tar.gz
historical-12ab149d8831fac7cab773cc69cc39b97ea34659.tar.bz2
historical-12ab149d8831fac7cab773cc69cc39b97ea34659.zip
initial bin ebuild of qtopia-desktop 1.6.2 for zaurus
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/qtopia-desktop-bin/ChangeLog8
-rw-r--r--app-pda/qtopia-desktop-bin/Manifest4
-rw-r--r--app-pda/qtopia-desktop-bin/files/digest-qtopia-desktop-bin-1.6.21
-rw-r--r--app-pda/qtopia-desktop-bin/metadata.xml6
-rw-r--r--app-pda/qtopia-desktop-bin/qtopia-desktop-bin-1.6.2.ebuild58
5 files changed, 77 insertions, 0 deletions
diff --git a/app-pda/qtopia-desktop-bin/ChangeLog b/app-pda/qtopia-desktop-bin/ChangeLog
new file mode 100644
index 000000000000..2b99dd9e8c32
--- /dev/null
+++ b/app-pda/qtopia-desktop-bin/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-pda/qtopia-desktop-bin
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/qtopia-desktop-bin/ChangeLog,v 1.1 2003/10/31 04:47:30 nerdboy Exp $
+
+*qtopia-desktop-bin-1.6.2 (30 Oct 2003)
+
+ 30 Oct 2003; <nerdboy@gentoo.org> qtopia-desktop-bin-1.6.2.ebuild:
+ Initial bin-ebuild of qtopia-desktop Zaurus sync app
diff --git a/app-pda/qtopia-desktop-bin/Manifest b/app-pda/qtopia-desktop-bin/Manifest
new file mode 100644
index 000000000000..097516d31d35
--- /dev/null
+++ b/app-pda/qtopia-desktop-bin/Manifest
@@ -0,0 +1,4 @@
+MD5 cf26741d3ad974ee37e8de5489df5ff9 metadata.xml 285
+MD5 ea017ea8049d84b3567404fc5f4b4b6d qtopia-desktop-bin-1.6.2.ebuild 1724
+MD5 5a1e067bab475d092125ee911de73a1c ChangeLog 300
+MD5 e47d4ed2b1a7b1876057de337ae540a4 files/digest-qtopia-desktop-bin-1.6.2 80
diff --git a/app-pda/qtopia-desktop-bin/files/digest-qtopia-desktop-bin-1.6.2 b/app-pda/qtopia-desktop-bin/files/digest-qtopia-desktop-bin-1.6.2
new file mode 100644
index 000000000000..5c4775f2f5b5
--- /dev/null
+++ b/app-pda/qtopia-desktop-bin/files/digest-qtopia-desktop-bin-1.6.2
@@ -0,0 +1 @@
+MD5 71bda30ff3a5a87e079b1ff127958039 qtopia-desktop-1.6.2-1rh9.i386.rpm 5899739
diff --git a/app-pda/qtopia-desktop-bin/metadata.xml b/app-pda/qtopia-desktop-bin/metadata.xml
new file mode 100644
index 000000000000..ead50e518d70
--- /dev/null
+++ b/app-pda/qtopia-desktop-bin/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>pda</herd>
+<longdescription>Qtopia Desktop is the sync app for qtopia on the Zaurus. It is not available in source form.</longdescription>
+</pkgmetadata>
diff --git a/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-1.6.2.ebuild b/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-1.6.2.ebuild
new file mode 100644
index 000000000000..ac167830cb25
--- /dev/null
+++ b/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-1.6.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/qtopia-desktop-bin/qtopia-desktop-bin-1.6.2.ebuild,v 1.1 2003/10/31 04:47:31 nerdboy Exp $
+
+IUSE="X"
+
+inherit virtualx
+
+BV=1.6.2-1
+QD="/opt/Qtopia"
+S="${WORKDIR}"
+
+DESCRIPTION="Qtopia Deskyop sync application for Zaurus PDA's"
+SRC_URI="ftp://ftp.trolltech.com/qtopia/desktop/RedHat9.0/qtopia-desktop-${BV}rh9.i386.rpm"
+HOMEPAGE="http://www.trolltech.com/download/qtopia/"
+
+DEPEND="app-arch/rpm2targz
+virtual/glibc"
+RDEPEND="virtual/x11"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~x86"
+RESTRICT="nomirror nostrip"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ TMPDIR=${T} rpm2targz ${DISTDIR}/qtopia-desktop-${BV}rh9.i386.rpm
+ tar xvzf qtopia-desktop-${BV}rh9.i386.tar.gz || die
+}
+
+src_install() {
+
+ dodir ${QD}
+ insinto ${QD}/qtopiadesktop/bin ; doins opt/Qtopia/qtopiadesktop/bin/*
+ insinto ${QD}/qtopiadesktop/doc/en ; doins opt/Qtopia/qtopiadesktop/doc/en/*
+ insinto ${QD}/qtopiadesktop/doc/de ; doins opt/Qtopia/qtopiadesktop/doc/de/*
+ insinto ${QD}/qtopiadesktop/doc ; doins opt/Qtopia/qtopiadesktop/doc/*
+ insinto ${QD}/qtopiadesktop/etc ; doins opt/Qtopia/qtopiadesktop/etc/*
+ insinto ${QD}/qtopiadesktop/plugins ; doins opt/Qtopia/qtopiadesktop/plugins/*
+ insinto ${QD}/lib ; doins opt/Qtopia/lib/*
+ exeinto ${QD}/bin ; doexe opt/Qtopia/bin/qtopiadesktop
+ dodir /etc/env.d
+ echo "PATH=${QD}/bin" > ${D}/etc/env.d/37qtopia-desktop-bin
+}
+
+pkg_postinst() {
+
+ einfo "******************************************************************"
+ einfo " Finished installing Qtopia Desktop into ${QD}"
+ einfo
+ einfo " To start Qtopia Desktop, run:"
+ einfo
+ einfo " $ qtopiadesktop"
+ einfo
+ einfo "******************************************************************"
+}