summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-04-23 08:20:25 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-04-23 08:20:25 +0000
commitfc8b71f9411e58bf4d5e29e61f07f04c53156ce4 (patch)
treeeff5967ef649f1050296cd25a9b58344a3e48f56 /app-sci/foldingathome
parentNew version of subversion. The old one is ancient (diff)
downloadhistorical-fc8b71f9411e58bf4d5e29e61f07f04c53156ce4.tar.gz
historical-fc8b71f9411e58bf4d5e29e61f07f04c53156ce4.tar.bz2
historical-fc8b71f9411e58bf4d5e29e61f07f04c53156ce4.zip
Fixes, closes #19709
Diffstat (limited to 'app-sci/foldingathome')
-rw-r--r--app-sci/foldingathome/ChangeLog6
-rw-r--r--app-sci/foldingathome/files/digest-foldingathome-3.241
-rw-r--r--app-sci/foldingathome/files/folding-init.d8
-rw-r--r--app-sci/foldingathome/foldingathome-3.24.ebuild15
4 files changed, 20 insertions, 10 deletions
diff --git a/app-sci/foldingathome/ChangeLog b/app-sci/foldingathome/ChangeLog
index e23c0d7d7713..90ca9e0b8667 100644
--- a/app-sci/foldingathome/ChangeLog
+++ b/app-sci/foldingathome/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/foldingathome
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/ChangeLog,v 1.3 2003/02/27 10:23:31 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/ChangeLog,v 1.4 2003/04/23 08:20:25 aliz Exp $
+
+ 23 Apr 2003; Daniel Ahlberg <aliz@gentoo.org> foldingathome-3.2.4.ebuild, files/folding-init.d :
+ Now has the version number in SRC_URI and also uses the newer client if we're running >=glibc-2.3.0.
+ Also updated init script, closes #19709.
*foldingathome-3.24 (27 Feb 2003)
diff --git a/app-sci/foldingathome/files/digest-foldingathome-3.24 b/app-sci/foldingathome/files/digest-foldingathome-3.24
deleted file mode 100644
index bb487acf3884..000000000000
--- a/app-sci/foldingathome/files/digest-foldingathome-3.24
+++ /dev/null
@@ -1 +0,0 @@
-MD5 df9c2a68e5a2b808daee0128d78ecde3 FAH3Console-Linux.exe 613632
diff --git a/app-sci/foldingathome/files/folding-init.d b/app-sci/foldingathome/files/folding-init.d
index f4dbefa1e15c..f2e2bbaea2a0 100644
--- a/app-sci/foldingathome/files/folding-init.d
+++ b/app-sci/foldingathome/files/folding-init.d
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/files/folding-init.d,v 1.2 2003/02/27 10:23:31 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/files/folding-init.d,v 1.3 2003/04/23 08:20:25 aliz Exp $
start() {
@@ -13,7 +13,9 @@ start() {
stop() {
ebegin "Stopping Folding@home"
- killall foldingathome
+ killall FahCore_78.exe > /dev/null
+ if ! $? ; then
+ killall foldingathome
+ fi
eend $?
}
-
diff --git a/app-sci/foldingathome/foldingathome-3.24.ebuild b/app-sci/foldingathome/foldingathome-3.24.ebuild
index 4e6bd86af48a..4ea83888bae0 100644
--- a/app-sci/foldingathome/foldingathome-3.24.ebuild
+++ b/app-sci/foldingathome/foldingathome-3.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/foldingathome-3.24.ebuild,v 1.1 2003/02/27 10:23:31 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/foldingathome/foldingathome-3.24.ebuild,v 1.2 2003/04/23 08:20:25 aliz Exp $
# no version number on this install dir since upgrades will be using same dir
# (data will be stored here too)
@@ -8,7 +8,8 @@ I="/opt/foldingathome"
DESCRIPTION="Help simulate protein folding at home"
HOMEPAGE="http://folding.stanford.edu/"
-SRC_URI="http://www.stanford.edu/group/pandegroup/release/FAH3Console-Linux.exe"
+SRC_URI="http://www.stanford.edu/group/pandegroup/release/FAH3Console-v${PV/.}-LinuxB.exe
+ http://www.stanford.edu/group/pandegroup/release/FAH3Console-v${PV/.}-Linux.exe"
SLOT="0"
LICENSE="as-is"
@@ -18,12 +19,16 @@ DEPEND=">=sys-apps/baselayout-1.8.0"
S="${WORKDIR}/${P}"
src_unpack() {
- mkdir ${P}
- cp ${DISTDIR}/FAH3Console-Linux.exe ${P}
+ mkdir -p ${S} ; cd ${S}
+ if has_version \>=glibc-2.3.0; then
+ cp ${DISTDIR}/FAH3Console-v${PV/.}-LinuxB.exe ${PN}
+ else
+ cp ${DISTDIR}/FAH3Console-v${PV/.}-Linux.exe ${PN}
+ fi
}
src_install() {
- exeinto ${I} ; newexe FAH3Console-Linux.exe foldingathome
+ exeinto ${I} ; doexe foldingathome
exeinto /etc/init.d ; newexe ${FILESDIR}/folding-init.d foldingathome
}