summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-05-24 12:46:18 +0000
committerChristian Birchinger <joker@gentoo.org>2003-05-24 12:46:18 +0000
commit34cdaebc959850ec7a120c8654a2210bf9ec3ada (patch)
tree8e5c298eebe94fd35d0e1e38271a045eb1dd1797 /app-shells
parentIncluded fixed gentoo completion (diff)
downloadhistorical-34cdaebc959850ec7a120c8654a2210bf9ec3ada.tar.gz
historical-34cdaebc959850ec7a120c8654a2210bf9ec3ada.tar.bz2
historical-34cdaebc959850ec7a120c8654a2210bf9ec3ada.zip
Included fixed gentoo completion
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/Manifest8
-rw-r--r--app-shells/bash-completion/bash-completion-20030505-r1.ebuild (renamed from app-shells/bash-completion/bash-completion-20030505.ebuild)2
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-20030505-r1 (renamed from app-shells/bash-completion/files/digest-bash-completion-20030505)0
-rw-r--r--app-shells/bash-completion/files/gentoo.completion32
4 files changed, 13 insertions, 29 deletions
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 707ea7847e73..81928b386c1c 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,10 +1,8 @@
-MD5 7acf9006fa4e601d1a1f6e7b8f105cdb ChangeLog 4112
-MD5 af3244685fb9d1d0268ad26de7c7be00 bash-completion-20030505.ebuild 1452
+MD5 70e6c2d3e99d0fd555e3c706ad5ec6f9 ChangeLog 4192
MD5 904d8397524aa1fca1a3eaac76a29980 bash-completion-20030327.ebuild 1199
-MD5 af3244685fb9d1d0268ad26de7c7be00 bash-completion-20030505-r1.ebuild 1452
+MD5 0636e3c6f09367f9d5e55d02ea857941 bash-completion-20030505-r1.ebuild 1455
MD5 c85a85bd33aac22ae4872c85733e581f files/README.gentoo 491
MD5 9b22241df7258cb9677cf9a1497e07c5 files/bash-completion 625
-MD5 86466a747ec82cd05ba511f06125c947 files/digest-bash-completion-20030505 76
MD5 1dffd8ac9c86af70eb6763385475b86f files/digest-bash-completion-20030327 76
MD5 86466a747ec82cd05ba511f06125c947 files/digest-bash-completion-20030505-r1 76
-MD5 e6f50cdea0fe986c0e41db1be95c9584 files/gentoo.completion 15215
+MD5 58c57aafa06a6e59c9f607bd90f68dde files/gentoo.completion 14919
diff --git a/app-shells/bash-completion/bash-completion-20030505.ebuild b/app-shells/bash-completion/bash-completion-20030505-r1.ebuild
index 4d60e5dba13e..a43362e577cd 100644
--- a/app-shells/bash-completion/bash-completion-20030505.ebuild
+++ b/app-shells/bash-completion/bash-completion-20030505-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030505.ebuild,v 1.2 2003/05/18 14:24:34 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030505-r1.ebuild,v 1.1 2003/05/24 12:46:08 joker Exp $
S=${WORKDIR}/${PN/-/_}
DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20030505 b/app-shells/bash-completion/files/digest-bash-completion-20030505-r1
index 944a25034898..944a25034898 100644
--- a/app-shells/bash-completion/files/digest-bash-completion-20030505
+++ b/app-shells/bash-completion/files/digest-bash-completion-20030505-r1
diff --git a/app-shells/bash-completion/files/gentoo.completion b/app-shells/bash-completion/files/gentoo.completion
index 4a79f8c2b3d0..e1fcd56da758 100644
--- a/app-shells/bash-completion/files/gentoo.completion
+++ b/app-shells/bash-completion/files/gentoo.completion
@@ -199,21 +199,7 @@ _emerge()
else
cd "${portagedir}"
grepcmd="grep -E ^${cur}.*"
- sedcmd="sed -e /CVS/d \
- -e /BUGS-TODO/d \
- -e /ChangeLog.*/d \
- -e /header.txt/d \
- -e /skel.build/d \
- -e /skel.ebuild/d \
- -e /distfiles/d \
- -e /eclass/d \
- -e /files/d \
- -e /incoming/d \
- -e /packages/d \
- -e /profiles/d \
- -e /scripts/d \
- -e /virtual-update/d \
- -e /current-packages/d"
+ sedcmd="sed -e /^[^-]*$/d"
if [ ${COMP_CWORD} -eq 1 ]; then
# If emerge hasn't been given any args yet, include "rsync"
@@ -303,7 +289,7 @@ complete -o default -F _ebuild ebuild
#
# rc-update completion command
#
-_rc-update()
+_rcupdate()
{
local cur prev initdir runlvdir origdir
origdir=${PWD}
@@ -325,12 +311,12 @@ _rc-update()
fi
return 0
}
-complete -F _rc-update rc-update
+complete -F _rcupdate rc-update
#
# gcc-config completion command
#
-_gcc-config()
+_gccconfig()
{
local cur curword numwords opts
COMPREPLY=()
@@ -368,9 +354,9 @@ _gcc-config()
COMPREPLY=($(compgen -W "${opts}" | grep ^$cur))
return 0
}
-complete -F _gcc-config gcc-config
+complete -F _gccconfig gcc-config
-_java-config()
+_javaconfig()
{
local cur curword numwords opts args arg spec flag sedcmd grepcmd
local multiplepkgs pkgs execopts
@@ -528,9 +514,9 @@ _java-config()
COMPREPLY=($(compgen -o nospace -W "${opts}" | grep ^${cur}))
return 0
}
-complete -o nospace -F _java-config java-config
+complete -o nospace -F _javaconfig java-config
-_opengl-update()
+_openglupdate()
{
local cur opts
COMPREPLY=()
@@ -553,4 +539,4 @@ _opengl-update()
echo ${COMPREPLY[@]})))
return 0
}
-complete -F _opengl-update opengl-update
+complete -F _openglupdate opengl-update