summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-05-29 03:57:40 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-05-29 03:57:40 +0000
commitff3823171cb5c10e418aeee67b526d29bd1bd08e (patch)
tree424e8c1a0cb47491c69975e8a307728d7cee790c /app-shells
parentInitial import, marked ~alpha and ~x86 (diff)
downloadhistorical-ff3823171cb5c10e418aeee67b526d29bd1bd08e.tar.gz
historical-ff3823171cb5c10e418aeee67b526d29bd1bd08e.tar.bz2
historical-ff3823171cb5c10e418aeee67b526d29bd1bd08e.zip
Initial import, marked ~alpha and ~x86
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/Manifest3
-rw-r--r--app-shells/ksh/files/digest-ksh-93.200304223
-rw-r--r--app-shells/ksh/ksh-93.20030422.ebuild101
3 files changed, 106 insertions, 1 deletions
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index 4e50b46e9a70..b69e999b65bf 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,2 +1,3 @@
-MD5 9d6b401778443294a648c28260ca01d5 ksh-93.20030422.ebuild 2927
+MD5 3731b18e1028c1c2f959362cd024cdb6 ksh-93.20030422.ebuild 3107
+MD5 5505f476c5ae16fbe73d36519a1831e5 ChangeLog 365
MD5 ae6a966c5c8702e7199266a3b73a9291 files/digest-ksh-93.20030422 206
diff --git a/app-shells/ksh/files/digest-ksh-93.20030422 b/app-shells/ksh/files/digest-ksh-93.20030422
new file mode 100644
index 000000000000..6ea50e872f14
--- /dev/null
+++ b/app-shells/ksh/files/digest-ksh-93.20030422
@@ -0,0 +1,3 @@
+MD5 ff404527ecdae4511d37dc1716055e45 INIT.2003-04-22.tgz 255836
+MD5 c80cc0be17484ad6868b07ab06877309 ast-ksh.2003-04-22.tgz 1429397
+MD5 a8288401b0a6984cac48864fc9a835b5 ast-ksh-locale.2003-04-22.tgz 516623
diff --git a/app-shells/ksh/ksh-93.20030422.ebuild b/app-shells/ksh/ksh-93.20030422.ebuild
new file mode 100644
index 000000000000..e6d9cb25471c
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20030422.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20030422.ebuild,v 1.1 2003/05/29 03:57:33 taviso Exp $
+
+RELEASE="2003-04-22"
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)."
+HOMEPAGE="http://www.kornshell.com/"
+
+inherit ccc eutils
+
+SRC_URI="http://www.research.att.com/~gsf/download/tgz/INIT.${RELEASE}.tgz
+ http://www.research.att.com/~gsf/download/tgz/ast-ksh.${RELEASE}.tgz
+ http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.${RELEASE}.tgz"
+
+LICENSE="ATT"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+IUSE="static nls"
+
+DEPEND="virtual/glibc
+ >=sys-apps/sed-4
+ !app-shells/pdksh"
+RDEPEND="virtual/glibc"
+
+S=${WORKDIR}
+
+src_unpack() {
+ # the AT&T build tools look in here for packages.
+ mkdir -p ${S}/lib/package/tgz
+
+ # move the packages into place.
+ cp ${DISTDIR}/ast-ksh.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
+ use nls && {
+ cp ${DISTDIR}/ast-ksh-locale.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
+ }
+
+ # INIT provides the basic tools to start building.
+ cd ${S}; unpack INIT.${RELEASE}.tgz || die
+
+ # `package read` will unpack any tarballs put in place.
+ ${S}/bin/package read || die
+}
+
+src_compile() {
+ # users who prefer ksh as there regular shell
+ # may want to make it static, so it can be used
+ # in the event of fs failure, for example
+ # where shared libraries are not available
+ use static && append-ldflags -static
+
+ # just a quick message for any users who inadvertantly
+ # typed `emerge ksh` but actually wanted `emerge pdksh`
+ ewarn "This ebuild will install the original AT&T Korn Shell"
+ ewarn "By David Korn, if you were looking for PDKSH, the Public"
+ ewarn "Domain Korn SHell, please cancel this emerge and then"
+ ewarn "emerge pdksh."
+ sleep 3
+
+ # set the optimisations for the build process
+ export CCFLAGS="${CFLAGS}"
+ cd ${S}; ./bin/package only make ast-ksh CC=${CC:-gcc} || true
+
+ # if we set any optimisations, linking will fail.
+ # but this isnt a problem, the optimisations will have already
+ # been applied to the object files, we just need to link
+ # them.
+ einfo "Dont worry about any linker errors above, i need to rerun"
+ einfo "the build to complete the linking process..."
+ sleep 2 ; unset CCFLAGS
+
+ # re-run to finish linking.
+ ./bin/package only make ast-ksh CC=${CC:-gcc} || die "sorry, build failed."
+
+ # install the optional locale data.
+ # heh, check out locale fudd, or piglatin :)
+ #
+ # "Too many symbowic winks in paf name twavewsal"
+
+ # david korn is a funny guy! :)
+ use nls && {
+ cd ${S}; ./bin/package only make ast-ksh-locale CC=${CC:-gcc}
+ }
+}
+
+src_install() {
+ # check where the build scripts put them
+ local my_arch="${S}/arch/$(${S}/bin/package)"
+ exeinto /bin
+ doexe ${my_arch}/bin/ok/ksh
+ # i doubt anyone is fanatical enough to use
+ # this as /bin/sh.
+ mv ${my_arch}/man/man1/sh.1 ${my_arch}/man/man1/ksh.1
+ doman ${my_arch}/man/man1/ksh.1
+ dodoc ${S}/lib/package/LICENSES/ast
+ dodoc ${S}/lib/package/gen/ast-ksh.txt
+ use nls && {
+ dodir /usr/share
+ mv ${S}/share/lib/locale ${D}/usr/share
+ }
+}