summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-09-13 21:42:16 +0000
committerAron Griffis <agriffis@gentoo.org>2006-09-13 21:42:16 +0000
commit9e3cfbaa842be43f2388e88f55d46f6ab2397197 (patch)
tree3e3dc2ea3bbad06330b2d6999b1beebaf382d58a /app-vim
parentChanged SRC_URI to point to gentoo mirrors. (diff)
downloadhistorical-9e3cfbaa842be43f2388e88f55d46f6ab2397197.tar.gz
historical-9e3cfbaa842be43f2388e88f55d46f6ab2397197.tar.bz2
historical-9e3cfbaa842be43f2388e88f55d46f6ab2397197.zip
Bump to 4.1 (from 4.0_beta3). Remove 4.0_beta3, 4.0_beta2, 4.0_beta1, 3.4
Package-Manager: portage-2.1.1_pre5-r2
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/taglist/ChangeLog9
-rw-r--r--app-vim/taglist/files/digest-taglist-3.4-r12
-rw-r--r--app-vim/taglist/files/digest-taglist-4.13
-rw-r--r--app-vim/taglist/taglist-4.1.ebuild24
4 files changed, 37 insertions, 1 deletions
diff --git a/app-vim/taglist/ChangeLog b/app-vim/taglist/ChangeLog
index 788db9f9e5a1..906d7d205fa7 100644
--- a/app-vim/taglist/ChangeLog
+++ b/app-vim/taglist/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/taglist
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/taglist/ChangeLog,v 1.43 2006/02/21 04:32:13 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/taglist/ChangeLog,v 1.44 2006/09/13 21:42:16 agriffis Exp $
+
+*taglist-4.1 (13 Sep 2006)
+
+ 13 Sep 2006; Aron Griffis <agriffis@gentoo.org> -taglist-3.4.ebuild,
+ -taglist-4.0_beta1.ebuild, -taglist-4.0_beta2.ebuild,
+ -taglist-4.0_beta3.ebuild, +taglist-4.1.ebuild:
+ Bump to 4.1 (from 4.0_beta3). Remove 4.0_beta3, 4.0_beta2, 4.0_beta1, 3.4
21 Feb 2006; Jeroen Roovers <jer@gentoo.org> taglist-4.0_beta3.ebuild:
Marked ~hppa.
diff --git a/app-vim/taglist/files/digest-taglist-3.4-r1 b/app-vim/taglist/files/digest-taglist-3.4-r1
index 00c56e0cff56..995aa0c9a410 100644
--- a/app-vim/taglist/files/digest-taglist-3.4-r1
+++ b/app-vim/taglist/files/digest-taglist-3.4-r1
@@ -1 +1,3 @@
MD5 2c62fb9d947c85bee69dfd12eb84dc0c taglist-3.4.tar.bz2 24968
+RMD160 4c49b647fb55c4d8f4c334a852cfc7b89929659a taglist-3.4.tar.bz2 24968
+SHA256 65eb2630fa20f4c530bf4f4de541a61dff8b35aee5ed19106cb7b2d0223173fa taglist-3.4.tar.bz2 24968
diff --git a/app-vim/taglist/files/digest-taglist-4.1 b/app-vim/taglist/files/digest-taglist-4.1
new file mode 100644
index 000000000000..99337c79729c
--- /dev/null
+++ b/app-vim/taglist/files/digest-taglist-4.1
@@ -0,0 +1,3 @@
+MD5 9d19d5e92ea685f0c95653a16fb6320c taglist-4.1.tar.bz2 37063
+RMD160 ebf1981e9073f6c4a68c3556e266e43deb5775c0 taglist-4.1.tar.bz2 37063
+SHA256 ad7c8a86daba414a97435e14c56d37528d2e9702a0eb5273a9f952655cf3fc2b taglist-4.1.tar.bz2 37063
diff --git a/app-vim/taglist/taglist-4.1.ebuild b/app-vim/taglist/taglist-4.1.ebuild
new file mode 100644
index 000000000000..5f57503f427e
--- /dev/null
+++ b/app-vim/taglist/taglist-4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/taglist/taglist-4.1.ebuild,v 1.1 2006/09/13 21:42:16 agriffis Exp $
+
+inherit vim-plugin eutils
+
+DESCRIPTION="vim plugin: ctags-based source code browser"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=273"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="taglist-intro"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-3.4-ebuilds.patch
+ [[ -f plugin/${PN}.vim.orig ]] && rm plugin/${PN}.vim.orig
+}
+