summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-02-28 10:18:04 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-02-28 10:18:04 +0000
commite4b314c9e7fd47a431130442da15167a8df16a84 (patch)
treeedb2c01ace6840a17733220b890969c71a0cf13e /dev-embedded/tigcc
parentAdded to ~ppc. (diff)
downloadhistorical-e4b314c9e7fd47a431130442da15167a8df16a84.tar.gz
historical-e4b314c9e7fd47a431130442da15167a8df16a84.tar.bz2
historical-e4b314c9e7fd47a431130442da15167a8df16a84.zip
Version bump as per bug #82335. Many thanks to Robert Führicht
Package-Manager: portage-2.0.51.17
Diffstat (limited to 'dev-embedded/tigcc')
-rw-r--r--dev-embedded/tigcc/ChangeLog8
-rw-r--r--dev-embedded/tigcc/Manifest18
-rw-r--r--dev-embedded/tigcc/files/digest-tigcc-0.96_beta25
-rw-r--r--dev-embedded/tigcc/tigcc-0.96_beta2.ebuild229
4 files changed, 256 insertions, 4 deletions
diff --git a/dev-embedded/tigcc/ChangeLog b/dev-embedded/tigcc/ChangeLog
index dba6f268b936..7b794bdc7dd6 100644
--- a/dev-embedded/tigcc/ChangeLog
+++ b/dev-embedded/tigcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/tigcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/tigcc/ChangeLog,v 1.7 2005/02/17 17:13:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/tigcc/ChangeLog,v 1.8 2005/02/28 10:18:04 dragonheart Exp $
+
+*tigcc-0.96_beta2 (28 Feb 2005)
+
+ 28 Feb 2005; Daniel Black <dragonheart@gentoo.org> +tigcc-0.96_beta2.ebuild:
+ Version bump as per bug #82335. Many thanks to Robert Führicht
+ <the_master_of_disaster@gmx.at>
17 Feb 2005; Robin H. Johnson <robbat2@gentoo.org> tigcc-0.95-r2.ebuild,
tigcc-0.95_p3.ebuild:
diff --git a/dev-embedded/tigcc/Manifest b/dev-embedded/tigcc/Manifest
index 28d377ddb72c..ba8339021411 100644
--- a/dev-embedded/tigcc/Manifest
+++ b/dev-embedded/tigcc/Manifest
@@ -1,7 +1,19 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 420df847a3db1c4969aff20243f656dd metadata.xml 165
+MD5 c4227eb67187cd03c84f4526ef549b67 tigcc-0.96_beta2.ebuild 6432
+MD5 f53793cea997bd546537d4462413c6cc ChangeLog 1408
MD5 3a8b30a23eebff88f4772ea1d8120987 tigcc-0.95-r2.ebuild 6495
MD5 ab3a26d7b8a324524371943f5425e13b tigcc-0.95_p3.ebuild 6493
-MD5 1bd2f9f0111b38d1578b988c6f0b819b ChangeLog 1192
-MD5 420df847a3db1c4969aff20243f656dd metadata.xml 165
-MD5 627b7e86641edb82ffa0702ff65de4c1 files/a68k-fix.patch 625
MD5 75b1dd6ba9dd67df855f5d0a3165fd06 files/digest-tigcc-0.95-r2 315
+MD5 e161f0140b76a6dc3981581bc5103585 files/digest-tigcc-0.96_beta2 318
+MD5 627b7e86641edb82ffa0702ff65de4c1 files/a68k-fix.patch 625
MD5 1ea537485d88f982402fa3bf8930fd64 files/digest-tigcc-0.95_p3 315
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.0 (GNU/Linux)
+
+iD8DBQFCIu/nmdTrptrqvGERAq0dAJ9r2ABq0tGbt1tU8UZlPLh975G2AACfRk8b
+GF+0nWIYKOv2da7A4Ui0lSA=
+=7C6n
+-----END PGP SIGNATURE-----
diff --git a/dev-embedded/tigcc/files/digest-tigcc-0.96_beta2 b/dev-embedded/tigcc/files/digest-tigcc-0.96_beta2
new file mode 100644
index 000000000000..dc4c8e4103f0
--- /dev/null
+++ b/dev-embedded/tigcc/files/digest-tigcc-0.96_beta2
@@ -0,0 +1,5 @@
+MD5 afdb56ddc1537922883b10aed1a0d353 tigcc-0.96_beta2.tar.bz2 3295616
+MD5 f878a455b14b3830aaf2da0a17f003c0 gcc-core-3.3.3.tar.bz2 11553433
+MD5 624e6b74983ac6b2960edaf2d522ca58 binutils-2.15.tar.bz2 11515075
+MD5 cdf21c9161d140468929473723b9c48f libfargo.zip 14658
+MD5 4c9eea1d6d2a6ab967e81b57a6021e84 flashosa.zip 2397
diff --git a/dev-embedded/tigcc/tigcc-0.96_beta2.ebuild b/dev-embedded/tigcc/tigcc-0.96_beta2.ebuild
new file mode 100644
index 000000000000..4dff1158d454
--- /dev/null
+++ b/dev-embedded/tigcc/tigcc-0.96_beta2.ebuild
@@ -0,0 +1,229 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/tigcc/tigcc-0.96_beta2.ebuild,v 1.1 2005/02/28 10:18:04 dragonheart Exp $
+
+inherit eutils
+
+BASE_GCC="3.3.3"
+BASE_BINUTILS="2.15"
+GCC_VER=${BASE_GCC:0:3}
+BIN_VER=${BASE_BINUTILS:0:4}
+ENV_FILE=${D}/etc/env.d/99tigcc
+S=${WORKDIR}
+DESCRIPTION="Cross compiler for Texas Instruments TI-89, TI-92(+) and V200 calculators"
+HOMEPAGE="http://tigcc.ticalc.org"
+
+# mirror://gentoo/${P}.tar.bz2 comes from http://tigcc.ticalc.org/linux/tigcc_src.tar.bz2
+# which isn't that reliable
+
+SRC_URI="mirror://gentoo/${PF}.tar.bz2
+ mirror://gnu/gcc/releases/gcc-${BASE_GCC}/gcc-core-${BASE_GCC}.tar.bz2
+ mirror:/kernel/linux/devel/binutils/binutils-${BASE_BINUTILS}.tar.bz2
+ http://members.chello.at/gerhard.kofler/kevin/ti89prog/libfargo.zip
+ http://members.chello.at/gerhard.kofler/kevin/ti89prog/flashosa.zip"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE="doc"
+
+DEPEND="virtual/libc
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ >=sys-devel/bison-1.875"
+
+src_unpack() {
+ unpack ${A}
+ # start by patching binutils and gcc
+ cd ${WORKDIR}/binutils-${BASE_BINUTILS}
+ epatch ${S}/sources/gcc/gas-${BIN_VER}-tigcc-*.diff
+
+ cd ${WORKDIR}/gcc-${BASE_GCC}
+ epatch ${S}/sources/gcc/gcc-${BASE_GCC}-tigcc-*.diff
+
+ # create build directories for binutils and gcc
+ mkdir -p ${WORKDIR}/build/binutils
+ mkdir ${WORKDIR}/build/gcc
+
+ # Workaround for non-existing directories
+ sed -ie '/SUBDIRS =/d' ${WORKDIR}/binutils-${BASE_BINUTILS}/gas/Makefile.in
+}
+
+src_compile() {
+ # build binutils
+ cd ${WORKDIR}/build/binutils
+ CFLAGS="$CFLAGS" ${WORKDIR}/binutils-${BASE_BINUTILS}/configure \
+ --disable-serial-configure --target=m68k-coff --disable-shared \
+ --enable-static --disable-multilib --disable-nls \
+ || die "binutils configure"
+ emake || die "gas"
+ # build gcc
+ cd ${WORKDIR}/build/gcc
+
+ CFLAGS="$CFLAGS" ${WORKDIR}/gcc-${BASE_GCC}/configure --target=m68k-coff \
+ --with-gnu-as --with-as=${WORKDIR}/build/binutils/gas/as-new --with-gnu-ld \
+ --disable-nls --disable-multilib --disable-shared --enable-static \
+ --disable-threads \
+ || die "gcc - configure"
+ # GCC compilations _is intended_ to fail on a certain point,
+ # don't worry about that.
+ emake
+
+ # build a68k assembler
+ cd ${S}/sources/a68k
+ emake -e || die "a68k"
+
+ # build ld-tigcc linker
+ cd ${S}/sources/ld-tigcc
+ emake -e || die "ld-tigcc"
+
+ # build tigcc front-end
+ cd ${S}/sources/tigcc/src
+ emake -e || die "tigcc"
+
+ # build tprbuilder (TIGCC project builder)
+ cd ${S}/sources/tprbuilder/src
+ emake -e || die "trpbuilder"
+
+ # build patcher (object file patcher)
+ cd ${S}/sources/patcher/src
+ emake -e || die "patcher"
+
+ # build parser
+ cd ${S}/sources/parser/src
+ emake -e || die "parser"
+
+ # build tict tool suite
+ cd ${S}/tt
+ CFLAGS="${CFLAGS}" ./makelinux.sh || die "tict tool suite"
+}
+
+src_install() {
+ into /usr
+ dodir /usr/bin
+
+ # install documentation
+ if use doc ; then
+ # patch the script that launches the documentation
+ # browser to point to the correct location
+ sed "s:\$TIGCC/doc:/usr/share/doc/${P}:g" \
+ ${S}/tigcclib/doc/converter/tigccdoc \
+ > ${S}/tigcclib/doc/converter/tigccdoc.new
+ cd ${S}/tigcclib/doc/converter
+ newbin tigccdoc.new tigccdoc
+ cd ${S}/tigcclib/doc
+ dohtml -r html/*.html
+ cp html/qt-assistant.adp ${D}/usr/share/doc/${PF}/html
+
+ cd ${S}/sources/a68k
+ docinto a68k
+ dodoc docs/*.txt
+ fi
+
+ dodir /usr/share/doc/${PF}
+ cd ${S}
+ dodoc AUTHORS BUGS CHANGELOG COPYING DIRECTORIES HOWTO \
+ INSTALL README README.linux README.osX
+
+ cd ${S}/sources/tigcc
+ docinto tigcc
+ dodoc AUTHORS COPYING ChangeLog README
+
+ cd ${S}/sources/tprbuilder
+ docinto tprbuilder
+ dodoc AUTHORS COPYING ChangeLog README
+
+ cd ${S}/sources/patcher
+ docinto patcher
+ dodoc AUTHORS COPYING ChangeLog README
+
+ cd ${S}/sources/parser
+ docinto parser
+ dodoc AUTHORS COPYING ChangeLog README
+
+ cd ${S}/tt
+ docinto tools
+ dodoc history.txt linux_readme.txt readme.txt tooldocs.txt
+
+ exeinto /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}
+ # install gcc
+ cd ${WORKDIR}/build/gcc
+ doexe gcc/cc1
+ newexe gcc/xgcc gcc
+ dosym /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/gcc \
+ /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/ti-linux-gnu-gcc
+
+ # install gas
+ # exeinto /usr/ti-linux-gnu/bin <-- a symlink will be
+ # created so that gas resides in /usr/ti-linux-gnu/bin too
+ cd ${WORKDIR}/build/binutils
+ newexe gas/as-new as
+
+ # install a68k
+ cd ${S}/sources/a68k
+ newexe A68k a68k
+
+ # install ld-tigcc
+ cd ${S}/sources/ld-tigcc
+ doexe ld-tigcc
+ doexe ar-tigcc
+
+ # install tigcc
+ cd ${S}/sources/tigcc/src
+ doexe tigcc
+ dosym /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/tigcc \
+ /usr/ti-linux-gnu/tigcc-bin/${GCC_VER}/ti-linux-gnu-tigcc
+
+ # install tprbuilder
+ cd ${S}/sources/tprbuilder/src
+ doexe tprbuilder
+
+ # install patcher
+ cd ${S}/sources/patcher/src
+ doexe patcher
+
+ # install parser
+ cd ${S}/sources/parser/src
+ doexe parser
+
+ # install tict tool suite
+ cd ${S}/tt
+ doexe linuxbin/*
+
+ # install header files
+ dodir /usr/include/tigcc
+ cp -R ${S}/tigcclib/include/* ${D}/usr/include/tigcc
+ dosym /usr/include/tigcc/asm/os.h /usr/include/tigcc/asm/OS.h
+
+ insinto /usr/lib/gcc-lib/ti-linux-gnu/${GCC_VER}
+ # install library
+ cd ${S}/tigcclib
+ doins lib/*
+ cd ${WORKDIR}
+ doins flashos.a
+ doins fargo.a
+
+ dodir /usr/share/tigcc
+ # copy example programs
+ # cp -r ${S}/examples ${D}/usr/share/tigcc
+
+ # create TIGCC env variable
+ dodir /etc/env.d
+ # echo -e "TIGCC=\"/usr/ti-linux-gnu/tigcc-bin/${GCC_VER}\"" >> ${ENV_FILE}
+ # echo -e "CC=\"tigcc\"" >> ${ENV_FILE}
+ echo -e "TIGCC=\"/usr/ti-linux-gnu\"" >> ${ENV_FILE}
+ echo -e "PATH=\"/usr/ti-linux-gnu/tigcc-bin/${GCC_VER}:/usr/ti-linux-gnu/bin\"" >> ${ENV_FILE}
+ echo -e "ROOTPATH=\"/usr/ti-linux-gnu/tigcc-bin/${GCC_VER}:/usr/ti-linux-gnu/bin\"" >> ${ENV_FILE}
+ echo -e "LDPATH=\"/usr/lib/gcc-lib/ti-linux-gnu/${GCC_VER}\"" >> ${ENV_FILE}
+
+ # a cross-compiling gcc with hard-coded names has been built.
+ # therefore, we must place some symlinks.
+ dosym /usr/include/tigcc /usr/ti-linux-gnu/include
+ dosym /usr/lib/gcc-lib/ti-linux-gnu/${GCC_VER} /usr/ti-linux-gnu/lib
+ dosym /usr/share/doc/${PF} /usr/ti-linux-gnu/doc
+ dosym /usr/ti-linux-gnu/tigcc-bin/${GCC_VER} /usr/ti-linux-gnu/bin
+}
+
+pkg-postinst() {
+ env-update && source /etc/profile
+}